summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/volume_key
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-21 03:34:39 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:54 +0200
commitb268e84f04a1d1e6c6924fdec031294fea215e6d (patch)
treed6d8bbb0c4d726ed6c83ead0fb944098d76ff2fb /meta-oe/recipes-extended/volume_key
parentd973a83c36f5efe878a542270ad994f16059cee0 (diff)
downloadmeta-openembedded-b268e84f04a1d1e6c6924fdec031294fea215e6d.tar.gz
volume-key: add recipe 0.3.9
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/volume_key')
-rw-r--r--meta-oe/recipes-extended/volume_key/files/0001-explicitly-support-python3-by-pkg-config.patch56
-rw-r--r--meta-oe/recipes-extended/volume_key/volume-key_0.3.9.bb34
2 files changed, 90 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/volume_key/files/0001-explicitly-support-python3-by-pkg-config.patch b/meta-oe/recipes-extended/volume_key/files/0001-explicitly-support-python3-by-pkg-config.patch
new file mode 100644
index 000000000..03edb1390
--- /dev/null
+++ b/meta-oe/recipes-extended/volume_key/files/0001-explicitly-support-python3-by-pkg-config.patch
@@ -0,0 +1,56 @@
1From 18415c0b4c6e50ed9b99dfdae8d210590d0ab72e Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 28 Apr 2017 04:50:30 -0400
4Subject: [PATCH] explicitly support python3 by pkg-config
5
6The PYTHON_CPPFLAGS and -lpython$(PYTHON_VERSION) is hardcoded,
7use pkg-config to replace
8
9Upstream-Status: Inappropriate [wr-installer specific]
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 Makefile.am | 5 ++---
14 configure.ac | 2 ++
15 2 files changed, 4 insertions(+), 3 deletions(-)
16
17diff --git a/Makefile.am b/Makefile.am
18index 4569bbf..7a8daf4 100644
19--- a/Makefile.am
20+++ b/Makefile.am
21@@ -20,7 +20,6 @@ ACLOCAL_AMFLAGS = -I m4
22 AM_CPPFLAGS = $(blkid_CFLAGS) $(glib_CFLAGS) $(GPGME_CFLAGS) \
23 $(libcryptsetup_CFLAGS) $(nss_CFLAGS)
24 LOCALEDIR_CPPFLAGS = -DLOCALEDIR='"$(localedir)"'
25-PYTHON_CPPFLAGS = -I/usr/include/python$(PYTHON_VERSION)
26
27 ## Targets
28 SUBDIRS = po
29@@ -63,9 +62,9 @@ lib_libvolume_key_la_LIBADD = $(blkid_LIBS) $(glib_LIBS) $(GPGME_LIBS) \
30 $(LTLIBINTL) $(libcryptsetup_LIBS) $(nss_LIBS)
31
32 python__volume_key_la_SOURCES = python/volume_key_wrap.c
33-python__volume_key_la_CPPFLAGS = $(AM_CPPFLAGS) $(PYTHON_CPPFLAGS)
34+python__volume_key_la_CPPFLAGS = $(AM_CPPFLAGS) $(python3_CFLAGS)
35 python__volume_key_la_LDFLAGS = -module -avoid-version $(glib_LIBS)
36-python__volume_key_la_LIBADD = lib/libvolume_key.la -lpython$(PYTHON_VERSION) \
37+python__volume_key_la_LIBADD = lib/libvolume_key.la $(python3_LIBS) \
38 $(glib_LIBS) $(nss_LIBS)
39
40 src_volume_key_SOURCES = src/volume_key.c
41diff --git a/configure.ac b/configure.ac
42index ff35dd0..0928a6c 100644
43--- a/configure.ac
44+++ b/configure.ac
45@@ -27,6 +27,8 @@ AM_INIT_AUTOMAKE([no-dist-gzip dist-xz no-define subdir-objects -Wall])
46 AC_PROG_CC
47 AM_PROG_CC_C_O
48 LT_INIT([disable-static])
49+
50+PKG_CHECK_MODULES(python3, [python3])
51 AM_PATH_PYTHON
52
53 dnl Not gpg2, it cannot receive passphrases from gpgme
54--
552.8.1
56
diff --git a/meta-oe/recipes-extended/volume_key/volume-key_0.3.9.bb b/meta-oe/recipes-extended/volume_key/volume-key_0.3.9.bb
new file mode 100644
index 000000000..febf3f256
--- /dev/null
+++ b/meta-oe/recipes-extended/volume_key/volume-key_0.3.9.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "The volume_key project provides a libvolume_key, a library for manipulating \
2storage volume encryption keys and storing them separately from volumes, and an \
3associated command-line tool, named volume_key."
4LICENSE = "GPLv2"
5SECTION = "devel/lib"
6
7HOMEPAGE = "https://pagure.io/volume_key"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "https://releases.pagure.org/volume_key/volume_key-${PV}.tar.xz \
12 file://0001-explicitly-support-python3-by-pkg-config.patch \
13"
14SRC_URI[md5sum] = "a2d14931177c660e1f3ebbcf5f47d8e2"
15SRC_URI[sha256sum] = "450a54fe9bf56acec6850c1e71371d3e4913c9ca1ef0cdc3a517b4b6910412a6"
16
17SRCNAME = "volume_key"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit autotools python3native gettext
21
22DEPENDS += " \
23 util-linux \
24 glib-2.0 \
25 cryptsetup \
26 nss \
27 gpgme \
28"
29
30RDEPENDS_python3-${PN} += "${PN}"
31
32PACKAGES += "python3-${PN}"
33FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
34