diff options
author | Brendan Le Foll <brendan.le.foll@intel.com> | 2018-02-21 14:50:42 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-01 16:12:55 -0800 |
commit | f988ce34a84eac5919a95b1726aca7b97ab2d182 (patch) | |
tree | 950d086c07d4cd1041825ad4574287b1ff4971d3 /meta-oe/recipes-extended/upm | |
parent | efc2e0837ea101bf86b4b7b162a459cbf19a9cfb (diff) | |
download | meta-openembedded-f988ce34a84eac5919a95b1726aca7b97ab2d182.tar.gz |
upm: Update recipe to use v1.6.0
ads1x15 patch is no longer required as it has been merged upstream
Signed-off-by: Brendan Le Foll <brendan.le.foll@intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/upm')
-rw-r--r-- | meta-oe/recipes-extended/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch | 54 | ||||
-rw-r--r-- | meta-oe/recipes-extended/upm/upm_git.bb | 5 |
2 files changed, 2 insertions, 57 deletions
diff --git a/meta-oe/recipes-extended/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch b/meta-oe/recipes-extended/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch deleted file mode 100644 index c617d14a1..000000000 --- a/meta-oe/recipes-extended/upm/files/ads1x15-fixed-case-logic-in-getThresh-function.patch +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | From c64d04d084f47b4cb3e1cdee6e96348fcc6a756e Mon Sep 17 00:00:00 2001 | ||
2 | From: Mihai Tudor Panu <mihai.tudor.panu@intel.com> | ||
3 | Date: Tue, 30 May 2017 15:14:09 -0700 | ||
4 | Subject: [PATCH 1/1] ads1x15: fixed case logic in getThresh() function | ||
5 | |||
6 | Signed-off-by: Mihai Tudor Panu <mihai.tudor.panu@intel.com> | ||
7 | |||
8 | Upstream-Status: Backported [c64d04d084f47b4cb3e1cdee6e96348fcc6a756e] | ||
9 | |||
10 | Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> | ||
11 | |||
12 | --- | ||
13 | src/ads1x15/ads1x15.cxx | 4 ++-- | ||
14 | src/ads1x15/ads1x15.hpp | 2 +- | ||
15 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/src/ads1x15/ads1x15.cxx b/src/ads1x15/ads1x15.cxx | ||
18 | index 35782709..47701b2a 100644 | ||
19 | --- a/src/ads1x15/ads1x15.cxx | ||
20 | +++ b/src/ads1x15/ads1x15.cxx | ||
21 | @@ -116,7 +116,7 @@ ADS1X15::setContinuous(bool mode){ | ||
22 | |||
23 | float | ||
24 | ADS1X15::getThresh(ADSTHRESH reg){ | ||
25 | - if( THRESH_HIGH && THRESH_LOW) return getLastSample(reg); | ||
26 | + if(reg == THRESH_HIGH || reg == THRESH_LOW) return getLastSample(reg); | ||
27 | else return 0.0; | ||
28 | } | ||
29 | |||
30 | @@ -137,7 +137,7 @@ ADS1X15::setThresh(ADSTHRESH reg, float value){ | ||
31 | case 2: | ||
32 | case 3: | ||
33 | set_value = value / getMultiplier(); | ||
34 | - set_value = set_value << m_bitShift; | ||
35 | + set_value = set_value << m_bitShift; | ||
36 | if(i2c->writeWordReg(reg, swapWord(set_value)) != mraa::SUCCESS){ | ||
37 | throw std::runtime_error(std::string(__FUNCTION__) + ": I2c.write() failed"); | ||
38 | return; | ||
39 | diff --git a/src/ads1x15/ads1x15.hpp b/src/ads1x15/ads1x15.hpp | ||
40 | index 7524572d..efd8c8ec 100644 | ||
41 | --- a/src/ads1x15/ads1x15.hpp | ||
42 | +++ b/src/ads1x15/ads1x15.hpp | ||
43 | @@ -390,7 +390,7 @@ namespace upm { | ||
44 | * @param reg ADSTHRES enum value. | ||
45 | * Returns 0.0 unless THRESH_HIGH or THRESH_LOW requested. | ||
46 | */ | ||
47 | - float getThresh(ADSTHRESH reg = THRESH_LOW); | ||
48 | + float getThresh(ADSTHRESH reg = THRESH_DEFAULT); | ||
49 | |||
50 | /** | ||
51 | * Sets threshold levels or configures for conversion ready | ||
52 | -- | ||
53 | 2.11.0 | ||
54 | |||
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb index a5c2bb321..d742a5e46 100644 --- a/meta-oe/recipes-extended/upm/upm_git.bb +++ b/meta-oe/recipes-extended/upm/upm_git.bb | |||
@@ -7,12 +7,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66493d54e65bfc12c7983ff2e884f37f" | |||
7 | 7 | ||
8 | DEPENDS = "libjpeg-turbo mraa" | 8 | DEPENDS = "libjpeg-turbo mraa" |
9 | 9 | ||
10 | SRCREV = "106b6c706268522ab0168a4ddb19e89ce832e084" | 10 | SRCREV = "cc7fec9ae0228add9011bf1c2cd5e0ca2ba0d4f0" |
11 | PV = "1.3.0-git${SRCPV}" | 11 | PV = "1.6.0-git${SRCPV}" |
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \ | 14 | git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \ |
15 | file://ads1x15-fixed-case-logic-in-getThresh-function.patch \ | ||
16 | " | 15 | " |
17 | 16 | ||
18 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |