diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-30 13:39:00 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-31 11:06:23 -0800 |
commit | 729af58460cf9d29e27e73655f38f15c7465713e (patch) | |
tree | 4f5efddcbb423b5a397c9e1498211c91d74f85d1 /meta-oe/recipes-extended/upm | |
parent | 2a9b5f98cb1a844705fb6d5746f99465d0c90650 (diff) | |
download | meta-openembedded-729af58460cf9d29e27e73655f38f15c7465713e.tar.gz |
upm: Disable -Wno-misleading-indentation with clang10+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/upm')
-rw-r--r-- | meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-extended/upm/upm_git.bb | 1 |
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch b/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch new file mode 100644 index 000000000..68b73bc2c --- /dev/null +++ b/meta-oe/recipes-extended/upm/upm/0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From d41e2bef1c39dcbc4896b1dd7ab168da530672b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 30 Dec 2019 13:33:39 -0800 | ||
4 | Subject: [PATCH] cmake: Disable -Wno-misleading-indentation with clang-10 onwards | ||
5 | |||
6 | clang also introduced this warning now | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/eclipse/upm/pull/693] | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | CMakeLists.txt | 5 +++++ | ||
13 | 1 file changed, 5 insertions(+) | ||
14 | |||
15 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
16 | index 069e4902..47c7f4c3 100644 | ||
17 | --- a/CMakeLists.txt | ||
18 | +++ b/CMakeLists.txt | ||
19 | @@ -99,6 +99,11 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_ | ||
20 | list (APPEND C_CXX_WARNING_FLAGS -Wno-misleading-indentation) | ||
21 | endif () | ||
22 | |||
23 | +# clang-10 added -Wmisleading-indentation as well, skipp it too | ||
24 | +if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER "9") | ||
25 | + list (APPEND C_CXX_WARNING_FLAGS -Wno-misleading-indentation) | ||
26 | +endif () | ||
27 | + | ||
28 | # Warnings as errors? | ||
29 | if (WERROR) | ||
30 | list (APPEND C_CXX_WARNING_FLAGS -Werror) | ||
31 | -- | ||
32 | 2.24.1 | ||
33 | |||
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb index 7564738dd..6db8f8825 100644 --- a/meta-oe/recipes-extended/upm/upm_git.bb +++ b/meta-oe/recipes-extended/upm/upm_git.bb | |||
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \ | |||
14 | file://0001-CMakeLists.txt-Use-SWIG_SUPPORT_FILES-to-find-the-li.patch \ | 14 | file://0001-CMakeLists.txt-Use-SWIG_SUPPORT_FILES-to-find-the-li.patch \ |
15 | file://0001-Use-stdint-types.patch \ | 15 | file://0001-Use-stdint-types.patch \ |
16 | file://0001-initialize-local-variables-before-use.patch \ | 16 | file://0001-initialize-local-variables-before-use.patch \ |
17 | file://0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | SRC_URI_append_toolchain-clang_x86 = " file://0001-nmea_gps-Link-with-latomic.patch " | 20 | SRC_URI_append_toolchain-clang_x86 = " file://0001-nmea_gps-Link-with-latomic.patch " |