diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-03 17:17:17 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-06 13:00:30 +0200 |
commit | 1250668972522b6f1552de23b7cfc4a93701c24b (patch) | |
tree | a6b2f2b2dba78581d524b6a2d225276d418e7e12 /meta-oe/recipes-extended/uml-utilities | |
parent | 10ad20d913202e2bdf5d341a73d44f317e4203b5 (diff) | |
download | meta-openembedded-1250668972522b6f1552de23b7cfc4a93701c24b.tar.gz |
uml-utilities: Fix problem founds during musl build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/uml-utilities')
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-include-required-system-header-files-for-fd_set-and-.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-include-required-system-header-files-for-fd_set-and-.patch new file mode 100644 index 000000000..38e945d64 --- /dev/null +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-include-required-system-header-files-for-fd_set-and-.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From a8d85949a068ee6cd9a2f923cd039047993f239e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 3 Apr 2017 17:11:32 -0700 | ||
4 | Subject: [PATCH] include required system header files for fd_set and makedev | ||
5 | |||
6 | fd_set comes from sys/select.h | ||
7 | makedev macro is defined in sys/sysmacros.h | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | uml_net/ethertap.c | 1 + | ||
12 | uml_net/host.c | 1 + | ||
13 | 2 files changed, 2 insertions(+) | ||
14 | |||
15 | diff --git a/uml_net/ethertap.c b/uml_net/ethertap.c | ||
16 | index ddd41f2..57f7119 100644 | ||
17 | --- a/uml_net/ethertap.c | ||
18 | +++ b/uml_net/ethertap.c | ||
19 | @@ -11,6 +11,7 @@ | ||
20 | #include <sys/signal.h> | ||
21 | #include <sys/socket.h> | ||
22 | #include <sys/stat.h> | ||
23 | +#include <sys/select.h> | ||
24 | #include <sys/ioctl.h> | ||
25 | #include <net/if.h> | ||
26 | #include "host.h" | ||
27 | diff --git a/uml_net/host.c b/uml_net/host.c | ||
28 | index 65c20df..fc04cd4 100644 | ||
29 | --- a/uml_net/host.c | ||
30 | +++ b/uml_net/host.c | ||
31 | @@ -10,6 +10,7 @@ | ||
32 | #include <ctype.h> | ||
33 | #include <sys/wait.h> | ||
34 | #include <sys/stat.h> | ||
35 | +#include <sys/sysmacros.h> | ||
36 | #include "output.h" | ||
37 | #include "host.h" | ||
38 | |||
39 | -- | ||
40 | 2.12.2 | ||
41 | |||
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb index 45cc2e751..ed19d1e41 100644 --- a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb | |||
@@ -3,10 +3,11 @@ SUMMARY = "Utilities for User-Mode-Linux" | |||
3 | LICENSE = "GPL-2.0" | 3 | LICENSE = "GPL-2.0" |
4 | DEPENDS = "zlib ncurses readline" | 4 | DEPENDS = "zlib ncurses readline" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
6 | SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_utilities_${PV}.tar.bz2 \ | 6 | SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_utilities_${PV}.tar.bz2 \ |
7 | file://fix-ldflags.patch \ | 7 | file://fix-ldflags.patch \ |
8 | file://unstrip.patch \ | 8 | file://unstrip.patch \ |
9 | " | 9 | file://0001-include-required-system-header-files-for-fd_set-and-.patch \ |
10 | " | ||
10 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" | 11 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" |
11 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" | 12 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" |
12 | 13 | ||