diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-02 18:59:24 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-05 22:49:35 -0700 |
commit | d40f39273254f01d03caacd204673d2e238232de (patch) | |
tree | ce32e9849f36528cd2b0aaa12612098274688a73 /meta-oe/recipes-extended/uml-utilities | |
parent | e1eb39b36a93cb3603ece4a3e56e229d04473c63 (diff) | |
download | meta-openembedded-d40f39273254f01d03caacd204673d2e238232de.tar.gz |
uml-utilities: Add missing headers for exit and str+ functions
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/uml-utilities')
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch new file mode 100644 index 000000000..9fce51a59 --- /dev/null +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | From a1c4716ceaed6333f8be01b5d4d971e64babcdd7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 2 Sep 2022 18:57:42 -0700 | ||
4 | Subject: [PATCH] Add missing standard headers for str* and exit APIs | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | jail/jail_uml | Bin 19120 -> 19120 bytes | ||
11 | jail/jail_uml.c | 1 + | ||
12 | port-helper/port-helper.c | 1 + | ||
13 | uml_router/port.c | 1 + | ||
14 | uml_router/uml_switch.c | 1 + | ||
15 | watchdog/uml_watchdog.c | 1 + | ||
16 | 6 files changed, 5 insertions(+) | ||
17 | |||
18 | --- a/jail/jail_uml.c | ||
19 | +++ b/jail/jail_uml.c | ||
20 | @@ -1,5 +1,6 @@ | ||
21 | #include <stdio.h> | ||
22 | #include <unistd.h> | ||
23 | +#include <stdlib.h> /* for exit */ | ||
24 | #include <errno.h> | ||
25 | |||
26 | static void Usage(void) | ||
27 | --- a/port-helper/port-helper.c | ||
28 | +++ b/port-helper/port-helper.c | ||
29 | @@ -12,6 +12,7 @@ for read and write, and the console is f | ||
30 | |||
31 | #include <stdio.h> | ||
32 | #include <stdlib.h> | ||
33 | +#include <string.h> /* memset */ | ||
34 | #include <signal.h> | ||
35 | #include <errno.h> | ||
36 | #include <unistd.h> | ||
37 | --- a/uml_router/port.c | ||
38 | +++ b/uml_router/port.c | ||
39 | @@ -1,5 +1,6 @@ | ||
40 | #include <stdio.h> | ||
41 | #include <stdlib.h> | ||
42 | +#include <string.h> /* memcmp */ | ||
43 | #include <unistd.h> | ||
44 | #include <errno.h> | ||
45 | #include <sys/socket.h> | ||
46 | --- a/uml_router/uml_switch.c | ||
47 | +++ b/uml_router/uml_switch.c | ||
48 | @@ -5,6 +5,7 @@ | ||
49 | #include <stdio.h> | ||
50 | #include <errno.h> | ||
51 | #include <stdlib.h> | ||
52 | +#include <string.h> /* strcmp */ | ||
53 | #include <signal.h> | ||
54 | #include <fcntl.h> | ||
55 | #include <stdint.h> | ||
56 | --- a/watchdog/uml_watchdog.c | ||
57 | +++ b/watchdog/uml_watchdog.c | ||
58 | @@ -1,5 +1,6 @@ | ||
59 | #include <stdio.h> | ||
60 | #include <stdlib.h> | ||
61 | +#include <string.h> /* strcmp */ | ||
62 | #include <unistd.h> | ||
63 | #include <signal.h> | ||
64 | #include <errno.h> | ||
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb index 663a145ef..35ae5f777 100644 --- a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb | |||
@@ -7,6 +7,7 @@ SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_ | |||
7 | file://fix-ldflags.patch \ | 7 | file://fix-ldflags.patch \ |
8 | file://unstrip.patch \ | 8 | file://unstrip.patch \ |
9 | file://0001-include-required-system-header-files-for-fd_set-and-.patch \ | 9 | file://0001-include-required-system-header-files-for-fd_set-and-.patch \ |
10 | file://0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch \ | ||
10 | " | 11 | " |
11 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" | 12 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" |
12 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" | 13 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" |