summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/tcsh
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-08 14:22:50 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-15 12:13:16 +0200
commit47e84b36863c0084e640422ea7d0e16b39ab8d99 (patch)
treed9a982a1d20004cc6fc4210e187f73d428ac939a /meta-oe/recipes-extended/tcsh
parent87fc6bb63978e95839c1efeb072d851f6ee3c907 (diff)
downloadmeta-openembedded-47e84b36863c0084e640422ea7d0e16b39ab8d99.tar.gz
tcsh: fix the wait definition to support gcc6
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/tcsh')
-rw-r--r--meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch11
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb13
2 files changed, 18 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch b/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch
new file mode 100644
index 000000000..acc2ce93d
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch
@@ -0,0 +1,11 @@
1--- tcsh-6.18.01/sh.proc.c.orig 2016-06-08 16:11:02.902326725 +0000
2+++ tcsh-6.18.01/sh.proc.c 2016-06-08 16:38:22.150304901 +0000
3@@ -48,7 +48,7 @@
4 #endif /* aiws */
5
6 #if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
7-# if !defined(__ANDROID__)
8+# if !defined(__ANDROID__) && !defined(__GLIBC__)
9 # define BSDWAIT
10 # endif
11 #endif /* _BSD || (IRIS4D && __STDC__) || __lucid || glibc */
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
index 5a6f19061..d7a7fd4d4 100644
--- a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
+++ b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
@@ -10,7 +10,8 @@ SECTION = "base"
10DEPENDS = "ncurses gettext-native" 10DEPENDS = "ncurses gettext-native"
11SRC_URI = " \ 11SRC_URI = " \
12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \ 12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs \ 13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs2 \
14 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-5.diff.gz;name=diffs5 \
14 file://01_build.1.patch \ 15 file://01_build.1.patch \
15 file://01_build.2.patch \ 16 file://01_build.2.patch \
16 file://01_build.3.patch \ 17 file://01_build.3.patch \
@@ -21,11 +22,14 @@ SRC_URI = " \
21 file://12_unknown_lscolors.patch \ 22 file://12_unknown_lscolors.patch \
22 file://tcsh-6.17.02-multibyte.patch \ 23 file://tcsh-6.17.02-multibyte.patch \
23 file://disable-broken-test.patch \ 24 file://disable-broken-test.patch \
25 file://fix-gcc6-wait-union.patch \
24" 26"
25SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a" 27SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
26SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8" 28SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
27SRC_URI[diffs.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9" 29SRC_URI[diffs2.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
28SRC_URI[diffs.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c" 30SRC_URI[diffs2.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
31SRC_URI[diffs5.md5sum] = "d536c12a02dc48c332cc472b86927319"
32SRC_URI[diffs5.sha256sum] = "7548d64bf996548bfbc13f3e0959fd2e8455f8375381a31da67d79554aabc7af"
29 33
30inherit autotools 34inherit autotools
31 35
@@ -47,6 +51,3 @@ pkg_postinst_${PN} () {
47#!/bin/sh -e 51#!/bin/sh -e
48echo /usr/bin/tcsh >> $D/etc/shells 52echo /usr/bin/tcsh >> $D/etc/shells
49} 53}
50
51# http://errors.yoctoproject.org/Errors/Details/68619/
52PNBLACKLIST[tcsh] ?= "BROKEN: fails to build with glibc-2.24"