summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sysdig/sysdig_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-extended/sysdig/sysdig_git.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sysdig/sysdig_git.bb')
-rw-r--r--meta-oe/recipes-extended/sysdig/sysdig_git.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-extended/sysdig/sysdig_git.bb b/meta-oe/recipes-extended/sysdig/sysdig_git.bb
index a626e3b20..a12f8ba5e 100644
--- a/meta-oe/recipes-extended/sysdig/sysdig_git.bb
+++ b/meta-oe/recipes-extended/sysdig/sysdig_git.bb
@@ -10,16 +10,16 @@ inherit cmake pkgconfig
10 10
11#OECMAKE_GENERATOR = "Unix Makefiles" 11#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit" 12JIT ?= "jit"
13JIT_mipsarchn32 = "" 13JIT:mipsarchn32 = ""
14JIT_mipsarchn64 = "" 14JIT:mipsarchn64 = ""
15JIT_riscv64 = "" 15JIT:riscv64 = ""
16JIT_riscv32 = "" 16JIT:riscv32 = ""
17JIT_powerpc = "" 17JIT:powerpc = ""
18JIT_powerpc64le = "" 18JIT:powerpc64le = ""
19JIT_powerpc64 = "" 19JIT:powerpc64 = ""
20 20
21DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native" 21DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
22RDEPENDS_${PN} = "bash" 22RDEPENDS:${PN} = "bash"
23 23
24SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \ 24SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \
25 file://0001-fix-build-with-LuaJIT-2.1-betas.patch \ 25 file://0001-fix-build-with-LuaJIT-2.1-betas.patch \
@@ -39,7 +39,7 @@ EXTRA_OECMAKE = "\
39 -DLUA_LIBRARY=libluajit-5.1.so \ 39 -DLUA_LIBRARY=libluajit-5.1.so \
40" 40"
41 41
42FILES_${PN} += " \ 42FILES:${PN} += " \
43 ${DIR_ETC}/* \ 43 ${DIR_ETC}/* \
44 ${datadir}/zsh/* \ 44 ${datadir}/zsh/* \
45 ${prefix}/src/* \ 45 ${prefix}/src/* \
@@ -48,8 +48,8 @@ FILES_${PN} += " \
48# It should be fixed in sysdig, until then disable 48# It should be fixed in sysdig, until then disable
49# on musl 49# on musl
50# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it 50# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
51COMPATIBLE_HOST_libc-musl = "null" 51COMPATIBLE_HOST:libc-musl = "null"
52COMPATIBLE_HOST_mips = "null" 52COMPATIBLE_HOST:mips = "null"
53COMPATIBLE_HOST_riscv64 = "null" 53COMPATIBLE_HOST:riscv64 = "null"
54COMPATIBLE_HOST_riscv32 = "null" 54COMPATIBLE_HOST:riscv32 = "null"
55COMPATIBLE_HOST_powerpc = "null" 55COMPATIBLE_HOST:powerpc = "null"