summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb')
-rw-r--r--meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb b/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
new file mode 100644
index 000000000..fd7b1b8c5
--- /dev/null
+++ b/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Control and monitor storage systems using S.M.A.R.T"
2DESCRIPTION = \
3"The smartmontools package contains two utility programs (smartctl \
4and smartd) to control and monitor storage systems using the Self-\
5Monitoring, Analysis and Reporting Technology System (SMART) built \
6into most modern ATA and SCSI hard disks. In many cases, these \
7utilities will provide advanced warning of disk degradation and failure."
8
9HOMEPAGE = "http://smartmontools.sourceforge.net/"
10SECTION = "console/utils"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
16 file://initd.smartd \
17 file://smartmontools.default \
18 file://smartd.service \
19 "
20
21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'libcap-ng', 'libcap-ng', '', d)} \
22 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
23 "
24PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
25PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
26
27SRC_URI[md5sum] = "d44f84081a12cef79cd17f78044351fc"
28SRC_URI[sha256sum] = "486f660579bb0fb4f6b927ded7531cb1f99685c666397377761c5b04dd96065b"
29
30inherit autotools update-rc.d systemd
31
32SYSTEMD_SERVICE_${PN} = "smartd.service"
33SYSTEMD_AUTO_ENABLE = "disable"
34
35do_install_append () {
36 #install the init.d/smartd
37 install -d ${D}${sysconfdir}/init.d
38 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
39 install -d ${D}${sysconfdir}/default
40 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
41
42 #install systemd service file
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
45 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
46 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
47 -e 's,@SBINDIR@,${sbindir},g' \
48 ${D}${systemd_unitdir}/system/smartd.service
49}
50
51INITSCRIPT_NAME = "smartd"
52INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ."
53
54RDEPENDS_${PN} += "mailx"