summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sip
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-01 13:47:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-07 12:21:23 +0200
commit614daa3a27d090fbf54e08c5f4eabc1f14d228c3 (patch)
treeace84277fb27f4bef58d97fc0e228112093bc69e /meta-oe/recipes-extended/sip
parent736887bd295ad35adb27eb5fb8e045681d844df7 (diff)
downloadmeta-openembedded-614daa3a27d090fbf54e08c5f4eabc1f14d228c3.tar.gz
sip: import from oe-classic and upgrade to latest
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sip')
-rw-r--r--meta-oe/recipes-extended/sip/sip-native_4.13.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sip/sip-native_4.13.3.bb b/meta-oe/recipes-extended/sip/sip-native_4.13.3.bb
new file mode 100644
index 000000000..2ef10bfd8
--- /dev/null
+++ b/meta-oe/recipes-extended/sip/sip-native_4.13.3.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
2AUTHOR = "Phil Thompson"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://sipgen.sbf;endline=15;md5=88e887a386c18a01240d8d055da4e441"
7
8SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
9SRC_URI[md5sum] = "76192829cc42ec558db46e4f9e1d8ba9"
10SRC_URI[sha256sum] = "ec295f71ef339c5b98db5650865f2c6c1200c4085b7a3f33f284111e1f534ac1"
11S = "${WORKDIR}/sip-${PV}/sipgen"
12
13inherit qt4x11 native python-dir
14
15EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
16
17export BUILD_SYS
18export HOST_SYS
19export STAGING_LIBDIR
20export STAGING_INCDIR
21
22do_configure_prepend() {
23 cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
24}
25do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 sip ${D}${bindir}/sip
28 # python-pyqt expects sip4
29 ln -sf sip ${D}${bindir}/sip4
30 cd ${WORKDIR}/sip-${PV} && python configure.py
31 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
32 install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR}
33}