diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-07 15:57:45 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-14 11:30:15 +0100 |
commit | 2bd11da4b50f401c9c49975aeedaaafa6a59d08b (patch) | |
tree | db1b531c534d13cd51d0b9fa4c418b89e899879e /meta-oe/recipes-extended/sip/sip_4.16.4.bb | |
parent | 8700ba38804af3c27f3662737f679afa1bdc86da (diff) | |
download | meta-openembedded-2bd11da4b50f401c9c49975aeedaaafa6a59d08b.tar.gz |
recipes: remove recipes using or depending on qt4 bbclasses or recipes
* anki is removed because it runtime depends on python-pyqt, other
recipes are inheriting one of bbclasses removed from oe-core in:
commit cb89d2b25b4edb1241bc5426a69a6bc44df9be2c
Author: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Date: Fri Nov 27 15:48:20 2015 +0200
qt4: remove recipes and classes
* if you're still using one of these recipes add it to meta-qt4 layer
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sip/sip_4.16.4.bb')
-rw-r--r-- | meta-oe/recipes-extended/sip/sip_4.16.4.bb | 54 |
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb deleted file mode 100644 index 032d1258b..000000000 --- a/meta-oe/recipes-extended/sip/sip_4.16.4.bb +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | SUMMARY = "SIP is a C++/Python Wrapper Generator" | ||
2 | AUTHOR = "Phil Thompson" | ||
3 | HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303" | ||
7 | DEPENDS_class-target = "qt4-x11-free python" | ||
8 | |||
9 | # riverbankcomputing is upstream, but keeps only latest version, sf usually have few older | ||
10 | #SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz" | ||
11 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz" | ||
12 | SRC_URI[md5sum] = "a9840670a064dbf8f63a8f653776fec9" | ||
13 | SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f2199d57f5" | ||
14 | |||
15 | BBCLASSEXTEND = "native" | ||
16 | |||
17 | PACKAGES += "python-sip" | ||
18 | |||
19 | inherit qmake2 python-dir pythonnative distro_features_check | ||
20 | # depends on qt4-x11-free | ||
21 | REQUIRED_DISTRO_FEATURES = "x11" | ||
22 | |||
23 | EXTRA_QMAKEVARS_POST += "CONFIG=console" | ||
24 | |||
25 | export BUILD_SYS | ||
26 | export HOST_SYS | ||
27 | export STAGING_LIBDIR | ||
28 | export STAGING_INCDIR | ||
29 | |||
30 | do_configure_prepend_class-target() { | ||
31 | echo "py_platform = linux" > sip.cfg | ||
32 | echo "py_inc_dir = %(sysroot)/${includedir}/python%(py_major).%(py_minor)" >> sip.cfg | ||
33 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
34 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
35 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
36 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
37 | python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_HOST} | ||
38 | } | ||
39 | do_configure_prepend_class-native() { | ||
40 | echo "py_platform = linux" > sip.cfg | ||
41 | echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)" >> sip.cfg | ||
42 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
43 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
44 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
45 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
46 | python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_NATIVE} | ||
47 | } | ||
48 | do_install() { | ||
49 | oe_runmake install | ||
50 | } | ||
51 | |||
52 | FILES_python-${BPN} = "${libdir}/${PYTHON_DIR}/site-packages/" | ||
53 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" | ||
54 | |||