summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sedutil
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-26 23:40:37 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-27 17:06:52 -0800
commitf38c94f735d8c9b4361c32aad435b1e369af8a61 (patch)
treefefd61af211295bbc71c7eb1eda5ee4a5d70e59c /meta-oe/recipes-extended/sedutil
parent293f8baaddb93626fdcfc641f55c8a783e9aad46 (diff)
downloadmeta-openembedded-f38c94f735d8c9b4361c32aad435b1e369af8a61.tar.gz
sedutil: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sedutil')
-rw-r--r--meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch32
-rw-r--r--meta-oe/recipes-extended/sedutil/sedutil_git.bb2
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch b/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
new file mode 100644
index 000000000..8afcb1fa4
--- /dev/null
+++ b/meta-oe/recipes-extended/sedutil/files/0001-include-missing-cstdint.patch
@@ -0,0 +1,32 @@
1From 927cd88cad7bea94c2eebecc18f7881f0defaccb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 26 Jan 2023 23:36:29 -0800
4Subject: [PATCH] include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint>
7is no longer transitively included [1]. Explicitly include
8it for uint{32,64}_t.
9
10[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
11
12Upstream-Status: Submitted [https://github.com/Drive-Trust-Alliance/sedutil/pull/425]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 Common/DtaOptions.h | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/Common/DtaOptions.h b/Common/DtaOptions.h
19index c012af1..7530a0b 100644
20--- a/Common/DtaOptions.h
21+++ b/Common/DtaOptions.h
22@@ -21,6 +21,7 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
23 #ifndef _DTAOPTIONS_H
24 #define _DTAOPTIONS_H
25
26+#include <cstdint>
27 /** Output modes */
28 typedef enum _sedutiloutput {
29 sedutilNormal,
30--
312.39.1
32
diff --git a/meta-oe/recipes-extended/sedutil/sedutil_git.bb b/meta-oe/recipes-extended/sedutil/sedutil_git.bb
index a377d4ec5..972a33c74 100644
--- a/meta-oe/recipes-extended/sedutil/sedutil_git.bb
+++ b/meta-oe/recipes-extended/sedutil/sedutil_git.bb
@@ -7,11 +7,11 @@ LICENSE = "GPL-3.0-only"
7 7
8LIC_FILES_CHKSUM = "file://Common/LICENSE.txt;md5=d32239bcb673463ab874e80d47fae504" 8LIC_FILES_CHKSUM = "file://Common/LICENSE.txt;md5=d32239bcb673463ab874e80d47fae504"
9 9
10BASEPV = "1.15.1"
11PV = "1.20.0" 10PV = "1.20.0"
12SRCREV = "d3de8e45e06a21d31cca0046ceb16ced1ef3563a" 11SRCREV = "d3de8e45e06a21d31cca0046ceb16ced1ef3563a"
13SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git;branch=master;protocol=https \ 12SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git;branch=master;protocol=https \
14 file://0001-Fix-build-on-big-endian-architectures.patch \ 13 file://0001-Fix-build-on-big-endian-architectures.patch \
14 file://0001-include-missing-cstdint.patch \
15 " 15 "
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"