diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-08-17 17:42:14 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-17 17:52:09 -0700 |
commit | 302a6c447456113255a4ec705aa4a17f404beb58 (patch) | |
tree | 4fff7ca162320b58b1dbde34bef199cb8aacb0a7 /meta-oe/recipes-extended/sedutil | |
parent | 6c25c473379a56729d8a4fa65c0ff646e2c8db29 (diff) | |
download | meta-openembedded-302a6c447456113255a4ec705aa4a17f404beb58.tar.gz |
sedutils: Fix build with clang11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sedutil')
-rw-r--r-- | meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sedutil/sedutil_git.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch b/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch new file mode 100644 index 000000000..4be3353c6 --- /dev/null +++ b/meta-oe/recipes-extended/sedutil/files/0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 9db49b94336f65453e06fb6a6bc4e6edf9403fea Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 17 Aug 2020 17:22:09 -0700 | ||
4 | Subject: [PATCH] DtaAnnotatedDump: Add typedef name to the union | ||
5 | |||
6 | This is found with clang | ||
7 | error: anonymous non-C-compatible type given name for linkage purposes by | ||
8 | typedef declaration; add a tag name here [-Werror,-Wnon-c-typedef-for-linkage] | ||
9 | | typedef union | ||
10 | | ^ | ||
11 | | CAtomHeader | ||
12 | |||
13 | Upstream-Status: Submitted [https://github.com/Drive-Trust-Alliance/sedutil/pull/332] | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | Common/DtaAnnotatedDump.h | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/Common/DtaAnnotatedDump.h b/Common/DtaAnnotatedDump.h | ||
20 | index 2749365..734c8eb 100644 | ||
21 | --- a/Common/DtaAnnotatedDump.h | ||
22 | +++ b/Common/DtaAnnotatedDump.h | ||
23 | @@ -20,7 +20,7 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>. | ||
24 | |||
25 | #pragma pack(push,1) | ||
26 | |||
27 | -typedef union | ||
28 | +typedef union CAtomHeader_t | ||
29 | { | ||
30 | // four bytes in big endian (network) byte order | ||
31 | uint8_t all[4]; | ||
32 | -- | ||
33 | 2.28.0 | ||
34 | |||
diff --git a/meta-oe/recipes-extended/sedutil/sedutil_git.bb b/meta-oe/recipes-extended/sedutil/sedutil_git.bb index 765618433..1e7a39319 100644 --- a/meta-oe/recipes-extended/sedutil/sedutil_git.bb +++ b/meta-oe/recipes-extended/sedutil/sedutil_git.bb | |||
@@ -12,6 +12,7 @@ PV = "${BASEPV}+git${SRCPV}" | |||
12 | SRCREV = "358cc758948be788284d5faba46ccf4cc1813796" | 12 | SRCREV = "358cc758948be788284d5faba46ccf4cc1813796" |
13 | SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git \ | 13 | SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git \ |
14 | file://0001-Fix-build-on-big-endian-architectures.patch \ | 14 | file://0001-Fix-build-on-big-endian-architectures.patch \ |
15 | file://0001-DtaAnnotatedDump-Add-typedef-name-to-the-union.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |