diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-27 19:08:07 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:26 +0200 |
commit | c0d763a6e604647f6dad25119eed5820195c2280 (patch) | |
tree | 223aa1331c7dc8f8e94a4b9b33d744f09edee22c /meta-oe/recipes-extended/sblim-sfcb | |
parent | d53546b7cb38e0dfea6f458859f7f477065daa43 (diff) | |
download | meta-openembedded-c0d763a6e604647f6dad25119eed5820195c2280.tar.gz |
sblim-sfcb: Add stdint.h for 'UINT16_MAX'
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sblim-sfcb')
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | 4 |
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch new file mode 100644 index 000000000..c2111a2c1 --- /dev/null +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 446fb15f79499f52ce01ca759dbdcfe635519a82 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 27 Jun 2017 07:09:33 -0700 | ||
4 | Subject: [PATCH] include stdint.h system header for UINT16_MAX | ||
5 | |||
6 | Fixes build error | ||
7 | |||
8 | error: 'UINT16_MAX' undeclared (first use in this function) | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | interopServerProvider.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/interopServerProvider.c b/interopServerProvider.c | ||
16 | index 23ae182..532febe 100644 | ||
17 | --- a/interopServerProvider.c | ||
18 | +++ b/interopServerProvider.c | ||
19 | @@ -33,6 +33,7 @@ | ||
20 | #include <sfcCommon/utilft.h> | ||
21 | #include <stdio.h> | ||
22 | #include <stdlib.h> | ||
23 | +#include <stdint.h> | ||
24 | #include <ctype.h> | ||
25 | #include <string.h> | ||
26 | #include <sys/types.h> | ||
27 | -- | ||
28 | 2.13.2 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb index fa75fcc16..ddb1cba7f 100644 --- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | |||
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261" | |||
12 | DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" | 12 | DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" |
13 | 13 | ||
14 | SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ | 14 | SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ |
15 | file://sfcb.service \ | ||
15 | file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ | 16 | file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ |
16 | file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \ | 17 | file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \ |
17 | file://sblim-sfcb-1.3.16-maxMsgLen.patch \ | 18 | file://sblim-sfcb-1.3.16-maxMsgLen.patch \ |
@@ -19,7 +20,8 @@ SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ | |||
19 | file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \ | 20 | file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \ |
20 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ | 21 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ |
21 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ | 22 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ |
22 | file://sfcb.service" | 23 | file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \ |
24 | " | ||
23 | 25 | ||
24 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" | 26 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" |
25 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" | 27 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |