diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:49 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:38 +0200 |
commit | 21f10c11f39020f9502d741c774a12d1aeb39499 (patch) | |
tree | fdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-extended/sblim-sfcb | |
parent | 723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff) | |
download | meta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz |
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sblim-sfcb')
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb index efd4295c8..ed5382e39 100644 --- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb +++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb | |||
@@ -25,13 +25,13 @@ SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" | |||
25 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" | 25 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
26 | 26 | ||
27 | inherit autotools | 27 | inherit autotools |
28 | inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} | 28 | inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} |
29 | 29 | ||
30 | SYSTEMD_PACKAGES = "${PN}" | 30 | SYSTEMD_PACKAGES = "${PN}" |
31 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" | 31 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" |
32 | SYSTEMD_AUTO_ENABLE = "enable" | 32 | SYSTEMD_AUTO_ENABLE = "enable" |
33 | 33 | ||
34 | LDFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | 34 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
35 | 35 | ||
36 | EXTRA_OECONF = '--enable-debug \ | 36 | EXTRA_OECONF = '--enable-debug \ |
37 | --enable-ssl \ | 37 | --enable-ssl \ |
@@ -50,7 +50,7 @@ do_install() { | |||
50 | 50 | ||
51 | oe_runmake DESTDIR=${D} install | 51 | oe_runmake DESTDIR=${D} install |
52 | 52 | ||
53 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 53 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
54 | install -d ${D}${systemd_unitdir}/system | 54 | install -d ${D}${systemd_unitdir}/system |
55 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service | 55 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service |
56 | fi | 56 | fi |