diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-01-12 16:16:11 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-01-15 16:36:35 +0100 |
commit | bd2d39df79bb52462e6e768fc20362b08697cd58 (patch) | |
tree | 5694b1e1b791f9d0c1ca9cb054646106f8bda9d9 /meta-oe/recipes-extended/rsyslog | |
parent | 95dc2ddce7a0ee4d16d6c69fd123e4e6921bdf2e (diff) | |
download | meta-openembedded-bd2d39df79bb52462e6e768fc20362b08697cd58.tar.gz |
rsyslog: fix build with json-0.12
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/rsyslog')
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/rsyslog/json-0.12-fix.patch | 45 | ||||
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb | 1 |
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/json-0.12-fix.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/json-0.12-fix.patch new file mode 100644 index 000000000..7390a7f54 --- /dev/null +++ b/meta-oe/recipes-extended/rsyslog/rsyslog/json-0.12-fix.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | json-c-0.12 unlike 0.11 doesn't install json -> json-c symlink in include | ||
2 | |||
3 | * Resolved in Version 7.6.4 [v7.6-stable] 2014-09-12 | ||
4 | https://github.com/rsyslog/rsyslog/blob/v7-stable/ChangeLog | ||
5 | * permits to build against json-c 0.12 | ||
6 | Unfortunately, json-c had an ABI breakage, so this is necessary. Note | ||
7 | that versions prior to 0.12 had security issues (CVE-2013-6370, | ||
8 | CVE-2013-6371) and so it is desirable to link against the new version. | ||
9 | Thanks to Thomas D. for the patch. Note that at least some distros | ||
10 | have fixed the security issue in older versions of json-c, so this | ||
11 | seems to apply mostly when building from sources. | ||
12 | |||
13 | Upstream-Status: Backport | ||
14 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
15 | |||
16 | diff -uNr rsyslog-7.4.4.orig/plugins/ommongodb/ommongodb.c rsyslog-7.4.4/plugins/ommongodb/ommongodb.c | ||
17 | --- rsyslog-7.4.4.orig/plugins/ommongodb/ommongodb.c 2013-09-03 11:54:20.000000000 +0200 | ||
18 | +++ rsyslog-7.4.4/plugins/ommongodb/ommongodb.c 2015-01-12 16:11:51.542591825 +0100 | ||
19 | @@ -33,9 +33,9 @@ | ||
20 | #include <stdint.h> | ||
21 | #include <time.h> | ||
22 | #include <mongo.h> | ||
23 | -#include <json.h> | ||
24 | +#include <json-c/json.h> | ||
25 | /* For struct json_object_iter, should not be necessary in future versions */ | ||
26 | -#include <json/json_object_private.h> | ||
27 | +#include <json-c/json_object_private.h> | ||
28 | |||
29 | #include "rsyslog.h" | ||
30 | #include "conf.h" | ||
31 | diff -uNr rsyslog-7.4.4.orig/runtime/msg.c rsyslog-7.4.4/runtime/msg.c | ||
32 | --- rsyslog-7.4.4.orig/runtime/msg.c 2013-09-03 12:31:42.000000000 +0200 | ||
33 | +++ rsyslog-7.4.4/runtime/msg.c 2015-01-12 16:12:00.403592142 +0100 | ||
34 | @@ -41,9 +41,9 @@ | ||
35 | #endif | ||
36 | #include <netdb.h> | ||
37 | #include <libestr.h> | ||
38 | -#include <json.h> | ||
39 | +#include <json-c/json.h> | ||
40 | /* For struct json_object_iter, should not be necessary in future versions */ | ||
41 | -#include <json/json_object_private.h> | ||
42 | +#include <json-c/json_object_private.h> | ||
43 | #if HAVE_MALLOC_H | ||
44 | # include <malloc.h> | ||
45 | #endif | ||
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb index aeca09a27..a9d9464e3 100644 --- a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb +++ b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb | |||
@@ -25,6 +25,7 @@ SRC_URI = "http://www.rsyslog.com/files/download/rsyslog/${BPN}-${PV}.tar.gz \ | |||
25 | file://run-ptest \ | 25 | file://run-ptest \ |
26 | file://rsyslog-fix-ptest-not-finish.patch \ | 26 | file://rsyslog-fix-ptest-not-finish.patch \ |
27 | file://rsyslog-use-serial-tests-config-needed-by-ptest.patch \ | 27 | file://rsyslog-use-serial-tests-config-needed-by-ptest.patch \ |
28 | file://json-0.12-fix.patch \ | ||
28 | " | 29 | " |
29 | 30 | ||
30 | SRC_URI[md5sum] = "ebcc010a6205c28eb505c0fe862f32c6" | 31 | SRC_URI[md5sum] = "ebcc010a6205c28eb505c0fe862f32c6" |