diff options
author | Stephen Arnold <sarnold@vctlabs.com> | 2016-06-07 17:14:58 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-15 12:13:14 +0200 |
commit | af6af8621ed8b93605a5db98d1ff8006f2ef1dff (patch) | |
tree | c5ebd4677d3d5755244a3ef0553e9439a4ce950e /meta-oe/recipes-extended/redis | |
parent | 548effebf1dc1e80c7898b92ca29b750daf403d5 (diff) | |
download | meta-openembedded-af6af8621ed8b93605a5db98d1ff8006f2ef1dff.tar.gz |
redis: fix hiredis build so it's less failure-prone and links properly
This patch resets the default OPT flags to -O2 and adds the missing
ranlib command to index the static library.
Signed-off-by: Stephen Arnold <sarnold@vctlabs.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis')
-rw-r--r-- | meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch | 19 | ||||
-rw-r--r-- | meta-oe/recipes-extended/redis/redis_3.0.2.bb | 2 |
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch b/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch new file mode 100644 index 000000000..2b3b58793 --- /dev/null +++ b/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | --- redis-3.0.2/deps/hiredis/Makefile.orig 2016-05-06 19:36:26.179003036 -0700 | ||
2 | +++ redis-3.0.2/deps/hiredis/Makefile 2016-05-06 19:40:15.341340736 -0700 | ||
3 | @@ -25,7 +25,7 @@ | ||
4 | |||
5 | # Fallback to gcc when $CC is not in $PATH. | ||
6 | CC?=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc') | ||
7 | -OPTIMIZATION?=-O3 | ||
8 | +OPTIMIZATION?=-O2 | ||
9 | WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings | ||
10 | DEBUG?= -g -ggdb | ||
11 | REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG) $(ARCH) | ||
12 | @@ -68,6 +68,7 @@ | ||
13 | |||
14 | $(STLIBNAME): $(OBJ) | ||
15 | $(STLIB_MAKE_CMD) $(OBJ) | ||
16 | + $(RANLIB) $@ | ||
17 | |||
18 | dynamic: $(DYLIBNAME) | ||
19 | static: $(STLIBNAME) | ||
diff --git a/meta-oe/recipes-extended/redis/redis_3.0.2.bb b/meta-oe/recipes-extended/redis/redis_3.0.2.bb index 55f2c9669..2e4b760cc 100644 --- a/meta-oe/recipes-extended/redis/redis_3.0.2.bb +++ b/meta-oe/recipes-extended/redis/redis_3.0.2.bb | |||
@@ -12,7 +12,9 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \ | |||
12 | file://oe-use-libc-malloc.patch \ | 12 | file://oe-use-libc-malloc.patch \ |
13 | file://redis.conf \ | 13 | file://redis.conf \ |
14 | file://init-redis-server \ | 14 | file://init-redis-server \ |
15 | file://hiredis-update-Makefile-to-add-symbols-to-staticlib.patch \ | ||
15 | " | 16 | " |
17 | |||
16 | SRC_URI[md5sum] = "87be8867447f62524b584813e5a7bd14" | 18 | SRC_URI[md5sum] = "87be8867447f62524b584813e5a7bd14" |
17 | SRC_URI[sha256sum] = "93e422c0d584623601f89b956045be158889ebe594478a2c24e1bf218495633f" | 19 | SRC_URI[sha256sum] = "93e422c0d584623601f89b956045be158889ebe594478a2c24e1bf218495633f" |
18 | 20 | ||