diff options
author | Kevin Baker <kevinb@ventureresearch.com> | 2013-02-09 05:02:47 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-16 05:54:59 +0100 |
commit | 49851b1190307524014e2645105b902657c46038 (patch) | |
tree | 6b1176969206c392f04f1110fcf3ab8a49bf8297 /meta-oe/recipes-extended/redis/redis_2.6.9.bb | |
parent | 1b6add994684cea82024e3389e559879118e16a4 (diff) | |
download | meta-openembedded-49851b1190307524014e2645105b902657c46038.tar.gz |
redis: add new recipe for redis-2.6.9
A recipe for Redis 2.6.9, an advanced key-value store.
Needed some patching of Makefiles and deps to get it to work with OE.
OE Specific configuration: This is built to override MALLOC and use
libc's malloc instead of the provided jemalloc or tcmalloc that
weren't building correctly.
Also the default savepoint setting was updated in the default
redis.conf to tune for a small embedded system.
Known Bug: redis-cli eats all the input on a serial port - watch out
when using the serial console with redis-cli.
see https://github.com/antirez/linenoise/issues/38
Tested with Yocto "Danny" / armv7a.
Signed-off-by: Kevin Baker <kevinb@ventureresearch.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis_2.6.9.bb')
-rw-r--r-- | meta-oe/recipes-extended/redis/redis_2.6.9.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis_2.6.9.bb b/meta-oe/recipes-extended/redis/redis_2.6.9.bb new file mode 100644 index 000000000..f6818ee51 --- /dev/null +++ b/meta-oe/recipes-extended/redis/redis_2.6.9.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Redis key-value store" | ||
2 | DESCRIPTION = "Redis is an open source, advanced key-value store." | ||
3 | HOMEPAGE = "http://redis.io" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM="file://COPYING;md5=673e0ac66aac758f8f2140c6fc7947d2" | ||
7 | |||
8 | SRC_URI = "http://redis.googlecode.com/files/redis-${PV}.tar.gz \ | ||
9 | file://hiredis-use-default-CC-if-it-is-set.patch \ | ||
10 | file://lua-update-Makefile-to-use-environment-build-setting.patch \ | ||
11 | file://oe-use-libc-malloc.patch \ | ||
12 | file://redis.conf \ | ||
13 | file://init-redis-server \ | ||
14 | " | ||
15 | |||
16 | inherit update-rc.d | ||
17 | |||
18 | INITSCRIPT_NAME = "redis-server" | ||
19 | INITSCRIPT_PARAMS = "defaults 87" | ||
20 | |||
21 | SRC_URI[md5sum] = "5093fb7c5f763e828c857daf260665bc" | ||
22 | SRC_URI[sha256sum] = "4d967eff2038aebea33875d17e85ed67179df6505df68529a622f7836d1c7489" | ||
23 | |||
24 | do_install() { | ||
25 | export PREFIX=${D}/${prefix} | ||
26 | oe_runmake install | ||
27 | |||
28 | install -d ${D}/${sysconfdir}/redis | ||
29 | install -m 0755 ${WORKDIR}/redis.conf ${D}/${sysconfdir}/redis/redis.conf | ||
30 | |||
31 | install -d ${D}/${sysconfdir}/init.d | ||
32 | install -m 0755 ${WORKDIR}/init-redis-server ${D}/${sysconfdir}/init.d/redis-server | ||
33 | |||
34 | install -d ${D}/var/lib/redis/ | ||
35 | } | ||
36 | |||