summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pmdk
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-06 18:26:38 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-06 18:44:20 -0700
commite39b78ad933d6909c8d851168f2438ff6c9e3180 (patch)
tree1ec4b45b67f3251c6ea57cf30c6b352412a17e6b /meta-oe/recipes-extended/pmdk
parent5f9f4cba2f3a9b22fcd658fed91b1fe05b840b7f (diff)
downloadmeta-openembedded-e39b78ad933d6909c8d851168f2438ff6c9e3180.tar.gz
pmdk: Update to 1.7
- Examples can be disabled via makefile argument, so drop the patch to disble building them and instead disable building via makefile argument - Add a patch to control secure_getenv definition spill into linux/musl case Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/pmdk')
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch33
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0003-Makefile-Don-t-build-the-examples.patch34
-rw-r--r--meta-oe/recipes-extended/pmdk/pmdk_1.7.bb (renamed from meta-oe/recipes-extended/pmdk/pmdk_1.6.bb)6
3 files changed, 36 insertions, 37 deletions
diff --git a/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch b/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch
new file mode 100644
index 000000000..33f25b6a6
--- /dev/null
+++ b/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch
@@ -0,0 +1,33 @@
1From 7d0732d69a774e28bc46b8b487d9f61bdd8afbff Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 6 Oct 2019 18:15:44 -0700
4Subject: [PATCH] os_posix: Use __FreeBSD__ to control secure_getenv definition
5
6__USE_GNU does not cover all Linux platforms, e.g. when using musl as C
7library, __USE_GNU may not be defined but it does provide secure_getenv
8so instead of narrowing the else condition, lets speicifically check for
9FreeBSD being the platform, since that seems to be the intention here
10anyway
11
12Upstream-Status: Submitted [https://github.com/pmem/pmdk/pull/3999]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/common/os_posix.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/common/os_posix.c b/src/common/os_posix.c
19index a9a37ef84..052db2383 100644
20--- a/src/common/os_posix.c
21+++ b/src/common/os_posix.c
22@@ -346,7 +346,7 @@ os_setenv(const char *name, const char *value, int overwrite)
23 /*
24 * secure_getenv -- provide GNU secure_getenv for FreeBSD
25 */
26-#ifndef __USE_GNU
27+#if defined(__FreeBSD__)
28 static char *
29 secure_getenv(const char *name)
30 {
31--
322.23.0
33
diff --git a/meta-oe/recipes-extended/pmdk/files/0003-Makefile-Don-t-build-the-examples.patch b/meta-oe/recipes-extended/pmdk/files/0003-Makefile-Don-t-build-the-examples.patch
deleted file mode 100644
index dbe9c45e1..000000000
--- a/meta-oe/recipes-extended/pmdk/files/0003-Makefile-Don-t-build-the-examples.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From ac24c78f5aa62ba43bb87b74301b659bcc506f11 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@wdc.com>
3Date: Thu, 18 Jul 2019 15:40:22 +0800
4Subject: [PATCH] Makefile: Don't build the examples
5
6Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
7Upstream-Status: Inappropriate [disable feature]
8---
9 src/Makefile | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/src/Makefile b/src/Makefile
13index 773ab1387..58912f0ab 100644
14--- a/src/Makefile
15+++ b/src/Makefile
16@@ -37,13 +37,13 @@ include $(TOP)/src/common.inc
17
18 TARGETS = libpmem libvmem libpmemblk libpmemlog libpmemobj libpmempool\
19 libvmmalloc tools
20-ALL_TARGETS = $(TARGETS) common librpmem examples benchmarks
21+ALL_TARGETS = $(TARGETS) common librpmem benchmarks
22
23 SCOPE_DIRS = $(TARGETS) common librpmem rpmem_common
24
25 DEBUG_RELEASE_TARGETS = common libpmem libvmem libpmemblk libpmemlog libpmemobj\
26 libpmempool libvmmalloc librpmem
27-RELEASE_TARGETS = tools examples benchmarks
28+RELEASE_TARGETS = tools benchmarks
29
30 CLEAN_NO_JE_TARGETS = $(ALL_TARGETS) rpmem_common test
31 CLEAN_TARGETS = $(CLEAN_NO_JE_TARGETS) jemalloc
32--
332.14.4
34
diff --git a/meta-oe/recipes-extended/pmdk/pmdk_1.6.bb b/meta-oe/recipes-extended/pmdk/pmdk_1.7.bb
index c8688b2c6..96da266e6 100644
--- a/meta-oe/recipes-extended/pmdk/pmdk_1.6.bb
+++ b/meta-oe/recipes-extended/pmdk/pmdk_1.7.bb
@@ -14,10 +14,10 @@ S = "${WORKDIR}/git"
14SRC_URI = "git://github.com/pmem/pmdk.git \ 14SRC_URI = "git://github.com/pmem/pmdk.git \
15 file://0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch \ 15 file://0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch \
16 file://0002-Makefile-Don-t-install-the-docs.patch \ 16 file://0002-Makefile-Don-t-install-the-docs.patch \
17 file://0003-Makefile-Don-t-build-the-examples.patch \ 17 file://0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch \
18 " 18 "
19 19
20SRCREV = "695e6eba28c53a69a0ef7bad3cc0f45c21ef3e00" 20SRCREV = "bc5e309485df61c452d08367e4b13ba9dfed5071"
21 21
22inherit autotools-brokensep pkgconfig 22inherit autotools-brokensep pkgconfig
23 23
@@ -26,7 +26,7 @@ inherit autotools-brokensep pkgconfig
26# | If you meant to cross compile, use `--host'. 26# | If you meant to cross compile, use `--host'.
27# 27#
28# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp] 28# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
29EXTRA_OEMAKE = "HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}" 29EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
30 30
31# Fix the missing fts libs when using musl 31# Fix the missing fts libs when using musl
32EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'" 32EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"