summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/p7zip
diff options
context:
space:
mode:
authorRaphael Freudiger <raphael.freudiger@siemens.com>2015-02-11 09:11:47 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:40:02 +0100
commit2f14e0b30187b37363d53e4de9ee64e50b6481a9 (patch)
tree14904a041c16b0e54ef00d3c77cea32956671e72 /meta-oe/recipes-extended/p7zip
parent22b1736acceab2ad97093fcca28c93772cdbc08f (diff)
downloadmeta-openembedded-2f14e0b30187b37363d53e4de9ee64e50b6481a9.tar.gz
p7zip: new recipe
p7zip is the command line version of 7-Zip for Unix/Linux. Signed-off-by: Raphael Freudiger <raphael.freudiger@siemens.com> Reviewed-By: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/p7zip')
-rw-r--r--meta-oe/recipes-extended/p7zip/files/do_not_override_compiler_and_do_not_strip.patch31
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb17
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/p7zip/files/do_not_override_compiler_and_do_not_strip.patch b/meta-oe/recipes-extended/p7zip/files/do_not_override_compiler_and_do_not_strip.patch
new file mode 100644
index 000000000..a3b02c5dc
--- /dev/null
+++ b/meta-oe/recipes-extended/p7zip/files/do_not_override_compiler_and_do_not_strip.patch
@@ -0,0 +1,31 @@
1do not override compiler and do not strip
2
3The default makefile sets the compiler to g++ or gcc. This leads to a wrong architecture when cross-compiling.
4Remove the hardcoded compiler and just append the flags to CXX and CC.
5
6Upstream-Status: Pending
7Signed-off-by: Raphael Freudiger <raphael.freudiger@siemens.com>
8Reviewed-By: Pascal Bach <pascal.bach@siemens.com>
9
10Index: p7zip_9.20.1/makefile.machine
11=====================================================================
12--- p7zip_9.20.1/makefile.machine 2011-03-13 12:54:57.000000000 +0100
13+++ p7zip_9.20.1/makefile.machine 2015-02-03 08:39:44.427696944 +0100
14@@ -4,14 +4,14 @@
15
16 OPTFLAGS=-O
17
18-ALLFLAGS=${OPTFLAGS} -pipe -s \
19+ALLFLAGS=${OPTFLAGS} -pipe \
20 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
21 -DNDEBUG -D_REENTRANT -DENV_UNIX \
22 -D_7ZIP_LARGE_PAGES \
23 $(LOCAL_FLAGS)
24
25-CXX=g++ $(ALLFLAGS)
26-CC=gcc $(ALLFLAGS)
27+CXX+=$(ALLFLAGS)
28+CC+=$(ALLFLAGS)
29 CC_SHARED=-fPIC
30 LINK_SHARED=-fPIC -shared
31
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
new file mode 100644
index 000000000..8905ae9d0
--- /dev/null
+++ b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
@@ -0,0 +1,17 @@
1SUMMARY = "7-zip is a commandline utility handling 7z archives."
2HOMEPAGE = "http://www.7-zip.org/"
3LICENSE = "LGPL-2.1+ & unRAR"
4LIC_FILES_CHKSUM = "file://DOCS/copying.txt;md5=ecfc54c9e37b63ac58900061ce2eab5a \
5 file://DOCS/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de"
6
7SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
8 file://do_not_override_compiler_and_do_not_strip.patch"
9SRC_URI[md5sum] = "bd6caaea567dc0d995c990c5cc883c89"
10SRC_URI[sha256sum] = "49557e7ffca08100f9fc687f4dfc5aea703ca207640c76d9dee7b66f03cb4782"
11
12S = "${WORKDIR}/${PN}_${PV}"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/bin/* ${D}${bindir}
17}