diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-15 12:31:08 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-15 12:31:08 +0100 |
commit | a5eae966b971c2fd34356df324dcef2d7eb37c7f (patch) | |
tree | 62475ab3a163bd77ee28561dd040642e18428bc6 /meta-oe/recipes-extended/owfs | |
parent | b20bf09d877bfab81c3a73712b086c0577cac853 (diff) | |
download | meta-openembedded-a5eae966b971c2fd34356df324dcef2d7eb37c7f.tar.gz |
owfs: import 2.8p4 from OE-classic, update to 2.8p14
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/owfs')
-rwxr-xr-x | meta-oe/recipes-extended/owfs/owfs/owhttpd | 60 | ||||
-rwxr-xr-x | meta-oe/recipes-extended/owfs/owfs/owserver | 59 | ||||
-rw-r--r-- | meta-oe/recipes-extended/owfs/owfs_2.8p14.bb | 65 |
3 files changed, 184 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/owfs/owfs/owhttpd b/meta-oe/recipes-extended/owfs/owfs/owhttpd new file mode 100755 index 000000000..5d74d13d9 --- /dev/null +++ b/meta-oe/recipes-extended/owfs/owfs/owhttpd | |||
@@ -0,0 +1,60 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | PATH=/sbin:/bin:/usr/bin | ||
4 | |||
5 | DAEMON="owhttpd" | ||
6 | |||
7 | test -f /usr/bin/${DAEMON} || exit 0 | ||
8 | |||
9 | if test -f /etc/default/${DAEMON} ; then | ||
10 | . /etc/default/${DAEMON} | ||
11 | else | ||
12 | : | ||
13 | fi | ||
14 | |||
15 | if [ "$START_OWHTTPD" != "yes" ] | ||
16 | then | ||
17 | exit 0 | ||
18 | fi | ||
19 | |||
20 | |||
21 | startdaemon(){ | ||
22 | echo -n "Starting ${DAEMON}: " | ||
23 | start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid | ||
24 | echo "done" | ||
25 | } | ||
26 | |||
27 | stopdaemon(){ | ||
28 | echo -n "Stopping ${DAEMON}: " | ||
29 | start-stop-daemon --stop -p /var/run/${DAEMON}.pid | ||
30 | echo "done" | ||
31 | } | ||
32 | |||
33 | |||
34 | |||
35 | case "$1" in | ||
36 | start) | ||
37 | startdaemon | ||
38 | ;; | ||
39 | stop) | ||
40 | stopdaemon | ||
41 | ;; | ||
42 | force-reload) | ||
43 | stopdaemon | ||
44 | startdaemon | ||
45 | ;; | ||
46 | restart) | ||
47 | stopdaemon | ||
48 | startdaemon | ||
49 | ;; | ||
50 | reload) | ||
51 | stopdaemon | ||
52 | startdaemon | ||
53 | ;; | ||
54 | *) | ||
55 | echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2 | ||
56 | exit 1 | ||
57 | ;; | ||
58 | esac | ||
59 | |||
60 | exit 0 | ||
diff --git a/meta-oe/recipes-extended/owfs/owfs/owserver b/meta-oe/recipes-extended/owfs/owfs/owserver new file mode 100755 index 000000000..b69ea53e3 --- /dev/null +++ b/meta-oe/recipes-extended/owfs/owfs/owserver | |||
@@ -0,0 +1,59 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | PATH=/sbin:/bin:/usr/bin | ||
4 | |||
5 | DAEMON="owserver" | ||
6 | |||
7 | test -f /usr/bin/${DAEMON} || exit 0 | ||
8 | |||
9 | if test -f /etc/default/${DAEMON} ; then | ||
10 | . /etc/default/${DAEMON} | ||
11 | else | ||
12 | : | ||
13 | fi | ||
14 | |||
15 | if [ "$START_OWSERVER" != "yes" ] | ||
16 | then | ||
17 | exit 0 | ||
18 | fi | ||
19 | |||
20 | startdaemon(){ | ||
21 | echo -n "Starting ${DAEMON}: " | ||
22 | start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid | ||
23 | echo "done" | ||
24 | } | ||
25 | |||
26 | stopdaemon(){ | ||
27 | echo -n "Stopping ${DAEMON}: " | ||
28 | start-stop-daemon --stop -p /var/run/${DAEMON}.pid | ||
29 | echo "done" | ||
30 | } | ||
31 | |||
32 | |||
33 | |||
34 | case "$1" in | ||
35 | start) | ||
36 | startdaemon | ||
37 | ;; | ||
38 | stop) | ||
39 | stopdaemon | ||
40 | ;; | ||
41 | force-reload) | ||
42 | stopdaemon | ||
43 | startdaemon | ||
44 | ;; | ||
45 | restart) | ||
46 | stopdaemon | ||
47 | startdaemon | ||
48 | ;; | ||
49 | reload) | ||
50 | stopdaemon | ||
51 | startdaemon | ||
52 | ;; | ||
53 | *) | ||
54 | echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2 | ||
55 | exit 1 | ||
56 | ;; | ||
57 | esac | ||
58 | |||
59 | exit 0 | ||
diff --git a/meta-oe/recipes-extended/owfs/owfs_2.8p14.bb b/meta-oe/recipes-extended/owfs/owfs_2.8p14.bb new file mode 100644 index 000000000..1acdcf99b --- /dev/null +++ b/meta-oe/recipes-extended/owfs/owfs_2.8p14.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | DESCRIPTION = "1-Wire file system" | ||
2 | HOMEPAGE = "http://www.owfs.org/" | ||
3 | SECTION = "console/network" | ||
4 | |||
5 | LICENSE = "GPLv2 & LGPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | ||
8 | |||
9 | DEPENDS = "fuse virtual/libusb0" | ||
10 | |||
11 | SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \ | ||
12 | file://owhttpd \ | ||
13 | file://owserver " | ||
14 | SRC_URI[md5sum] = "cd213fd9bbfed95cca2c833c0f14dd72" | ||
15 | SRC_URI[sha256sum] = "88b6ee5e7e4d3fe6f4faf021948236162219cf5d1ff4bf3844e62e6ae2635b23" | ||
16 | |||
17 | inherit autotools update-rc.d | ||
18 | |||
19 | EXTRA_OECONF = " \ | ||
20 | --with-fuseinclude=${STAGING_INCDIR} \ | ||
21 | --with-fuselib=${STAGING_LIBDIR} \ | ||
22 | --enable-owhttpd \ | ||
23 | --enable-cache \ | ||
24 | --enable-mt \ | ||
25 | --disable-swig \ | ||
26 | --disable-owtcl \ | ||
27 | " | ||
28 | |||
29 | do_install_prepend() { | ||
30 | install -d ${D}${sysconfdir}/default/ | ||
31 | install -d ${D}${sysconfdir}/init.d/ | ||
32 | install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd | ||
33 | install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver | ||
34 | } | ||
35 | |||
36 | PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap" | ||
37 | |||
38 | DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access" | ||
39 | DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control" | ||
40 | DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control" | ||
41 | DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access" | ||
42 | DESCRIPTION_libowcapi = "easy C-language 1-wire interface " | ||
43 | DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol" | ||
44 | DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol" | ||
45 | DESCRIPTION_owmon = "Monitor for owserver settings and statistics" | ||
46 | DESCRIPTION_owtap = "Packet sniffer for the owserver protocol" | ||
47 | |||
48 | FILES_owftpd = "${bindir}/owftpd" | ||
49 | FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd" | ||
50 | FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver" | ||
51 | FILES_owshell = "${bindir}/owread ${bindir}/owwrite \ | ||
52 | ${bindir}/owdir ${bindir}/owpresent \ | ||
53 | ${bindir}/owget ${bindir}/owside" | ||
54 | FILES_owmon = "${bindir}/owmon" | ||
55 | FILES_owtap = "${bindir}/owtap" | ||
56 | FILES_libowcapi = "${libdir}/libowcapi-*" | ||
57 | FILES_libow = "${libdir}/libow-*" | ||
58 | FILES_libownet = "${libdir}/libownet-*" | ||
59 | |||
60 | INITSCRIPT_PACKAGES = "owhttpd owserver" | ||
61 | INITSCRIPT_NAME_owserver = "owserver" | ||
62 | INITSCRIPT_NAME_owhttpd = "owhttpd" | ||
63 | INITSCRIPT_PARAMS_owserver = "defaults 20" | ||
64 | INITSCRIPT_PARAMS_owhttpd = "defaults 21" | ||
65 | |||