diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2021-12-02 10:22:38 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-01 20:36:31 -0800 |
commit | 1bacbe783ad81ec23ae4a6954b811a53a4af433d (patch) | |
tree | d223d853b08a60a071539e3ef2c282d2eb8bd3ae /meta-oe/recipes-extended/ostree | |
parent | a7313d45035ea3340c520a98436de7fa4c8cd49a (diff) | |
download | meta-openembedded-1bacbe783ad81ec23ae4a6954b811a53a4af433d.tar.gz |
ostree: add nativesdk support
# Changed in V2: s/$OECORE_NATIVE_SYSROOT/\$OECORE_NATIVE_SYSROOT/ for
# ostree wrapper of nativesdk
Refer the impment of native, use the same PACKAGECONFIG, EXTRA_OECONF
and similar create_wrapper for ostree
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/ostree')
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree_2021.6.bb | 18 |
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb index 8f37a7f86..a80207689 100644 --- a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb +++ b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb | |||
@@ -52,6 +52,13 @@ PACKAGECONFIG:class-native ??= " \ | |||
52 | soup \ | 52 | soup \ |
53 | " | 53 | " |
54 | 54 | ||
55 | PACKAGECONFIG:class-nativesdk ??= " \ | ||
56 | ${@bb.utils.filter('DISTRO_FEATURES', 'selinux smack', d)} \ | ||
57 | builtin-grub2-mkconfig \ | ||
58 | gpgme \ | ||
59 | soup \ | ||
60 | " | ||
61 | |||
55 | PACKAGECONFIG[avahi] = "--with-avahi, --without-avahi, avahi" | 62 | PACKAGECONFIG[avahi] = "--with-avahi, --without-avahi, avahi" |
56 | PACKAGECONFIG[builtin-grub2-mkconfig] = "--with-builtin-grub2-mkconfig, --without-builtin-grub2-mkconfig" | 63 | PACKAGECONFIG[builtin-grub2-mkconfig] = "--with-builtin-grub2-mkconfig, --without-builtin-grub2-mkconfig" |
57 | PACKAGECONFIG[curl] = "--with-curl, --without-curl, curl" | 64 | PACKAGECONFIG[curl] = "--with-curl, --without-curl, curl" |
@@ -89,6 +96,11 @@ EXTRA_OECONF:class-native = " \ | |||
89 | --disable-otmpfile \ | 96 | --disable-otmpfile \ |
90 | " | 97 | " |
91 | 98 | ||
99 | EXTRA_OECONF:class-nativesdk = " \ | ||
100 | --enable-wrpseudo-compat \ | ||
101 | --disable-otmpfile \ | ||
102 | " | ||
103 | |||
92 | # Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the | 104 | # Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the |
93 | # do_configure stage so we do depend on it | 105 | # do_configure stage so we do depend on it |
94 | SYSROOT_DIR = "${STAGING_DIR_TARGET}" | 106 | SYSROOT_DIR = "${STAGING_DIR_TARGET}" |
@@ -106,6 +118,10 @@ do_install:append:class-native() { | |||
106 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" | 118 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" |
107 | } | 119 | } |
108 | 120 | ||
121 | do_install:append:class-nativesdk() { | ||
122 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="\$OECORE_NATIVE_SYSROOT/usr/lib/ostree/ostree-grub-generator" | ||
123 | } | ||
124 | |||
109 | PACKAGE_BEFORE_PN = " \ | 125 | PACKAGE_BEFORE_PN = " \ |
110 | ${PN}-dracut \ | 126 | ${PN}-dracut \ |
111 | ${PN}-grub \ | 127 | ${PN}-grub \ |
@@ -186,4 +202,4 @@ RRECOMMENDS:${PN} += "kernel-module-overlay" | |||
186 | SYSTEMD_SERVICE:${PN} = "ostree-remount.service ostree-finalize-staged.path" | 202 | SYSTEMD_SERVICE:${PN} = "ostree-remount.service ostree-finalize-staged.path" |
187 | SYSTEMD_SERVICE:${PN}-switchroot = "ostree-prepare-root.service" | 203 | SYSTEMD_SERVICE:${PN}-switchroot = "ostree-prepare-root.service" |
188 | 204 | ||
189 | BBCLASSEXTEND = "native" | 205 | BBCLASSEXTEND = "native nativesdk" |