summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/openlmi
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-08-25 13:19:56 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:12 +0200
commit1f7e41d5570eef9b3f33a2c002ab9894be41917d (patch)
tree57a9b8f88bf3ddac8094fbcb8a271c4df84aaa90 /meta-oe/recipes-extended/openlmi
parentbe019b379479f4df346b34a940ec46aaa3534d22 (diff)
downloadmeta-openembedded-1f7e41d5570eef9b3f33a2c002ab9894be41917d.tar.gz
openlmi: add openlmi
OpenLMI = Open Linux Management Infrastructure. OpenLMI is open-source project aiming to improve management of Linux systems using WBEM standards. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/openlmi')
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-networking/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch31
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb30
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-error.patch26
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch31
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb54
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb32
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb23
7 files changed, 227 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-networking/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch b/meta-oe/recipes-extended/openlmi/openlmi-networking/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch
new file mode 100644
index 000000000..c23820094
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-networking/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch
@@ -0,0 +1,31 @@
1From 336bb5a031077461ec6b2e5438738bf100f0dd2f Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@cn.fujitsu.com>
3Date: Mon, 3 Aug 2015 02:37:46 +0900
4Subject: [PATCH] fix lib64 can not be shiped in 64bit target
5
6Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
7---
8 CMakeLists.txt | 7 -------
9 1 file changed, 7 deletions(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 1ba3cd3..2411745 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -35,13 +35,6 @@ if (DEBUG)
16 add_definitions("-DDEBUG_ENABLED")
17 endif (DEBUG)
18
19-# Set LIB_SUFFIX to 64 on 64bit architectures
20-if(CMAKE_SIZEOF_VOID_P EQUAL 4)
21- set(LIB_SUFFIX "")
22-else(CMAKE_SIZEOF_VOID_P EQUAL 4)
23- SET(LIB_SUFFIX 64)
24-endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
25-
26 # Find OpenLMIMacros when installed in other prefix than /usr (e.g. /usr/local)
27 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_INSTALL_PREFIX})
28 include(OpenLMIMacros RESULT_VARIABLE LMIMACROS)
29--
301.8.4.2
31
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb b/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb
new file mode 100644
index 000000000..54429108b
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-networking_0.3.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "CIM providers for network management"
2DESCRIPTION = "\
3openlmi-networking is set of CMPI providers for network management using \
4Common Information Model (CIM)."
5HOMEPAGE = "http://www.openlmi.org/"
6LICENSE = "LGPL-2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
8SECTION = "System/Management"
9DEPENDS = "openlmi-providers konkretcmpi sblim-cmpi-devel cim-schema-exper networkmanager dbus libcheck glib-2.0"
10
11SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
12 file://0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch \
13 "
14SRC_URI[md5sum] = "f20de8c76fb6a80001b14c1eb035953e"
15SRC_URI[sha256sum] = "578eaa5c65fe924b5d7aeb635509dd46443166cd6a88b019bc42646e3518a460"
16
17inherit cmake
18
19EXTRA_OECMAKE = "${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
20 ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
21 "
22
23
24do_configure_prepend() {
25 export CMAKE_INSTALL_DATDIR="${STAGING_DATADIR}"
26}
27
28
29FILES_${PN} =+ "${libdir}/cmpi/libcmpiLMI_Networking.so ${prefix}/libexec*"
30FILES_${PN}-dbg =+ "${libdir}/cmpi/.debug*"
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-error.patch b/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-error.patch
new file mode 100644
index 000000000..4bcd1c4d9
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-error.patch
@@ -0,0 +1,26 @@
1From 764171866b84e0198b67538f63022abde3e628ad Mon Sep 17 00:00:00 2001
2From: Qian Lei <qianl.fnst@cn.fujitsu.com>
3Date: Fri, 16 Jan 2015 14:15:25 +0800
4Subject: [PATCH] fix error
5
6Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
7---
8 cmake/modules/OpenLMIMacros.cmake | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/cmake/modules/OpenLMIMacros.cmake b/cmake/modules/OpenLMIMacros.cmake
12index d55f983..dbc32ec 100644
13--- a/cmake/modules/OpenLMIMacros.cmake
14+++ b/cmake/modules/OpenLMIMacros.cmake
15@@ -89,7 +89,7 @@ macro(konkretcmpi_generate MOFS CIM_PROVIDERS CIM_HEADERS CIM_CLASSES)
16 endforeach(CLASS ${CIM_CLASS_NAMES})
17
18 # Generate headers for CIM classes
19- set(ENV{KONKRET_SCHEMA_DIR} "/usr/share/mof/cim-current")
20+ set(ENV{KONKRET_SCHEMA_DIR} "$ENV{CMAKE_INSTALL_DATDIR}/mof/cim-current")
21 execute_process(COMMAND ${KONKRETCMPI_KONKRET}
22 ${KONKRET_MOF_FILES}
23 ${GENERATE_PROVIDERS}
24--
251.8.3.1
26
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch b/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch
new file mode 100644
index 000000000..9c8ebe4c0
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-providers/0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch
@@ -0,0 +1,31 @@
1From 7cecfa95f033b33a1c3260c214b2d0e5e81b4fd3 Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@cn.fujitsu.com>
3Date: Mon, 3 Aug 2015 02:05:56 +0900
4Subject: [PATCH] fix lib64 can not be shiped in 64bit target
5
6Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
7---
8 CMakeLists.txt | 7 -------
9 1 file changed, 7 deletions(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 48ae206..3ead9c6 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -21,13 +21,6 @@ else(HAS_STACK_PROTECTOR_STRONG)
16 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector")
17 endif()
18
19-# Set LIB_SUFFIX to 64 on 64bit architectures
20-if(CMAKE_SIZEOF_VOID_P EQUAL 4)
21- set(LIB_SUFFIX "")
22-else(CMAKE_SIZEOF_VOID_P EQUAL 4)
23- SET(LIB_SUFFIX 64)
24-endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
25-
26 if(NOT SYSCONF_INSTALL_DIR)
27 set(SYSCONF_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/etc)
28 endif(NOT SYSCONF_INSTALL_DIR)
29--
301.8.4.2
31
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb b/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb
new file mode 100644
index 000000000..f74fb7781
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-providers_0.6.0.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Set of basic CIM providers"
2DESCRIPTION = "\
3openlmi-providers is set of (usually) small CMPI providers (agents) for \
4basic monitoring and management of host system using Common Information \
5Model (CIM)."
6HOMEPAGE = "http://www.openlmi.org/"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
9SECTION = "System/Management"
10DEPENDS = "konkretcmpi-native konkretcmpi sblim-sfcb sblim-cmpi-devel cim-schema-exper lmsensors libuser swig swig-native dbus udev systemd-systemctl-native pciutils"
11
12SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
13 file://0001-fix-error.patch \
14 file://0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch \
15 "
16SRC_URI[md5sum] = "5904f23cf494946237cfbbdbe644a3cd"
17SRC_URI[sha256sum] = "e2b2fbeaec45a83905d0da3b87da83904d9cd94c1b86312f844587b3fff11f56"
18
19inherit cmake
20LDFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
21EXTRA_OECMAKE = " \
22 -DWITH-DEVASSISTANT=OFF \
23 -DWITH-JOURNALD=OFF \
24 -DWITH-SERVICE=OFF \
25 -DWITH-SERVICE-LEGACY=ON \
26 -DWITH-ACCOUNT=OFF \
27 -DWITH-PCP=OFF \
28 -DWITH-REALMD=OFF \
29 -DWITH-FAN=OFF \
30 -DWITH-LOCALE=OFF \
31 -DWITH-INDSENDER=OFF \
32 -DWITH-JOBMANAGER=OFF \
33 -DWITH-SSSD=OFF \
34 -DWITH-SELINUX=OFF \
35 -DWITH-SOFTWARE-DBUS=ON \
36 ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
37 ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
38 "
39
40do_configure_prepend() {
41 export CMAKE_INSTALL_DATDIR="${STAGING_DATADIR}"
42}
43
44do_install_append() {
45 if [ -d ${D}${prefix}${sysconfidr} ]; then
46 mv ${D}${prefix}${sysconfdir} ${D}${sysconfdir}
47 fi
48}
49
50FILES_${PN} =+ "${libdir}/cmpi/libcmpiLMI* ${prefix}/libexec*"
51FILES_${PN}-dev =+ "${datadir}/cmake*"
52FILES_${PN}-dbg =+ "${libdir}/cmpi/.debug*"
53
54RDEPENDS_${PN} = "python"
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
new file mode 100644
index 000000000..015d80339
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "CIM providers for storage management"
2DESCRIPTION = "\
3The openlmi-storage package contains CMPI providers for management of storage \
4using Common Information Managemen (CIM) protocol. \
5\
6The providers can be registered in any CMPI-aware CIMOM, both OpenPegasus and \
7SFCB were tested."
8HOMEPAGE = "http://www.openlmi.org/"
9LICENSE = "LGPL-2.1+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "System/Management"
12DEPENDS = "openlmi-providers pywbem cmpi-bindings"
13RDEPENDS_${PN} += "bash"
14
15SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz"
16SRC_URI[md5sum] = "898cf0d8c03b8ad6b45d65f335ddee0d"
17SRC_URI[sha256sum] = "4a1ba9957750f94ea58a89cea28985564f38d7cc9aa00fcae20c51e7b32bd0a8"
18
19inherit setuptools
20
21do_install_append() {
22 install -m 755 -d ${D}${datadir}/${BPN}
23 install -m 644 ${S}/mof/* ${D}${datadir}/${BPN}/
24
25 install -m 755 -d ${D}${sysconfdir}/openlmi/storage
26 install -m 644 storage.conf ${D}${sysconfdir}/openlmi/storage/storage.conf
27
28 install -m 755 -d ${D}${libexecdir}/pegasus
29 install -m 755 pycmpiLMI_Storage-cimprovagt ${D}${libexecdir}/pegasus/
30}
31
32FILES_${PN} =+ "${sysconfdir}/openlmi/storage/storage.conf ${datadir}/${BPN}/*"
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
new file mode 100644
index 000000000..b23869d76
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Set of CLI tools for Openlmi providers"
2DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
3HOMEPAGE = "http://www.openlmi.org/"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
6SECTION = "System/Management"
7
8inherit setuptools
9
10DEPENDS = "python-native pywbem-native python-m2crypto pywbem"
11
12SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
13 "
14SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
15SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
16
17do_compile_prepend() {
18 cd cli
19 sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py
20}
21do_install_prepend() {
22 cd cli
23}