summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2011-12-06 14:51:17 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-06 16:37:29 +0100
commit4a00432856fe8bb074506f9968fb8b7d4edbd597 (patch)
treea363e762203fc435fa34c825fd14622d9daf46ea /meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb
parenta4d6623d1604fc4946ed1366560b20f91ab7e2d0 (diff)
downloadmeta-openembedded-4a00432856fe8bb074506f9968fb8b7d4edbd597.tar.gz
nostromo-1.9.5: add recipe
Nostromo is a simple, fast and secure webserver. The patch was imported from the OpenEmbedded git server (git://git.openembedded.org/openembedded) as of commit id 2218504b0413efaf2b1f643a802176eb803a9bf6 and updated to the latest stable version available. Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb')
-rw-r--r--meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb b/meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb
new file mode 100644
index 000000000..a368887ab
--- /dev/null
+++ b/meta-oe/recipes-extended/nostromo/nostromo_1.9.5.bb
@@ -0,0 +1,51 @@
1HOMEPAGE = "http://www.nazgul.ch/dev_nostromo.html"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://src/nhttpd/main.c;beginline=2;endline=14;md5=e5ec3fa723b29b7d59d205afd8d36938"
4
5SRC_URI = "http://www.nazgul.ch/dev/${PN}-${PV}.tar.gz \
6 file://0001-GNUmakefile-add-possibility-to-override-variables.patch \
7 file://nhttpd.conf \
8 file://volatiles \
9 file://nostromo \
10 "
11
12TARGET_CC_ARCH += "${LDFLAGS}"
13
14DEPENDS = "openssl"
15
16inherit update-rc.d
17
18INITSCRIPT_NAME = "nostromo"
19INITSCRIPT_PARAMS = "defaults 70"
20
21do_compile() {
22 oe_runmake
23}
24
25do_install() {
26 install -d ${D}/${sbindir}
27 install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd
28 install -m 0755 src/tools/crypt ${D}/${sbindir}/crypt
29 install -d ${D}/${mandir}/man8
30 install -m 0444 src/nhttpd/nhttpd.8 ${D}/${mandir}/man8/nhttpd.8
31 install -d ${D}${localstatedir}/nostromo/conf
32 install -d ${D}${localstatedir}/nostromo/htdocs/cgi-bin
33 install -d ${D}${localstatedir}/nostromo/icons
34 install -d ${D}${localstatedir}/log/nostromo
35 install -d ${D}${localstatedir}/run/nostromo
36 install -d ${D}${sysconfdir}/init.d
37 install -m 0644 conf/mimes ${D}${localstatedir}/nostromo/conf/mimes
38 install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir}
39 install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d
40 install -c -D -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo
41 install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html
42 install -m 0644 htdocs/nostromo.gif ${D}${localstatedir}/nostromo/htdocs/nostromo.gif
43 install -m 0644 icons/dir.gif ${D}${localstatedir}/nostromo/icons/dir.gif
44 install -m 0644 icons/file.gif ${D}${localstatedir}/nostromo/icons/file.gif
45 chown -R www-data:www-data ${D}/${localstatedir}/nostromo ${D}/${localstatedir}/log/nostromo ${D}/${localstatedir}/run/nostromo
46}
47
48SRC_URI[md5sum] = "dc6cfd6b5aae04c370c7f818fa7bde55"
49SRC_URI[sha256sum] = "5f62578285e02449406b46cf06a7888fe3dc4a90bedf58cc18523bad62f6b914"
50
51CONFFILES_${PN} += "/var/nostromo/conf/mimes ${sysconfdir}/nhttpd.conf"