summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/net-snmp/net-snmp.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-extended/net-snmp/net-snmp.inc
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/net-snmp/net-snmp.inc')
-rw-r--r--meta-oe/recipes-extended/net-snmp/net-snmp.inc56
1 files changed, 28 insertions, 28 deletions
diff --git a/meta-oe/recipes-extended/net-snmp/net-snmp.inc b/meta-oe/recipes-extended/net-snmp/net-snmp.inc
index e369ccf03..5a6ec9f16 100644
--- a/meta-oe/recipes-extended/net-snmp/net-snmp.inc
+++ b/meta-oe/recipes-extended/net-snmp/net-snmp.inc
@@ -19,26 +19,26 @@ EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
19${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}" 19${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}"
20 20
21do_install () { 21do_install () {
22 oe_runmake install 22 oe_runmake install
23} 23}
24 24
25do_install_append() { 25do_install_append() {
26 install -d ${D}${sysconfdir}/snmp 26 install -d ${D}${sysconfdir}/snmp
27 install -d ${D}${sysconfdir}/init.d 27 install -d ${D}${sysconfdir}/init.d
28 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/snmpd 28 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/snmpd
29 install -m 644 ${WORKDIR}/snmpd.conf ${D}${sysconfdir}/snmp/ 29 install -m 644 ${WORKDIR}/snmpd.conf ${D}${sysconfdir}/snmp/
30 install -m 644 ${WORKDIR}/snmptrapd.conf ${D}${sysconfdir}/snmp/ 30 install -m 644 ${WORKDIR}/snmptrapd.conf ${D}${sysconfdir}/snmp/
31 install -d ${STAGING_BINDIR} 31 install -d ${STAGING_BINDIR}
32 install -m 0755 ${D}${bindir}/net-snmp-config ${STAGING_BINDIR}/ 32 install -m 0755 ${D}${bindir}/net-snmp-config ${STAGING_BINDIR}/
33 sed -e "s@-I/usr/include@@g" \ 33 sed -e "s@-I/usr/include@@g" \
34 -e "s@^prefix=.*@prefix=${STAGING_DIR_HOST}@g" \ 34 -e "s@^prefix=.*@prefix=${STAGING_DIR_HOST}@g" \
35 -e "s@^exec_prefix=.*@exec_prefix=${STAGING_DIR_HOST}@g" \ 35 -e "s@^exec_prefix=.*@exec_prefix=${STAGING_DIR_HOST}@g" \
36 -e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \ 36 -e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \
37 -e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \ 37 -e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \
38 -i ${STAGING_BINDIR}/net-snmp-config 38 -i ${STAGING_BINDIR}/net-snmp-config
39 install -d ${D}${systemd_unitdir}/system 39 install -d ${D}${systemd_unitdir}/system
40 install -m 0644 ${WORKDIR}/snmpd.service ${D}${systemd_unitdir}/system 40 install -m 0644 ${WORKDIR}/snmpd.service ${D}${systemd_unitdir}/system
41 install -m 0644 ${WORKDIR}/snmptrapd.service ${D}${systemd_unitdir}/system 41 install -m 0644 ${WORKDIR}/snmptrapd.service ${D}${systemd_unitdir}/system
42} 42}
43 43
44PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-dev ${PN}-staticdev ${PN}-static ${PN}-libs \ 44PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-dev ${PN}-staticdev ${PN}-static ${PN}-libs \
@@ -48,13 +48,13 @@ ALLOW_EMPTY_${PN}-server = "1"
48FILES_${PN}-libs = "${libdir}/lib*${SOLIBS}" 48FILES_${PN}-libs = "${libdir}/lib*${SOLIBS}"
49FILES_${PN}-mibs = "${datadir}/snmp/mibs" 49FILES_${PN}-mibs = "${datadir}/snmp/mibs"
50FILES_${PN}-server-snmpd = "${sbindir}/snmpd \ 50FILES_${PN}-server-snmpd = "${sbindir}/snmpd \
51 ${sysconfdir}/snmp/snmpd.conf \ 51 ${sysconfdir}/snmp/snmpd.conf \
52 ${sysconfdir}/init.d \ 52 ${sysconfdir}/init.d \
53 ${systemd_unitdir}/system/snmpd.service \ 53 ${systemd_unitdir}/system/snmpd.service \
54" 54"
55FILES_${PN}-server-snmptrapd = "${sbindir}/snmptrapd \ 55FILES_${PN}-server-snmptrapd = "${sbindir}/snmptrapd \
56 ${sysconfdir}/snmp/snmptrapd.conf \ 56 ${sysconfdir}/snmp/snmptrapd.conf \
57 ${systemd_unitdir}/system/snmptrapd.service \ 57 ${systemd_unitdir}/system/snmptrapd.service \
58" 58"
59FILES_${PN}-client = "${bindir}/* ${datadir}/snmp/" 59FILES_${PN}-client = "${bindir}/* ${datadir}/snmp/"
60FILES_${PN}-dbg += "${libdir}/.debug/ ${sbindir}/.debug/ ${bindir}/.debug/" 60FILES_${PN}-dbg += "${libdir}/.debug/ ${sbindir}/.debug/ ${bindir}/.debug/"
@@ -86,10 +86,10 @@ RCONFLICTS_${PN}-server-snmptrapd += "${PN}-server-snmptrapd-systemd"
86LEAD_SONAME = "libnetsnmp.so" 86LEAD_SONAME = "libnetsnmp.so"
87 87
88pkg_postrm_${PN}-server() { 88pkg_postrm_${PN}-server() {
89 if test "x$D" != "x"; then 89 if test "x$D" != "x"; then
90 OPT="-r $D " 90 OPT="-r $D "
91 else 91 else
92 OPT="" 92 OPT=""
93 /etc/init.d/snmpd stop 93 /etc/init.d/snmpd stop
94 fi 94 fi
95} 95}