diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2015-01-23 14:03:31 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-02-12 19:31:51 +0100 |
commit | 34c8c858833ada1f596e776ba89924e3cddf34af (patch) | |
tree | eaf93c0087fed5e935d68750450792991c01e813 /meta-oe/recipes-extended/nana | |
parent | 4e08e7c3a5c36c859e01e4d2168ea3e1b287bcc0 (diff) | |
download | meta-openembedded-34c8c858833ada1f596e776ba89924e3cddf34af.tar.gz |
nana: add new recipe
GNU Nana is a free library providing improved support for assertion
checking (as in assert.h) and logging (printf style debugging) in
GNU C and C++.
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/nana')
3 files changed, 211 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch b/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch new file mode 100644 index 000000000..653a7e44c --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 7b04c4873c0a4510bdaf9145bf01ca34b3549fdb Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Thu, 4 Dec 2014 03:50:19 +0900 | ||
4 | Subject: [PATCH 1/2] change mandir to DESTDIR | ||
5 | |||
6 | Upstream-Status: pending | ||
7 | |||
8 | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> | ||
9 | --- | ||
10 | man/Makefile.am | 2 +- | ||
11 | man/Makefile.in | 2 +- | ||
12 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/man/Makefile.am b/man/Makefile.am | ||
15 | index 80d24d8..944bc57 100644 | ||
16 | --- a/man/Makefile.am | ||
17 | +++ b/man/Makefile.am | ||
18 | @@ -16,5 +16,5 @@ install-data-local: | ||
19 | @sect=1; \ | ||
20 | inst=`echo "nana" | sed '$(transform)'`.1; \ | ||
21 | echo installing nana.1 as $(mandir)/man$$sect/$$inst; \ | ||
22 | - $(INSTALL_DATA) $(srcdir)/nana.1 $(mandir)/man$$sect/$$inst | ||
23 | + $(INSTALL_DATA) $(srcdir)/nana.1 $(DESTDIR)$(mandir)/man$$sect/$$inst | ||
24 | |||
25 | diff --git a/man/Makefile.in b/man/Makefile.in | ||
26 | index 6008b20..64bb84c 100644 | ||
27 | --- a/man/Makefile.in | ||
28 | +++ b/man/Makefile.in | ||
29 | @@ -274,7 +274,7 @@ install-data-local: | ||
30 | @sect=1; \ | ||
31 | inst=`echo "nana" | sed '$(transform)'`.1; \ | ||
32 | echo installing nana.1 as $(mandir)/man$$sect/$$inst; \ | ||
33 | - $(INSTALL_DATA) $(srcdir)/nana.1 $(mandir)/man$$sect/$$inst | ||
34 | + $(INSTALL_DATA) $(srcdir)/nana.1 $(DESTDIR)$(mandir)/man$$sect/$$inst | ||
35 | |||
36 | # Tell versions [3.59,3.63) of GNU make to not export all variables. | ||
37 | # Otherwise a system limit (for SysV at least) may be exceeded. | ||
38 | -- | ||
39 | 1.8.4.2 | ||
40 | |||
diff --git a/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch b/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch new file mode 100644 index 000000000..aeb25466c --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch | |||
@@ -0,0 +1,137 @@ | |||
1 | From 679e33bfe74d713240fdd930602b993b937dce39 Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Fri, 23 Jan 2015 03:30:47 +0900 | ||
4 | Subject: [PATCH] modify acinclude.m4 and configure.in | ||
5 | |||
6 | this patch is from Debian to fix build errors. | ||
7 | "acinclude.m4:34: error: automatic de-ANSI-fication | ||
8 | support has been removed" | ||
9 | |||
10 | Upstream-Status: pending | ||
11 | |||
12 | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> | ||
13 | --- | ||
14 | acinclude.m4 | 79 ------------------------------------------------------------ | ||
15 | configure.in | 12 +++++++++ | ||
16 | 2 files changed, 12 insertions(+), 79 deletions(-) | ||
17 | |||
18 | diff --git a/acinclude.m4 b/acinclude.m4 | ||
19 | index e9e5500..d467fb5 100644 | ||
20 | --- a/acinclude.m4 | ||
21 | +++ b/acinclude.m4 | ||
22 | @@ -30,82 +30,3 @@ AC_SUBST($1) | ||
23 | ## ------------------------------- ## | ||
24 | ## Check for function prototypes. ## | ||
25 | ## ------------------------------- ## | ||
26 | - | ||
27 | -AC_DEFUN(fp_C_PROTOTYPES, | ||
28 | -[AC_REQUIRE([AM_PROG_CC_STDC]) | ||
29 | -AC_MSG_CHECKING([for function prototypes]) | ||
30 | -if test "$ac_cv_prog_cc_stdc" != no; then | ||
31 | - AC_MSG_RESULT(yes) | ||
32 | - AC_DEFINE(PROTOTYPES) | ||
33 | - U= ANSI2KNR= | ||
34 | -else | ||
35 | - AC_MSG_RESULT(no) | ||
36 | - U=_ ANSI2KNR=./ansi2knr | ||
37 | -fi | ||
38 | -AC_SUBST(U)dnl | ||
39 | -AC_SUBST(ANSI2KNR)dnl | ||
40 | -]) | ||
41 | - | ||
42 | -## ----------------------------------------- ## | ||
43 | -## ANSIfy the C compiler whenever possible. ## | ||
44 | -## ----------------------------------------- ## | ||
45 | - | ||
46 | -# @defmac AC_PROG_CC_STDC | ||
47 | -# @maindex PROG_CC_STDC | ||
48 | -# @ovindex CC | ||
49 | -# If the C compiler in not in ANSI C mode by default, try to add an option | ||
50 | -# to output variable @code{CC} to make it so. This macro tries various | ||
51 | -# options that select ANSI C on some system or another. It considers the | ||
52 | -# compiler to be in ANSI C mode if it defines @code{__STDC__} to 1 and | ||
53 | -# handles function prototypes correctly. | ||
54 | -# | ||
55 | -# If you use this macro, you should check after calling it whether the C | ||
56 | -# compiler has been set to accept ANSI C; if not, the shell variable | ||
57 | -# @code{ac_cv_prog_cc_stdc} is set to @samp{no}. If you wrote your source | ||
58 | -# code in ANSI C, you can make an un-ANSIfied copy of it by using the | ||
59 | -# program @code{ansi2knr}, which comes with Ghostscript. | ||
60 | -# @end defmac | ||
61 | - | ||
62 | -AC_DEFUN(fp_PROG_CC_STDC, | ||
63 | -[AC_MSG_CHECKING(for ${CC-cc} option to accept ANSI C) | ||
64 | -AC_CACHE_VAL(ac_cv_prog_cc_stdc, | ||
65 | -[ac_cv_prog_cc_stdc=no | ||
66 | -ac_save_CFLAGS="$CFLAGS" | ||
67 | -# Don't try gcc -ansi; that turns off useful extensions and | ||
68 | -# breaks some systems' header files. | ||
69 | -# AIX -qlanglvl=ansi | ||
70 | -# Ultrix and OSF/1 -std1 | ||
71 | -# HP-UX -Aa -D_HPUX_SOURCE | ||
72 | -# SVR4 -Xc | ||
73 | -for ac_arg in "" -qlanglvl=ansi -std1 "-Aa -D_HPUX_SOURCE" -Xc | ||
74 | -do | ||
75 | - CFLAGS="$ac_save_CFLAGS $ac_arg" | ||
76 | - AC_TRY_COMPILE( | ||
77 | -[#if !defined(__STDC__) || __STDC__ != 1 | ||
78 | -choke me | ||
79 | -#endif | ||
80 | -], [int test (int i, double x); | ||
81 | -struct s1 {int (*f) (int a);}; | ||
82 | -struct s2 {int (*f) (double a);};], | ||
83 | -[ac_cv_prog_cc_stdc="$ac_arg"; break]) | ||
84 | -done | ||
85 | -CFLAGS="$ac_save_CFLAGS" | ||
86 | -]) | ||
87 | -AC_MSG_RESULT($ac_cv_prog_cc_stdc) | ||
88 | -case "x$ac_cv_prog_cc_stdc" in | ||
89 | - x|xno) ;; | ||
90 | - *) CC="$CC $ac_cv_prog_cc_stdc" ;; | ||
91 | -esac | ||
92 | -]) | ||
93 | - | ||
94 | -## --------------------------------------------------------- ## | ||
95 | -## Use AC_PROG_INSTALL, supplementing it with INSTALL_SCRIPT ## | ||
96 | -## substitution. ## | ||
97 | -## --------------------------------------------------------- ## | ||
98 | - | ||
99 | -AC_DEFUN(fp_PROG_INSTALL, | ||
100 | -[AC_PROG_INSTALL | ||
101 | -test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 755' | ||
102 | -AC_SUBST(INSTALL_SCRIPT)dnl | ||
103 | -]) | ||
104 | - | ||
105 | diff --git a/configure.in b/configure.in | ||
106 | index 6b25ed5..a6a7f5b 100644 | ||
107 | --- a/configure.in | ||
108 | +++ b/configure.in | ||
109 | @@ -103,6 +103,12 @@ nana_DEFINE(DI_MAKE_VALID_BREAKPOINT,(exprn), | ||
110 | sparc-*-*|i?86-*-*) | ||
111 | DI_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
112 | ;; | ||
113 | + arm*-*-*|frv-*-*|mips*-*-*) | ||
114 | + DI_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
115 | + ;; | ||
116 | + sh*-*-*) | ||
117 | + DI_MAKE_VALID_BREAKPOINT='asm("nop\n\tnop\n\t")' | ||
118 | + ;; | ||
119 | esac | ||
120 | ]) | ||
121 | |||
122 | @@ -113,6 +119,12 @@ nana_DEFINE(DL_MAKE_VALID_BREAKPOINT,(), | ||
123 | sparc-*-*|i?86-*-*) | ||
124 | DL_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
125 | ;; | ||
126 | + arm*-*-*|frv-*-*|mips*-*-*) | ||
127 | + DL_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
128 | + ;; | ||
129 | + sh*-*-*) | ||
130 | + DL_MAKE_VALID_BREAKPOINT='asm("nop\n\tnop\n\t")' | ||
131 | + ;; | ||
132 | esac | ||
133 | ]) | ||
134 | |||
135 | -- | ||
136 | 1.8.4.2 | ||
137 | |||
diff --git a/meta-oe/recipes-extended/nana/nana_2.5.bb b/meta-oe/recipes-extended/nana/nana_2.5.bb new file mode 100644 index 000000000..e55cec884 --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana_2.5.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Support for assertion checking and logging in GNU C/C++" | ||
2 | DESCRIPTION = "GNU Nana is a free library providing improved support for assertion\ | ||
3 | checking (as in assert.h) and logging (printf style debugging) in \ | ||
4 | GNU C and C++." | ||
5 | SECTION = "Development/Languages/C and C++" | ||
6 | |||
7 | SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${BP}.tar.gz \ | ||
8 | file://change-mandir-to-DESTDIR.patch \ | ||
9 | file://modify-acinclude.m4-and-configure.in.patch \ | ||
10 | " | ||
11 | SRC_URI[md5sum] = "66c88aa0ad095b2e67673773135475f1" | ||
12 | SRC_URI[sha256sum] = "fd1819ffea94b209513959447e4802afe2719600e7d161cd78b265a42812affa" | ||
13 | |||
14 | LICENSE = "BSD-2-Clause" | ||
15 | |||
16 | LIC_FILES_CHKSUM = "file://COPYING;md5=16aa57f3b7fdda870cee597275bd5d11" | ||
17 | |||
18 | inherit autotools-brokensep pkgconfig | ||
19 | |||
20 | EXTRA_OEMAKE = "DESTDIR=${D}" | ||
21 | |||
22 | do_configure_prepend_virtclass-nativesdk() { | ||
23 | sed -i -e 's:@CPP@:\$\{CXX\} \$\{CXXFLAGS\} \-E:g' ${S}/src/nana.in | ||
24 | sed -i -e 's:@CC@:\$\{CC\} \$\{CFLAGS\} \-E:g' ${S}/src/nana-clg.in | ||
25 | sed -i -e 's:@CXX@::g' ${S}/src/nana-c++lg.in | ||
26 | sed -i -e 's:@GDB@:\$\{GDB\}:g' ${S}/src/nana-run.in | ||
27 | } | ||
28 | |||
29 | do_install_prepend() { | ||
30 | install -d ${D}${mandir}/man1 | ||
31 | install -d ${D}${mandir}/man3 | ||
32 | install -d ${D}${datadir}/info | ||
33 | } | ||
34 | BBCLASSEXTEND = "native nativesdk" | ||