diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2018-01-27 02:24:28 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-02-11 11:50:56 -0800 |
commit | 75356b6a76e965f6e282e8219e88afc1ab4f3240 (patch) | |
tree | 6a8fb4def143c0139c7048f42844582175ba902d /meta-oe/recipes-extended/mraa | |
parent | 427184e46a1b9138159f0baa5db497807b0a65a1 (diff) | |
download | meta-openembedded-75356b6a76e965f6e282e8219e88afc1ab4f3240.tar.gz |
mraa: fix build for musl
* be16toh and le16toh are defined in endian.h
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mraa')
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa_git.bb | 2 |
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch new file mode 100644 index 000000000..401949e2e --- /dev/null +++ b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 6c2649718fc9818da0d602a0b4767ea21a367e9e Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <timothy.t.orling@linux.intel.com> | ||
3 | Date: Sat, 27 Jan 2018 02:06:36 -0800 | ||
4 | Subject: [PATCH] examples/iio_driver.c: include endian.h to fix musl build | ||
5 | |||
6 | * be16toh and le16toh are defined in endian.h | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> | ||
11 | --- | ||
12 | examples/iio_driver.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/examples/iio_driver.c b/examples/iio_driver.c | ||
16 | index c5a0181..e3dc438 100644 | ||
17 | --- a/examples/iio_driver.c | ||
18 | +++ b/examples/iio_driver.c | ||
19 | @@ -23,6 +23,7 @@ | ||
20 | */ | ||
21 | |||
22 | #include <unistd.h> | ||
23 | +#include <endian.h> | ||
24 | #include "mraa/iio.h" | ||
25 | |||
26 | static void | ||
27 | -- | ||
28 | 2.13.6 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb index c4b9c6f90..e1d593cbe 100644 --- a/meta-oe/recipes-extended/mraa/mraa_git.bb +++ b/meta-oe/recipes-extended/mraa/mraa_git.bb | |||
@@ -10,6 +10,8 @@ PV = "1.7.0-git${SRCPV}" | |||
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" | 11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" |
12 | 12 | ||
13 | SRC_URI_append_libc-musl = " file://0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch" | ||
14 | |||
13 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
14 | 16 | ||
15 | # CMakeLists.txt checks the architecture, only x86 and ARM supported for now | 17 | # CMakeLists.txt checks the architecture, only x86 and ARM supported for now |