diff options
author | Brendan Le Foll <brendan.le.foll@intel.com> | 2018-02-21 14:50:41 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-01 16:12:55 -0800 |
commit | efc2e0837ea101bf86b4b7b162a459cbf19a9cfb (patch) | |
tree | f61df990bbdd05e98326b83d68a1f020f33d86e1 /meta-oe/recipes-extended/mraa | |
parent | 3e0ec54b8cfe994a0c5a23780fa036d851cd90a4 (diff) | |
download | meta-openembedded-efc2e0837ea101bf86b4b7b162a459cbf19a9cfb.tar.gz |
mraa: Update recipe to use v1.9.0
The musl endian patch has been merged upstream so is no longer needed
Signed-off-by: Brendan Le Foll <brendan.le.foll@intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mraa')
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa_git.bb | 8 |
2 files changed, 3 insertions, 34 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch deleted file mode 100644 index 401949e2e..000000000 --- a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 6c2649718fc9818da0d602a0b4767ea21a367e9e Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <timothy.t.orling@linux.intel.com> | ||
3 | Date: Sat, 27 Jan 2018 02:06:36 -0800 | ||
4 | Subject: [PATCH] examples/iio_driver.c: include endian.h to fix musl build | ||
5 | |||
6 | * be16toh and le16toh are defined in endian.h | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> | ||
11 | --- | ||
12 | examples/iio_driver.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/examples/iio_driver.c b/examples/iio_driver.c | ||
16 | index c5a0181..e3dc438 100644 | ||
17 | --- a/examples/iio_driver.c | ||
18 | +++ b/examples/iio_driver.c | ||
19 | @@ -23,6 +23,7 @@ | ||
20 | */ | ||
21 | |||
22 | #include <unistd.h> | ||
23 | +#include <endian.h> | ||
24 | #include "mraa/iio.h" | ||
25 | |||
26 | static void | ||
27 | -- | ||
28 | 2.13.6 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb index e1d593cbe..16883be3a 100644 --- a/meta-oe/recipes-extended/mraa/mraa_git.bb +++ b/meta-oe/recipes-extended/mraa/mraa_git.bb | |||
@@ -3,15 +3,13 @@ HOMEPAGE = "https://github.com/intel-iot-devkit/mraa" | |||
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | 4 | ||
5 | LICENSE = "MIT" | 5 | LICENSE = "MIT" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=66493d54e65bfc12c7983ff2e884f37f" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4b92a3b497d7943042a6db40c088c3f2" |
7 | 7 | ||
8 | SRCREV = "8ddbcde84e2d146bc0f9e38504d6c89c14291480" | 8 | SRCREV = "fbb7d9232067eac3f4508a37a8f7ea0c4fcebacb" |
9 | PV = "1.7.0-git${SRCPV}" | 9 | PV = "1.9.0-git${SRCPV}" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" | 11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" |
12 | 12 | ||
13 | SRC_URI_append_libc-musl = " file://0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch" | ||
14 | |||
15 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
16 | 14 | ||
17 | # CMakeLists.txt checks the architecture, only x86 and ARM supported for now | 15 | # CMakeLists.txt checks the architecture, only x86 and ARM supported for now |