diff options
author | Maciej Borzecki <maciej.borzecki@open-rnd.pl> | 2016-01-06 12:37:16 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-14 11:30:15 +0100 |
commit | 6ec1dde77e18ce32508b9e12f0cccf8ad9aca650 (patch) | |
tree | ad59d4000b836fdd46aad28524f5c3fda4d6de78 /meta-oe/recipes-extended/mozjs | |
parent | 25856244fa8e43042082f33d392ab2607261415e (diff) | |
download | meta-openembedded-6ec1dde77e18ce32508b9e12f0cccf8ad9aca650.tar.gz |
mozjs: fix linking issues on i586
When building for qemux86 on a x86 host, there's a possibility that the build
will try to link with incorrect libraries. Due to problematic -rpath-link the
linker may try to use host libraries if they are present and are arch
compatible.
Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs')
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch | 46 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | 1 |
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch b/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch new file mode 100644 index 000000000..6432e1fb7 --- /dev/null +++ b/meta-oe/recipes-extended/mozjs/mozjs/0010-fix-cross-compilation-on-i586-targets.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From a452138a1dd274bfad381a701729783360dc86fb Mon Sep 17 00:00:00 2001 | ||
2 | From: Maciej Borzecki <maciej.borzecki@open-rnd.pl> | ||
3 | Date: Tue, 5 Jan 2016 22:04:17 +0100 | ||
4 | Subject: [PATCH] fix cross compilation on i586 targets | ||
5 | |||
6 | Remove offending -Wl,-rpath-link that may cause host libraries to be picked | ||
7 | during linking. The patch applies a fix to configure.in. So as not to | ||
8 | regenerate configure, similar fix is applied there. | ||
9 | |||
10 | Upstream-Status: Inappropriate [embedded specific] | ||
11 | |||
12 | Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> | ||
13 | --- | ||
14 | js/src/configure | 2 +- | ||
15 | js/src/configure.in | 2 +- | ||
16 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/js/src/configure b/js/src/configure | ||
19 | index d019b0fdba44233596541de94307010d85a8e32e..5aa40f757a3dbb7d6887175046f44212c15c2eac 100755 | ||
20 | --- a/js/src/configure | ||
21 | +++ b/js/src/configure | ||
22 | @@ -5555,7 +5555,7 @@ TARGET_MD_ARCH=unix | ||
23 | DIRENT_INO=d_ino | ||
24 | MOZ_USER_DIR=".mozilla" | ||
25 | |||
26 | -MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib' | ||
27 | +MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin' | ||
28 | |||
29 | MOZ_COMPONENT_NSPR_LIBS='-L$(LIBXUL_DIST)/bin $(NSPR_LIBS)' | ||
30 | |||
31 | diff --git a/js/src/configure.in b/js/src/configure.in | ||
32 | index 0673aca12f6d83035549ade2a4a83906bf91f0f0..39b22724f9535ac1a6dba04658c91e4ef667fc47 100644 | ||
33 | --- a/js/src/configure.in | ||
34 | +++ b/js/src/configure.in | ||
35 | @@ -919,7 +919,7 @@ TARGET_MD_ARCH=unix | ||
36 | DIRENT_INO=d_ino | ||
37 | MOZ_USER_DIR=".mozilla" | ||
38 | |||
39 | -MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib' | ||
40 | +MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin' | ||
41 | |||
42 | MOZ_COMPONENT_NSPR_LIBS='-L$(LIBXUL_DIST)/bin $(NSPR_LIBS)' | ||
43 | |||
44 | -- | ||
45 | 2.5.0 | ||
46 | |||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb index bb7170749..be4b50b8e 100644 --- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb +++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | |||
@@ -13,6 +13,7 @@ SRC_URI = " \ | |||
13 | file://0001-regenerate-configure.patch;patchdir=../../ \ | 13 | file://0001-regenerate-configure.patch;patchdir=../../ \ |
14 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ | 14 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ |
15 | file://fix_milestone_compile_issue.patch \ | 15 | file://fix_milestone_compile_issue.patch \ |
16 | file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" | 19 | SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" |