diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2013-06-06 19:28:38 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-06-20 12:27:59 +0200 |
commit | 0368f18b3ff032c57f5bfa93cf1ffa398cc5bcc0 (patch) | |
tree | f8a250ecaaec47df48a2fe2288ab0f12af930149 /meta-oe/recipes-extended/mozjs | |
parent | 31613424db9b61fd765fe14f8a332564cbeefe5f (diff) | |
download | meta-openembedded-0368f18b3ff032c57f5bfa93cf1ffa398cc5bcc0.tar.gz |
mozjs: initial add 17.0.0
later versions of polkit will need it
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs')
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs/0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | 35 |
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch b/meta-oe/recipes-extended/mozjs/mozjs/0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch new file mode 100644 index 000000000..bc141d9d5 --- /dev/null +++ b/meta-oe/recipes-extended/mozjs/mozjs/0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 0a61b0b98c152f10404ccbdeeac583a486638a7a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Thu, 6 Jun 2013 18:36:01 +0200 | ||
4 | Subject: [PATCH] js.pc.in: do not include RequiredDefines.h for depending | ||
5 | packages | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | in our cross environment the would fail with: | ||
11 | |||
12 | | cc1: fatal error: /usr/include/js-17.0/js/RequiredDefines.h: No such file or directory | ||
13 | |||
14 | and currently it only defines __STDC_LIMIT_MACROS | ||
15 | |||
16 | Upstream-Status: Inappropriate [embedded specific] | ||
17 | |||
18 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
19 | --- | ||
20 | js.pc.in | 2 +- | ||
21 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
22 | |||
23 | diff --git a/js.pc.in b/js.pc.in | ||
24 | index 13d761d..a95a7bd 100644 | ||
25 | --- a/js.pc.in | ||
26 | +++ b/js.pc.in | ||
27 | @@ -8,4 +8,4 @@ Description: The Mozilla library for JavaScript | ||
28 | Version: @MOZILLA_VERSION@ | ||
29 | Requires.private: @NSPR_PKGCONF_CHECK@ | ||
30 | Libs: -L${libdir} -l@LIBRARY_NAME@ | ||
31 | -Cflags: -include ${includedir}/@MODULE@/js/RequiredDefines.h -I${includedir}/@MODULE@ | ||
32 | +Cflags: -I${includedir}/@MODULE@ | ||
33 | -- | ||
34 | 1.7.6.5 | ||
35 | |||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb new file mode 100644 index 000000000..311372f01 --- /dev/null +++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "SpiderMonkey is Mozilla's JavaScript engine written in C/C++" | ||
2 | LICENSE = "MPL-2.0" | ||
3 | LIC_FILES_CHKSUM = "file://../../LICENSE;md5=815ca599c9df247a0c7f619bab123dad" | ||
4 | |||
5 | SRC_URI = " \ | ||
6 | http://ftp.mozilla.org/pub/mozilla.org/js/${PN}${PV}.tar.gz \ | ||
7 | file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \ | ||
8 | " | ||
9 | SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" | ||
10 | SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba" | ||
11 | |||
12 | S = "${WORKDIR}/${PN}${PV}/js/src" | ||
13 | |||
14 | inherit autotools pkgconfig perlnative | ||
15 | |||
16 | DEPENDS += "nspr" | ||
17 | |||
18 | # nspr's package-config is ignored so set libs manually | ||
19 | EXTRA_OECONF = " \ | ||
20 | --target=${TARGET_SYS} \ | ||
21 | --host=${BUILD_SYS} \ | ||
22 | --build=${BUILD_SYS} \ | ||
23 | --prefix=${prefix} \ | ||
24 | --with-nspr-libs='-lplds4 -lplc4 -lnspr4' \ | ||
25 | --enable-threadsafe \ | ||
26 | " | ||
27 | |||
28 | # mozjs requires autoreconf 2.13 | ||
29 | do_configure() { | ||
30 | ./configure ${EXTRA_OECONF} | ||
31 | } | ||
32 | |||
33 | PACKAGES =+ "lib${PN}" | ||
34 | FILES_lib${PN} += "${libdir}/lib*.so" | ||
35 | FILES_${PN}-dev += "${bindir}/js17-config" | ||