summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libqb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-19 20:59:59 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-29 16:58:44 -0700
commitb02424812ede9ec095702734427f3f761d61452b (patch)
tree632b78bdb57f652a114381a4f652c3fbf0a41874 /meta-oe/recipes-extended/libqb
parentdbc5708539c24903569d8d648a763d2dd6b9db61 (diff)
downloadmeta-openembedded-b02424812ede9ec095702734427f3f761d61452b.tar.gz
libqb: Upgrade to 1.0.3
Drop upstreamed patch Backport another patch to fix out of tree build regression Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libqb')
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch43
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch56
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.3.bb (renamed from meta-oe/recipes-extended/libqb/libqb_1.0.2.bb)6
3 files changed, 60 insertions, 45 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
deleted file mode 100644
index 28bc5c07d..000000000
--- a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From e6fbad0c122ba8e87b67a9e2447505adcaafe204 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 29 Mar 2017 16:31:38 -0700
4Subject: [PATCH] Remove runtime check for CLOCK_MONOTONIC
5
6Does not work during cross compile
7
8use a compile-time check to detect whether the
9monotonic clock is available. This check can run just fine when we are
10cross-compiling.
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 configure.ac | 12 ++++++++++--
15 1 file changed, 10 insertions(+), 2 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index fa13ae6..f4f0f46 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -175,9 +175,17 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
22 )
23
24 AC_MSG_CHECKING(for a working clock_getres(CLOCK_MONOTONIC, &ts))
25-AC_RUN_IFELSE([AC_LANG_PROGRAM(
26+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
27 [[#include <time.h>]],
28-[[struct timespec ts; if(clock_getres(CLOCK_MONOTONIC, &ts)) return -1;]])],
29+[[
30+#include <unistd.h>
31+int main() {
32+#if !(defined(_POSIX_MONOTONIC_CLOCK) && _POSIX_MONOTONIC_CLOCK >= 0 && defined(CLOCK_MONOTONIC))
33+ #error No monotonic clock
34+#endif
35+ return 0;
36+
37+]])],
38 [
39 AC_MSG_RESULT([yes])
40 AC_DEFINE_UNQUOTED([HAVE_CLOCK_GETRES_MONOTONIC], 1, [Define to 1 if clock_getres(CLOCK_MONOTONIC, &ts) works])
41--
422.12.1
43
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch b/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
new file mode 100644
index 000000000..c82f3bf01
--- /dev/null
+++ b/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
@@ -0,0 +1,56 @@
1From 73d2aea33e32272bac693550e8a3b0e3ad89707f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
3Date: Tue, 26 Dec 2017 00:02:26 +0100
4Subject: [PATCH] build: fix configure script neglecting, re-enable out-of-tree
5 builds
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10For the former, a prototype and the final code got (hm, mysteriously)
11intertwisted. For the latter, I am clearly guilty of (rare, anyway)
12testing of the out-of-tree builds only with libqb-already-system-wide
13scenario, which is rather shortsighted.
14
15Thanks Fabio and his ci.kronosnet.org project for spotting that.
16
17X-mas-present-for: Fabio M. Di Nitto <fdinitto@redhat.com>
18Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
19---
20Upstream-Status: Backport
21
22 configure.ac | 2 +-
23 lib/Makefile.am | 4 +++-
24 2 files changed, 4 insertions(+), 2 deletions(-)
25
26diff --git a/configure.ac b/configure.ac
27index 9900310..f9761cc 100644
28--- a/configure.ac
29+++ b/configure.ac
30@@ -710,7 +710,7 @@ if test "x${GCC}" = xyes; then
31 | grep __stop___verbose | cut -d" " -f 3)
32 test "${verbose_start_addr}" = "${verbose_stop_addr}" \
33 && gcc_has_attribute_section_visible=no \
34- || { verbose_start_type=$(${READELF} -s backup \
35+ || { verbose_start_type=$(${READELF} -s "conftest${shrext_cmds}" \
36 | sed -n '/__start___verbose/{s/^\s*//p;q}' \
37 | tr -s ' ' \
38 | cut -d" " -f6)
39diff --git a/lib/Makefile.am b/lib/Makefile.am
40index 6ca6b15..b035f0b 100644
41--- a/lib/Makefile.am
42+++ b/lib/Makefile.am
43@@ -101,7 +101,9 @@ endif
44 endif
45
46 qblog_script.ld: %.ld: %.ld.in
47- $(AM_V_GEN)$(CPP) -xc -I$(top_srcdir)/include -D_GNU_SOURCE -C -P $< \
48+ $(AM_V_GEN)$(CPP) -C -D_GNU_SOURCE -P \
49+ -I$(top_srcdir)/include -I$(top_builddir)/include \
50+ -xc $< \
51 | sed -n "/$$(sed -n '/^[^#]/{s/[*\/]/\\&/g;p;q;}' $<)/,$$ p" \
52 > $@
53
54--
552.16.2
56
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.2.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
index 574f6601c..73cea5e39 100644
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.2.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
@@ -11,12 +11,14 @@ inherit autotools pkgconfig
11 11
12PV .= "+git${SRCPV}" 12PV .= "+git${SRCPV}"
13 13
14SRCREV = "608de6d59a3de0eef0fbcbd8f284acbc018daa9a" 14# v1.0.3
15SRCREV = "28dff090c74b6ba8609c4797294a5afe3fe73987"
15SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \ 16SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
16 file://0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch \ 17 file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \
17 " 18 "
18S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
19 20
21CFLAGS += "-pthread -D_REENTRANT"
20do_configure_prepend() { 22do_configure_prepend() {
21 ( cd ${S} 23 ( cd ${S}
22 ${S}/autogen.sh ) 24 ${S}/autogen.sh )