diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-29 16:37:15 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-06 13:00:09 +0200 |
commit | bc4d1aa833f62e1bc270eaed99dfd50c0f7abe3a (patch) | |
tree | eb6e580b21c3a47ba818c4baf2331ccd76ec2ef2 /meta-oe/recipes-extended/libqb | |
parent | 82dbf3f408ee92b5650629cfe8292407f21b5a5c (diff) | |
download | meta-openembedded-bc4d1aa833f62e1bc270eaed99dfd50c0f7abe3a.tar.gz |
libqb: Upgrade to 1.0.1 release
Add a patch needed for cross compiling
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libqb')
-rw-r--r-- | meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libqb/libqb_1.0.1.bb (renamed from meta-oe/recipes-extended/libqb/libqb_0.17.2.bb) | 14 |
2 files changed, 49 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch new file mode 100644 index 000000000..28bc5c07d --- /dev/null +++ b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From e6fbad0c122ba8e87b67a9e2447505adcaafe204 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 29 Mar 2017 16:31:38 -0700 | ||
4 | Subject: [PATCH] Remove runtime check for CLOCK_MONOTONIC | ||
5 | |||
6 | Does not work during cross compile | ||
7 | |||
8 | use a compile-time check to detect whether the | ||
9 | monotonic clock is available. This check can run just fine when we are | ||
10 | cross-compiling. | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | configure.ac | 12 ++++++++++-- | ||
15 | 1 file changed, 10 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index fa13ae6..f4f0f46 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -175,9 +175,17 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM( | ||
22 | ) | ||
23 | |||
24 | AC_MSG_CHECKING(for a working clock_getres(CLOCK_MONOTONIC, &ts)) | ||
25 | -AC_RUN_IFELSE([AC_LANG_PROGRAM( | ||
26 | +AC_COMPILE_IFELSE([AC_LANG_PROGRAM( | ||
27 | [[#include <time.h>]], | ||
28 | -[[struct timespec ts; if(clock_getres(CLOCK_MONOTONIC, &ts)) return -1;]])], | ||
29 | +[[ | ||
30 | +#include <unistd.h> | ||
31 | +int main() { | ||
32 | +#if !(defined(_POSIX_MONOTONIC_CLOCK) && _POSIX_MONOTONIC_CLOCK >= 0 && defined(CLOCK_MONOTONIC)) | ||
33 | + #error No monotonic clock | ||
34 | +#endif | ||
35 | + return 0; | ||
36 | + | ||
37 | +]])], | ||
38 | [ | ||
39 | AC_MSG_RESULT([yes]) | ||
40 | AC_DEFINE_UNQUOTED([HAVE_CLOCK_GETRES_MONOTONIC], 1, [Define to 1 if clock_getres(CLOCK_MONOTONIC, &ts) works]) | ||
41 | -- | ||
42 | 2.12.1 | ||
43 | |||
diff --git a/meta-oe/recipes-extended/libqb/libqb_0.17.2.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.1.bb index 94030b2ea..e26bb7c19 100644 --- a/meta-oe/recipes-extended/libqb/libqb_0.17.2.bb +++ b/meta-oe/recipes-extended/libqb/libqb_1.0.1.bb | |||
@@ -4,22 +4,20 @@ It provides high performance logging, tracing, ipc, and poll." | |||
4 | 4 | ||
5 | HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki" | 5 | HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki" |
6 | SECTION = "libs" | 6 | SECTION = "libs" |
7 | |||
8 | LICENSE = "LGPL-2.1" | 7 | LICENSE = "LGPL-2.1" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" |
10 | 9 | ||
11 | inherit autotools-brokensep pkgconfig | 10 | inherit autotools pkgconfig |
12 | |||
13 | PV = "0.17.2+git${SRCPV}" | ||
14 | 11 | ||
15 | SRCREV = "bd2c587f6ccacd8a5644b275d99324d200c2b378" | 12 | PV .= "+git${SRCPV}" |
16 | SRC_URI = "git://github.com/ClusterLabs/${BPN}.git" | ||
17 | 13 | ||
14 | SRCREV = "0a329683a76bc6aeb36f20f2bf6b43ba0440c4dc" | ||
15 | SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \ | ||
16 | file://0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch \ | ||
17 | " | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||
20 | do_configure_prepend() { | 20 | do_configure_prepend() { |
21 | ( cd ${S} | 21 | ( cd ${S} |
22 | ${S}/autogen.sh ) | 22 | ${S}/autogen.sh ) |
23 | } | 23 | } |
24 | |||
25 | |||