diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-07-24 03:04:04 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-13 13:19:00 +0200 |
commit | 89e1d189e3a0c69b65dfdda5525d86882c2edba7 (patch) | |
tree | 1af216952cd1dee0b94c820fa16ad19196ad2ce3 /meta-oe/recipes-extended/libpwquality/files | |
parent | 369b9f4421971a3feb496b63a3ce1d35363e860c (diff) | |
download | meta-openembedded-89e1d189e3a0c69b65dfdda5525d86882c2edba7.tar.gz |
libpwquality: add recipe 1.4.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libpwquality/files')
-rw-r--r-- | meta-oe/recipes-extended/libpwquality/files/add-missing-python-include-dir-for-cross.patch | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libpwquality/files/add-missing-python-include-dir-for-cross.patch b/meta-oe/recipes-extended/libpwquality/files/add-missing-python-include-dir-for-cross.patch new file mode 100644 index 000000000..d12492f02 --- /dev/null +++ b/meta-oe/recipes-extended/libpwquality/files/add-missing-python-include-dir-for-cross.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 1ea09e09ab2387c326bb7170835361ece6e25477 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 3 Aug 2015 13:43:14 +0800 | ||
4 | Subject: [PATCH] setup.py.in: add missing python include dir for cross | ||
5 | compiling | ||
6 | |||
7 | Upstream-Status: inappropriate [oe-core specific] | ||
8 | |||
9 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
10 | --- | ||
11 | python/Makefile.am | 2 +- | ||
12 | python/setup.py.in | 3 ++- | ||
13 | 2 files changed, 3 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/python/Makefile.am b/python/Makefile.am | ||
16 | index abc5cd3..e35ba71 100644 | ||
17 | --- a/python/Makefile.am | ||
18 | +++ b/python/Makefile.am | ||
19 | @@ -14,4 +14,4 @@ all-local: | ||
20 | CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py build --build-lib=. | ||
21 | |||
22 | install-exec-local: | ||
23 | - CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py install --prefix=${DESTDIR}${prefix} | ||
24 | + CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py install --prefix=${DESTDIR}${prefix} --install-lib=${DESTDIR}/${PYTHONSITEDIR} | ||
25 | diff --git a/python/setup.py.in b/python/setup.py.in | ||
26 | index 6457595..d3db0e5 100755 | ||
27 | --- a/python/setup.py.in | ||
28 | +++ b/python/setup.py.in | ||
29 | @@ -6,6 +6,7 @@ | ||
30 | |||
31 | from distutils.core import setup, Extension | ||
32 | from distutils.command.build_ext import build_ext as _build_ext | ||
33 | +import os | ||
34 | |||
35 | class build_ext(_build_ext): | ||
36 | def genconstants(self, headerfile, outputfile): | ||
37 | @@ -23,7 +24,7 @@ class build_ext(_build_ext): | ||
38 | |||
39 | pwqmodule = Extension('pwquality', | ||
40 | sources = ['pwquality.c'], | ||
41 | - include_dirs = ['../src'], | ||
42 | + include_dirs = ['../src', os.path.join(os.environ['STAGING_INCDIR'], os.environ['PYTHON_DIR'])], | ||
43 | library_dirs = ['../src/.libs'], | ||
44 | libraries = ['pwquality']) | ||
45 | |||
46 | -- | ||
47 | 1.9.1 | ||
48 | |||