diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-09-04 23:23:59 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-09-08 13:32:12 -0700 |
commit | bfbcc00cb95633c2e55f5adb3f1969867e1d1f89 (patch) | |
tree | c2927231600bf9fa0ec957d676785c738a1cf15f /meta-oe/recipes-extended/libimobiledevice | |
parent | 412045dfaf6955142e46c23d7c0196403946d284 (diff) | |
download | meta-openembedded-bfbcc00cb95633c2e55f5adb3f1969867e1d1f89.tar.gz |
libimobiledevice: Upgrade to latest
Needs several packages to be updates
Fixes build with openSSL 1.1.x
License-Update:
Drop LGPL-2.1, its moved out to separate package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libimobiledevice')
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch | 51 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch | 21 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb (renamed from meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb) | 10 |
3 files changed, 4 insertions, 78 deletions
diff --git a/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch b/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch deleted file mode 100644 index f8114a063..000000000 --- a/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From ad1be542b87b3186f8ef7bee2c594daefe5bb4c8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 18 Oct 2016 21:31:40 +0000 | ||
4 | Subject: [PATCH] Fix warnings found with clang | ||
5 | |||
6 | | /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:107:12: error: non-void function 'base64decode' should return a value [-Wreturn-type] | ||
7 | | if (!buf) return; | ||
8 | | ^ | ||
9 | | /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:109:16: error: non-void function 'base64decode' should return a value [-Wreturn-type] | ||
10 | | if (len <= 0) return; | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | libcnary/node.c | 2 +- | ||
17 | src/base64.c | 4 ++-- | ||
18 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
19 | |||
20 | diff --git a/libcnary/node.c b/libcnary/node.c | ||
21 | index 1f9f669..d6f3f63 100644 | ||
22 | --- a/libcnary/node.c | ||
23 | +++ b/libcnary/node.c | ||
24 | @@ -104,7 +104,7 @@ int node_detach(node_t* parent, node_t* child) { | ||
25 | |||
26 | int node_insert(node_t* parent, unsigned int index, node_t* child) | ||
27 | { | ||
28 | - if (!parent || !child) return; | ||
29 | + if (!parent || !child) return -1; | ||
30 | child->isLeaf = TRUE; | ||
31 | child->isRoot = FALSE; | ||
32 | child->parent = parent; | ||
33 | diff --git a/src/base64.c b/src/base64.c | ||
34 | index 65c6061..531a06a 100644 | ||
35 | --- a/src/base64.c | ||
36 | +++ b/src/base64.c | ||
37 | @@ -104,9 +104,9 @@ static int base64decode_block(unsigned char *target, const char *data, size_t da | ||
38 | |||
39 | unsigned char *base64decode(const char *buf, size_t *size) | ||
40 | { | ||
41 | - if (!buf) return; | ||
42 | + if (!buf) return 0; | ||
43 | size_t len = strlen(buf); | ||
44 | - if (len <= 0) return; | ||
45 | + if (len <= 0) return 0; | ||
46 | unsigned char *outbuf = (unsigned char*)malloc((len/4)*3+3); | ||
47 | |||
48 | unsigned char *line; | ||
49 | -- | ||
50 | 1.9.1 | ||
51 | |||
diff --git a/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch b/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch deleted file mode 100644 index f6ef6f4f8..000000000 --- a/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | From 335b25febd4c864ad0ac08479f5cd43fc21b7d73 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nikias Bassen | ||
3 | Date: Mon, 09 Jul 2012 21:17:15 +0000 | ||
4 | Subject: Fix building with parallel build makeopts | ||
5 | |||
6 | --- | ||
7 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
8 | index 0bad840..155994e 100644 | ||
9 | --- a/CMakeLists.txt | ||
10 | +++ b/CMakeLists.txt | ||
11 | @@ -57,6 +57,8 @@ ADD_SUBDIRECTORY( plutil ) | ||
12 | ADD_SUBDIRECTORY( include ) | ||
13 | ADD_SUBDIRECTORY( test ) | ||
14 | |||
15 | +ADD_DEPENDENCIES( plist libcnary ) | ||
16 | + | ||
17 | IF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND ) | ||
18 | ADD_SUBDIRECTORY( swig ) | ||
19 | ENDIF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND ) | ||
20 | -- | ||
21 | cgit v0.9.0.2 | ||
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb index f78979619..43c1fd5ca 100644 --- a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb +++ b/meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb | |||
@@ -6,15 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \ | |||
6 | 6 | ||
7 | DEPENDS = "libxml2 glib-2.0 swig python" | 7 | DEPENDS = "libxml2 glib-2.0 swig python" |
8 | 8 | ||
9 | inherit cmake pkgconfig | 9 | inherit autotools pkgconfig pythonnative |
10 | 10 | ||
11 | SRC_URI = "http://www.libimobiledevice.org/downloads/libplist-${PV}.tar.bz2 \ | 11 | SRCREV = "62ec804736435fa34e37e66e228e17e2aacee1d7" |
12 | file://fix-parallel-make.patch \ | 12 | SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \ |
13 | file://0001-Fix-warnings-found-with-clang.patch \ | ||
14 | " | 13 | " |
15 | 14 | ||
16 | SRC_URI[md5sum] = "2a9e0258847d50f9760dc3ece25f4dc6" | 15 | S = "${WORKDIR}/git" |
17 | SRC_URI[sha256sum] = "a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec" | ||
18 | 16 | ||
19 | do_install_append () { | 17 | do_install_append () { |
20 | if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then | 18 | if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then |