summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcec/libcec_git.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-25 13:46:37 +0200
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:16 -0700
commit9517a114c8af0eba9815275a3005b823d48b3c74 (patch)
treed237ff95f18eb72ca7cce8251448f7393ac4caf0 /meta-oe/recipes-extended/libcec/libcec_git.bb
parent1102fbf8943298e049b56a51e72a1852cbd1f3f2 (diff)
downloadmeta-openembedded-9517a114c8af0eba9815275a3005b823d48b3c74.tar.gz
libcec: update to 6.0.2
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libcec/libcec_git.bb')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
deleted file mode 100644
index 39ceb489e..000000000
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac"
6
7DEPENDS = "p8platform udev ncurses swig-native python3"
8
9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
11
12PV = "5.0.0"
13
14SRCREV = "43bc27fe7be491149e6f57d14110e02abdac2f24"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \
16 file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
17 file://0001-Enhance-reproducibility.patch \
18 "
19
20S = "${WORKDIR}/git"
21
22inherit cmake pkgconfig
23
24# Put client tools into a separate package
25PACKAGE_BEFORE_PN += "${PN}-tools"
26FILES_${PN}-tools = "${bindir}"
27RDEPENDS_${PN}-tools = "python3-${BPN} python3-core"
28
29# Create the wrapper for python3
30PACKAGES += "python3-${BPN}"
31FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
32RDEPENDS_${PN} = "python3-core"
33
34# cec-client and xbmc need the .so present to work :(
35FILES_${PN} += "${libdir}/*.so"
36INSANE_SKIP_${PN} = "dev-so"
37
38# Adapter shows up as a CDC-ACM device
39RRECOMMENDS_${PN} = "kernel-module-cdc-acm"