summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcec/libcec_git.bb
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-03-10 18:30:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-16 23:32:32 +0100
commit9a3e69fe84a38c8b9a95ce110ed90ea5814aba0a (patch)
tree8d2f4e4a04f255f125aa379ccee99882d00a4ebd /meta-oe/recipes-extended/libcec/libcec_git.bb
parent1dff2351aa6cdafa5a501e8956cb853ab17ed9ae (diff)
downloadmeta-openembedded-9a3e69fe84a38c8b9a95ce110ed90ea5814aba0a.tar.gz
libcec: update to version 4.0.1 and provide package for python3 wrapper
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libcec/libcec_git.bb')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index 0ce7ea1c0..cb65caad8 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -4,23 +4,24 @@ HOMEPAGE = "http://libcec.pulse-eight.com/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
6 6
7DEPENDS = "p8platform udev lockdev ncurses" 7DEPENDS = "p8platform udev lockdev ncurses swig-native python3"
8 8
9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" 9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" 10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
11 11
12PV = "3.1.0+gitr${SRCPV}" 12PV = "4.0.1+gitr${SRCPV}"
13 13
14SRCREV = "6d68d21243aa92862592435e8396b4280ea46c3f" 14SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git" 15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
16 file://python-install-location.patch"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19
19inherit cmake pkgconfig 20inherit cmake pkgconfig
20 21
21# Disable python wrapper, it doesn't have crosscompiles 22# Create the wrapper for python3
22EXTRA_OECMAKE = "-DCMAKE_INSTALL_LIBDIR=${libdir} -DCMAKE_INSTALL_LIBDIR_NOARCH=${libdir} \ 23PACKAGES += "python3-${BPN}"
23 -DSKIP_PYTHON_WRAPPER=1" 24FILES_python3-${BPN} = "${libdir}/python3*"
24 25
25# cec-client and xbmc need the .so present to work :( 26# cec-client and xbmc need the .so present to work :(
26FILES_${PN} += "${libdir}/*.so" 27FILES_${PN} += "${libdir}/*.so"