summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libblockdev
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2018-07-27 14:20:33 +0300
committerKhem Raj <raj.khem@gmail.com>2018-07-27 19:26:51 -0700
commitc41ed7f332ea41984d26ad4a9ee242819c6a5a4c (patch)
tree06c74146fc693c27648122a7229f671b768ded18 /meta-oe/recipes-extended/libblockdev
parentd00b7bd416eceb4d6aa70a572832a05d6f9870c0 (diff)
downloadmeta-openembedded-c41ed7f332ea41984d26ad4a9ee242819c6a5a4c.tar.gz
libblockdev: cleanup/fix PACKAGECONFIG/dependencies
It only makes sense to rdepend on lvm2 if lvm is enabled by the configuration and the nss and volume-key dependencies are only needed if --with-escrow is configured. These dependencies are quite big so it's good to have a way to disable them. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libblockdev')
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb11
1 files changed, 3 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
index 4dbd04cd7..a58871f0c 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
@@ -12,8 +12,6 @@ inherit autotools python3native gobject-introspection
12 12
13DEPENDS += " \ 13DEPENDS += " \
14 cryptsetup \ 14 cryptsetup \
15 nss \
16 volume-key \
17 libbytesize \ 15 libbytesize \
18 btrfs-tools \ 16 btrfs-tools \
19" 17"
@@ -26,16 +24,12 @@ SRC_URI = " \
26 24
27S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
28 26
29RDEPENDS_${PN} += " \
30 lvm2 \
31"
32
33FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" 27FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
34 28
35PACKAGECONFIG ??= "python3 lvm dm kmod parted fs" 29PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow"
36PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" 30PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
37PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2" 31PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
38PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools" 32PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
39PACKAGECONFIG[dm] = "--with-dm, --without-dm" 33PACKAGECONFIG[dm] = "--with-dm, --without-dm"
40PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid" 34PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
41PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod" 35PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
@@ -44,6 +38,7 @@ PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
44PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" 38PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
45PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm" 39PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm"
46PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo" 40PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
41PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
47 42
48export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" 43export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"
49 44