diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-01 23:50:15 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-12 06:56:44 +0200 |
commit | fb26fdcda0b719512fac4760e680b213c0b016c0 (patch) | |
tree | 767b8c5b4f8f55acee921216637ec07d40be55d9 /meta-oe/recipes-extended/konkretcmpi | |
parent | e7bd0b99108a9688f991dfcd74cca36fd9c5dc95 (diff) | |
download | meta-openembedded-fb26fdcda0b719512fac4760e680b213c0b016c0.tar.gz |
konkretcmpi: Update and fix build with latest oe-core
Drop already upstreamed patch
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/konkretcmpi')
3 files changed, 40 insertions, 40 deletions
diff --git a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/0001-drop-including-rpath-cmake-module.patch b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/0001-drop-including-rpath-cmake-module.patch new file mode 100644 index 000000000..342017bed --- /dev/null +++ b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/0001-drop-including-rpath-cmake-module.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 45e1c4c04a126d2386446775f99084bd603016af Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 1 Jun 2017 23:10:59 -0700 | ||
4 | Subject: [PATCH] drop including rpath cmake module | ||
5 | |||
6 | Fixes cross compilation QA errors e.g. | ||
7 | /usr/lib/libkonkret.so.0.0.1 contains probably-redundant RPATH /usr/lib [useless-rpaths] | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/konkret/CMakeLists.txt | 1 - | ||
12 | src/program/CMakeLists.txt | 1 - | ||
13 | 2 files changed, 2 deletions(-) | ||
14 | |||
15 | diff --git a/src/konkret/CMakeLists.txt b/src/konkret/CMakeLists.txt | ||
16 | index c2faa40..df49e11 100644 | ||
17 | --- a/src/konkret/CMakeLists.txt | ||
18 | +++ b/src/konkret/CMakeLists.txt | ||
19 | @@ -8,7 +8,6 @@ set(konkret_SRCS | ||
20 | kstr.c | ||
21 | print.c | ||
22 | ) | ||
23 | -include(rpath) | ||
24 | include_directories(${CMPI_INCLUDE_DIR}) | ||
25 | |||
26 | add_library(libkonkret SHARED ${konkret_SRCS}) | ||
27 | diff --git a/src/program/CMakeLists.txt b/src/program/CMakeLists.txt | ||
28 | index afcefe5..8a4646c 100644 | ||
29 | --- a/src/program/CMakeLists.txt | ||
30 | +++ b/src/program/CMakeLists.txt | ||
31 | @@ -1,4 +1,3 @@ | ||
32 | -include (rpath) | ||
33 | include_directories(${CMPI_INCLUDE_DIR} ${CMAKE_SOURCE_DIR}/src) | ||
34 | |||
35 | add_executable(konkret main.cpp) | ||
36 | -- | ||
37 | 2.13.0 | ||
38 | |||
diff --git a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/konkretcmpi-0.9.2-fix-returning-instance-from-method.patch b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/konkretcmpi-0.9.2-fix-returning-instance-from-method.patch deleted file mode 100644 index b54d09159..000000000 --- a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi/konkretcmpi-0.9.2-fix-returning-instance-from-method.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | Port from Fedora20 | ||
2 | |||
3 | | commit aca6c7f910ffe9930b5789969f0adfadd668bb46 | ||
4 | | Author: Michal Minar <miminar@redhat.com> | ||
5 | | Date: Fri Jun 20 10:50:45 2014 +0200 | ||
6 | | | ||
7 | | Fix returning instance as an output argument from method | ||
8 | | | ||
9 | | Submitted By: Radek Novacek <rnovacek@redhat.com> | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | ||
13 | |||
14 | diff --git a/src/program/main.cpp b/src/program/main.cpp | ||
15 | index 885dc12..9e7108a 100644 | ||
16 | --- a/src/program/main.cpp | ||
17 | +++ b/src/program/main.cpp | ||
18 | @@ -506,7 +506,11 @@ static void gen_feature_decls( | ||
19 | |||
20 | // Add sig entry [type][length][name][zero-terminator] | ||
21 | |||
22 | - KTag tag = _ktag(pd->data_type, pd->array_index, key, false, false); | ||
23 | + KTag tag; | ||
24 | + if (pd->qualifiers->has_key("EmbeddedInstance")) | ||
25 | + tag = _ktag(TOK_INSTANCE, pd->array_index, key, false, false); | ||
26 | + else | ||
27 | + tag = _ktag(pd->data_type, pd->array_index, key, false, false); | ||
28 | pack_tag(sig, tag); | ||
29 | pack_name(sig, pd->name); | ||
30 | count++; | ||
31 | @@ -640,6 +644,7 @@ static void gen_param(FILE* os, MOF_Parameter* p, vector<unsigned char>& sig) | ||
32 | const char* ktn = _ktype_name(p->data_type); | ||
33 | |||
34 | if (p->qualifiers->has_key("EmbeddedInstance")) { | ||
35 | + tag = _ktag(TOK_INSTANCE, p->array_index, false, in, out); | ||
36 | if (p->array_index) | ||
37 | put(os, " KInstanceA $0;\n", p->name, NULL); | ||
38 | else | ||
diff --git a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb index 1d8b0dbd4..4e4aa6cde 100644 --- a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb +++ b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb | |||
@@ -9,11 +9,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f673270bfc350d9ce1efc8724c6c1873" | |||
9 | DEPENDS = "swig-native sblim-cmpi-devel python" | 9 | DEPENDS = "swig-native sblim-cmpi-devel python" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/rnovacek/konkretcmpi.git \ | 11 | SRC_URI = "git://github.com/rnovacek/konkretcmpi.git \ |
12 | file://konkretcmpi-0.9.2-fix-returning-instance-from-method.patch \ | ||
13 | file://0001-CMakeLists.txt-fix-lib64-can-not-be-shiped-in-64bit-.patch \ | 12 | file://0001-CMakeLists.txt-fix-lib64-can-not-be-shiped-in-64bit-.patch \ |
13 | file://0001-drop-including-rpath-cmake-module.patch \ | ||
14 | " | 14 | " |
15 | 15 | ||
16 | SRCREV = "460e6421c16a8216d29ccd1b7490f814dab8b769" | 16 | SRCREV = "ad28225e6eceff88417a60c1ba8896c8e40f21a7" |
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
19 | inherit cmake | 19 | inherit cmake |