summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
diff options
context:
space:
mode:
authorMarc Reilly <marc@cpdesign.com.au>2012-08-21 01:48:18 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 19:34:31 +0200
commite0fe08a35ae6e1a4458c13daa13167c9a1e74bde (patch)
treed2c8d89e6b5315c6e9b9831101bc16e61e562c2d /meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
parentab30278835335a2fec6c9bfb672089db21fda852 (diff)
downloadmeta-openembedded-e0fe08a35ae6e1a4458c13daa13167c9a1e74bde.tar.gz
hplip: Introduce version 3.12.6
This introduces a recipe to build hplip 3.12.6 in a simple configuration aimed at USB printers. It is based on a 3.11.3a recipe for oe classic by Steve Sakoman. The hp-setup program is patched to add a small delay after restarting cups, as on slower embedded systems the cups daemon would sometimes not restart quickly enough and adding a new printer would sporadically fail. Tested on an armv6 system (with cups 1.4.6, ghostscript 9.05, foomatic). Signed-off-by: Marc Reilly <marc@cpdesign.com.au> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/hplip/hplip_3.12.6.bb')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
new file mode 100644
index 000000000..2826a76ae
--- /dev/null
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -0,0 +1,68 @@
1DESCRIPTION = "HP Linux Imaging and Printing"
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=442bb3cbbeeb60643a87325718b8a8ee"
4
5SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
6 file://setup-add-sleep-after-cups-reset.patch \
7 file://fix-libusb-paths.patch \
8 "
9
10DEPENDS += "cups python libusb"
11
12inherit autotools python-dir pythonnative
13
14export BUILD_SYS
15export HOST_SYS
16export STAGING_INCDIR
17export STAGING_LIBDIR
18
19EXTRA_OECONF += "\
20 LIBUSBINCLUDEROOT=${STAGING_INCDIR} \
21 --disable-network-build \
22 --disable-doc-build \
23 --disable-pp-build \
24 --disable-scan-build \
25 --disable-gui-build \
26 --disable-fax-build \
27 --disable-policykit \
28 --disable-qt4 \
29 --disable-qt3 \
30 --disable-dbus-build \
31 --disable-foomatic-drv-install \
32 --enable-foomatic-ppd-install \
33 --enable-foomatic-rip-hplip-install \
34 "
35
36PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
37
38RDEPENDS_${PN} += " \
39 python-syslog \
40 python-pprint \
41 python-compression \
42 python-shell \
43 python-xml \
44 python-unixadmin \
45 python-html \
46 python-resource \
47 python-terminal \
48 python-subprocess\
49 "
50
51# need to snag the debug file or OE will fail on backend package
52FILES_${PN}-dbg += "\
53 ${libdir}/cups/backend/.debug \
54 ${PYTHON_SITEPACKAGES_DIR}/.debug \
55 ${libdir}/cups/filter/.debug "
56
57FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
58FILES_${PN}-ppd = "${datadir}/ppd"
59FILES_${PN}-cups = "${datadir}/cups"
60FILES_${PN}-backend = "${libdir}/cups/backend"
61FILES_${PN}-filter = "${libdir}/cups/filter"
62FILES_${PN}-hal = "${datadir}/hal"
63
64FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*.so"
65
66SRC_URI[md5sum] = "5303938e8630775ea6fb383af85775e5"
67SRC_URI[sha256sum] = "54578000792969adb583e75efeacb9c46ab69659ec7e9424de390613f3595775"
68