summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hplip/hplip-3.12.6
diff options
context:
space:
mode:
authorMarc Reilly <marc@cpdesign.com.au>2012-08-21 01:48:18 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 19:34:31 +0200
commite0fe08a35ae6e1a4458c13daa13167c9a1e74bde (patch)
treed2c8d89e6b5315c6e9b9831101bc16e61e562c2d /meta-oe/recipes-extended/hplip/hplip-3.12.6
parentab30278835335a2fec6c9bfb672089db21fda852 (diff)
downloadmeta-openembedded-e0fe08a35ae6e1a4458c13daa13167c9a1e74bde.tar.gz
hplip: Introduce version 3.12.6
This introduces a recipe to build hplip 3.12.6 in a simple configuration aimed at USB printers. It is based on a 3.11.3a recipe for oe classic by Steve Sakoman. The hp-setup program is patched to add a small delay after restarting cups, as on slower embedded systems the cups daemon would sometimes not restart quickly enough and adding a new printer would sporadically fail. Tested on an armv6 system (with cups 1.4.6, ghostscript 9.05, foomatic). Signed-off-by: Marc Reilly <marc@cpdesign.com.au> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/hplip/hplip-3.12.6')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip-3.12.6/fix-libusb-paths.patch35
-rw-r--r--meta-oe/recipes-extended/hplip/hplip-3.12.6/setup-add-sleep-after-cups-reset.patch12
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip-3.12.6/fix-libusb-paths.patch b/meta-oe/recipes-extended/hplip/hplip-3.12.6/fix-libusb-paths.patch
new file mode 100644
index 000000000..b347f831c
--- /dev/null
+++ b/meta-oe/recipes-extended/hplip/hplip-3.12.6/fix-libusb-paths.patch
@@ -0,0 +1,35 @@
1Upstream-Status: Inappropriate [configuration]
2
3diff -rupN hplip-3.12.6_orig/configure.in hplip-3.12.6/configure.in
4--- hplip-3.12.6_orig/configure.in 2012-06-18 20:44:24.000000000 +1000
5+++ hplip-3.12.6/configure.in 2012-08-16 13:40:07.259927650 +1000
6@@ -524,6 +524,8 @@ if test "$hpijs_only_build" = "no"; then
7 AC_CHECK_HEADERS(usb.h, ,[AC_MSG_ERROR([cannot find libusb-devel support], 11)])
8 else
9 AC_CHECK_LIB([usb-1.0], [libusb_init], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find libusb 1.0 support], 2)])
10+ LIBUSBINCLUDEROOT?="/usr/include/"
11+ AC_ARG_VAR(LIBUSBINCLUDEROOT, [path to libusb-1.0 folder])
12 AC_CHECK_HEADERS(libusb-1.0/libusb.h, ,[AC_MSG_ERROR([cannot find libusb-1.0-devel support], 11)])
13 fi
14 fi
15diff -rupN hplip-3.12.6_orig/Makefile.am hplip-3.12.6/Makefile.am
16--- hplip-3.12.6_orig/Makefile.am 2012-06-18 20:44:13.000000000 +1000
17+++ hplip-3.12.6/Makefile.am 2012-08-16 13:41:12.307932822 +1000
18@@ -72,7 +72,7 @@ libhpmud_la_SOURCES = io/hpmud/hpmud.c i
19 io/hpmud/hpmud.h io/hpmud/hpmudi.h io/hpmud/list.h io/hpmud/mlc.h io/hpmud/pml.h io/hpmud/dot4.c \
20 io/hpmud/dot4.h io/hpmud/jd.c io/hpmud/jd.h io/hpmud/pp.c io/hpmud/pp.h io/hpmud/musb.h io/hpmud/musb_libusb01.c
21 else
22-libhpmud_la_CFLAGS = -I/usr/include/libusb-1.0 -DMUDNAME=\"$(MUDNAME)\" -DCONFDIR=\"$(hplip_confdir)\"
23+libhpmud_la_CFLAGS = -I/$(LIBUSBINCLUDEROOT)/libusb-1.0 -DMUDNAME=\"$(MUDNAME)\" -DCONFDIR=\"$(hplip_confdir)\"
24 libhpmud_la_SOURCES = io/hpmud/hpmud.c io/hpmud/mlc.c io/hpmud/model.c io/hpmud/pml.c \
25 io/hpmud/hpmud.h io/hpmud/hpmudi.h io/hpmud/list.h io/hpmud/mlc.h io/hpmud/pml.h io/hpmud/dot4.c \
26 io/hpmud/dot4.h io/hpmud/jd.c io/hpmud/jd.h io/hpmud/pp.c io/hpmud/pp.h io/hpmud/musb.h io/hpmud/musb.c
27@@ -286,7 +286,7 @@ hpmudext_la_LIBADD = libhpmud.la
28 if LIBUSB01_BUILD
29 hpmudext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
30 else
31-hpmudext_la_CFLAGS =-I/usr/include/libusb-1.0 -I$(PYTHONINCLUDEDIR)
32+hpmudext_la_CFLAGS =-I$(LIBUSBINCLUDEROOT)/libusb-1.0 -I$(PYTHONINCLUDEDIR)
33 endif
34
35 # ui (qt3)
diff --git a/meta-oe/recipes-extended/hplip/hplip-3.12.6/setup-add-sleep-after-cups-reset.patch b/meta-oe/recipes-extended/hplip/hplip-3.12.6/setup-add-sleep-after-cups-reset.patch
new file mode 100644
index 000000000..0e1b6c4ed
--- /dev/null
+++ b/meta-oe/recipes-extended/hplip/hplip-3.12.6/setup-add-sleep-after-cups-reset.patch
@@ -0,0 +1,12 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3--- hplip-3.11.10/setup.py.orig 2011-10-02 14:06:19.000000000 +1100
4+++ hplip-3.11.10/setup.py 2012-02-29 08:21:39.167999938 +1100
5@@ -573,6 +573,7 @@
6
7 log.debug("Restarting CUPS...")
8 status, output = utils.run(restart_cups())
9+ time.sleep(3)
10 log.debug("Restart CUPS returned: exit=%d output=%s" % (status, output))
11
12 cups.setPasswordPrompt("You do not have permission to add a printer.")