diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-09-08 17:12:03 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-13 11:13:22 +0200 |
commit | 8c037f68f95739482716a5b68d4d1a271bdc51e1 (patch) | |
tree | 0ae1b5dab8a4f5abd1e0e66427fb0be58c95495f /meta-oe/recipes-extended/fluentbit | |
parent | 7a873e61d55dcea56dc5b45adfbc4ab18a58e976 (diff) | |
download | meta-openembedded-8c037f68f95739482716a5b68d4d1a271bdc51e1.tar.gz |
fluentbit: Upgrade to 0.12.1
Drop upstreamed patches
Fix jemalloc build with musl
Fix linking errors due to missing -lpthread
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit')
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch | 24 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-fluent-bit-shared-Link-with-lpthread.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch | 18 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_0.12.1.bb (renamed from meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb) | 10 |
5 files changed, 58 insertions, 57 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch deleted file mode 100644 index 90242aeb6..000000000 --- a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | From 84d70b6bc744cd348e66a0bc6c7958cdfa9ce670 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 29 Jun 2017 12:56:21 -0700 | ||
4 | Subject: [PATCH] flb-plugin-proxy-go: Add missing dependency on jemalloc | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/proxy/go/CMakeLists.txt | 3 +++ | ||
9 | 1 file changed, 3 insertions(+) | ||
10 | |||
11 | diff --git a/src/proxy/go/CMakeLists.txt b/src/proxy/go/CMakeLists.txt | ||
12 | index 3273346..02a54c2 100644 | ||
13 | --- a/src/proxy/go/CMakeLists.txt | ||
14 | +++ b/src/proxy/go/CMakeLists.txt | ||
15 | @@ -2,3 +2,6 @@ set(src | ||
16 | go.c) | ||
17 | |||
18 | add_library(flb-plugin-proxy-go STATIC ${src}) | ||
19 | +if(FLB_JEMALLOC) | ||
20 | + target_link_libraries(flb-plugin-proxy-go libjemalloc) | ||
21 | +endif() | ||
22 | -- | ||
23 | 2.13.2 | ||
24 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-fluent-bit-shared-Link-with-lpthread.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-fluent-bit-shared-Link-with-lpthread.patch new file mode 100644 index 000000000..e9eed24b3 --- /dev/null +++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-fluent-bit-shared-Link-with-lpthread.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 62fa9bceb15a9d160dd5d624a6d46907c1019c5c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 8 Sep 2017 17:02:55 -0700 | ||
4 | Subject: [PATCH] fluent-bit-shared: Link with -lpthread | ||
5 | |||
6 | This fixes a reference to pthread_atfork in libfluent-bit.so | ||
7 | otherwise we get undefined reference to the symbols in binaries | ||
8 | which are linked with libfluent-bit.so | ||
9 | |||
10 | Fixes errors like | ||
11 | arm-bec-linux-gnueabi-ld: ../../bin/hello_world: hidden symbol `pthread_atfork' in /mnt/a/oe/build/tmp/work/cortexa7t2hf-neon-vfpv4-bec-linux-gnueabi/fluentbit/0.12.1-r0/recipe-sysroot/usr/lib/libpthread_nonshared.a(pthread_atfork.oS) is referenced by DSO | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | Upstream-Status: Submitted | ||
16 | |||
17 | src/CMakeLists.txt | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
21 | index 425a246..1264e59 100644 | ||
22 | --- a/src/CMakeLists.txt | ||
23 | +++ b/src/CMakeLists.txt | ||
24 | @@ -168,7 +168,7 @@ set(FLB_DEPS | ||
25 | # Shared Library | ||
26 | if(NOT FLB_WITHOUT_SHARED_LIB) | ||
27 | add_library(fluent-bit-shared SHARED ${src}) | ||
28 | - target_link_libraries(fluent-bit-shared ${FLB_DEPS}) | ||
29 | + target_link_libraries(fluent-bit-shared ${FLB_DEPS} -lpthread) | ||
30 | set_target_properties(fluent-bit-shared | ||
31 | PROPERTIES OUTPUT_NAME fluent-bit) | ||
32 | |||
33 | -- | ||
34 | 2.14.1 | ||
35 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch deleted file mode 100644 index 35cdb18ad..000000000 --- a/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From d95c2977da074be0d3913e94fb8fb5ed1c64404a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 10:04:03 -0700 | ||
4 | Subject: [PATCH 2/2] msgpack: Add comment for intended fallthrough | ||
5 | |||
6 | Helps fixing build with gcc7 | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h b/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h | ||
14 | index a6dae6f..651e6c2 100644 | ||
15 | --- a/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h | ||
16 | +++ b/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h | ||
17 | @@ -248,7 +248,7 @@ msgpack_unpack_func(int, _execute)(msgpack_unpack_struct(_context)* ctx, const c | ||
18 | |||
19 | _fixed_trail_again: | ||
20 | ++p; | ||
21 | - | ||
22 | + // fallthrough | ||
23 | default: | ||
24 | if((size_t)(pe - p) < trail) { goto _out; } | ||
25 | n = p; p += trail - 1; | ||
26 | -- | ||
27 | 2.12.2 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch new file mode 100644 index 000000000..abaf92c05 --- /dev/null +++ b/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Add --with-jemalloc-prefix=je_ so it compiles on musl | ||
2 | |||
3 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Index: fluent-bit-0.12.1/CMakeLists.txt | ||
7 | =================================================================== | ||
8 | --- fluent-bit-0.12.1.orig/CMakeLists.txt | ||
9 | +++ fluent-bit-0.12.1/CMakeLists.txt | ||
10 | @@ -325,7 +325,7 @@ if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME} | ||
11 | # Link to Jemalloc as an external dependency | ||
12 | ExternalProject_Add(jemalloc | ||
13 | SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc | ||
14 | - CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR> | ||
15 | + CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure --with-jemalloc-prefix=je_ ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR> | ||
16 | CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops | ||
17 | BUILD_COMMAND ${MAKE} | ||
18 | INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/ | ||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.1.bb index 521d00bf6..e2edd095a 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.1.bb | |||
@@ -2,12 +2,12 @@ SUMMARY = "Fast data collector for Embedded Linux" | |||
2 | HOMEPAGE = "http://fluentbit.io" | 2 | HOMEPAGE = "http://fluentbit.io" |
3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" | 3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" |
4 | 4 | ||
5 | SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ | 5 | SRC_URI = "http://fluentbit.io/releases/0.12/fluent-bit-${PV}.tar.gz \ |
6 | file://0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch \ | 6 | file://jemalloc.patch \ |
7 | file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ | 7 | file://0001-fluent-bit-shared-Link-with-lpthread.patch \ |
8 | " | 8 | " |
9 | SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6" | 9 | SRC_URI[md5sum] = "6b4472cb7e7213a01425af9121576827" |
10 | SRC_URI[sha256sum] = "93b1bdd14db20f2823cd31c6f1a2f3fcb7c94ec3e0c8daefabf130310b7fc4ed" | 10 | SRC_URI[sha256sum] = "8ec05365baea723033165687611b3bba3e67a77dce72e282e9f000f7acf9e37b" |
11 | 11 | ||
12 | S = "${WORKDIR}/fluent-bit-${PV}" | 12 | S = "${WORKDIR}/fluent-bit-${PV}" |
13 | 13 | ||