diff options
author | Kai Kang <kai.kang@windriver.com> | 2016-08-10 17:49:50 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-08-15 12:32:00 +0200 |
commit | 7f3023003cb1c0c2428b09055b9808c9c4ec0245 (patch) | |
tree | e2768dfa0932d9a9ea288f3dc1963cc94fc879b0 /meta-oe/recipes-extended/efivar | |
parent | 2ad60db95aa580f31caf8b671951c3f2f13dd4b1 (diff) | |
download | meta-openembedded-7f3023003cb1c0c2428b09055b9808c9c4ec0245.tar.gz |
efivar: 0.23 -> 0.24
Upgrade efivar from 0.23 to 0.24. Enable full native build at same
time and add patch to fix compile error of "multiple definition of
`efi_set_variable'".
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/efivar')
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar/allow-multi-definitions-for-native.patch | 23 | ||||
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar_0.24.bb (renamed from meta-oe/recipes-extended/efivar/efivar_0.23.bb) | 17 |
2 files changed, 31 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar/allow-multi-definitions-for-native.patch b/meta-oe/recipes-extended/efivar/efivar/allow-multi-definitions-for-native.patch new file mode 100644 index 000000000..87f555509 --- /dev/null +++ b/meta-oe/recipes-extended/efivar/efivar/allow-multi-definitions-for-native.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | It fails to create .so file when build efivar-native: | ||
4 | |||
5 | | lib.o:(*IND*+0x0): multiple definition of `efi_set_variable' | ||
6 | | lib.o:lib.c:(.text+0xa0): first defined here | ||
7 | |||
8 | Add link option '-z muldefs' to fix it. | ||
9 | |||
10 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
11 | --- | ||
12 | diff --git a/Make.rules b/Make.rules | ||
13 | index d9c0609..874bce0 100644 | ||
14 | --- a/Make.rules | ||
15 | +++ b/Make.rules | ||
16 | @@ -20,6 +20,7 @@ include $(TOPDIR)/Make.version | ||
17 | $(CCLD) $(ccldflags) $(CPPFLAGS) $(SOFLAGS) \ | ||
18 | -Wl,-soname,$@.$(MAJOR_VERSION) \ | ||
19 | -Wl,--version-script=$(MAP) \ | ||
20 | + -Wl,-z,muldefs \ | ||
21 | -o $@ $^ $(LDLIBS) | ||
22 | |||
23 | %.o : %.c | ||
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.23.bb b/meta-oe/recipes-extended/efivar/efivar_0.24.bb index 5879031fc..35412b6bc 100644 --- a/meta-oe/recipes-extended/efivar/efivar_0.23.bb +++ b/meta-oe/recipes-extended/efivar/efivar_0.24.bb | |||
@@ -5,18 +5,21 @@ HOMEPAGE = "https://github.com/rhinstaller/efivar" | |||
5 | LICENSE = "LGPLv2.1" | 5 | LICENSE = "LGPLv2.1" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
7 | 7 | ||
8 | DEPENDS_class-target = "popt efivar-native" | 8 | DEPENDS = "popt" |
9 | DEPENDS_append_class-target = " efivar-native" | ||
9 | 10 | ||
10 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
11 | 12 | ||
12 | SRCREV = "7367d78281fa3ce390e10c7c9f4608c58e7a6d3d" | 13 | SRCREV = "963cb2e5adc145fe00717f94e382f2973f80e753" |
13 | SRC_URI = "git://github.com/rhinstaller/efivar.git" | 14 | SRC_URI = "git://github.com/rhinstaller/efivar.git \ |
15 | file://0002-disable-static-build.patch \ | ||
16 | " | ||
14 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ | 17 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ |
15 | file://0002-disable-static-build.patch \ | ||
16 | file://0003-efivar-fix-for-cross-compile.patch \ | 18 | file://0003-efivar-fix-for-cross-compile.patch \ |
17 | file://0004-fix-unknow-option-for-gold-linker.patch \ | 19 | file://0004-fix-unknow-option-for-gold-linker.patch \ |
18 | " | 20 | " |
19 | SRC_URI_append_class-native = " file://fix-compile-failure-with-host-gcc-4.6.patch \ | 21 | SRC_URI_append_class-native = " file://fix-compile-failure-with-host-gcc-4.6.patch \ |
22 | file://allow-multi-definitions-for-native.patch \ | ||
20 | " | 23 | " |
21 | 24 | ||
22 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
@@ -28,15 +31,11 @@ do_compile_prepend() { | |||
28 | sed -i -e s:-Werror::g ${S}/gcc.specs | 31 | sed -i -e s:-Werror::g ${S}/gcc.specs |
29 | } | 32 | } |
30 | 33 | ||
31 | do_compile_class-native() { | ||
32 | oe_runmake -C src makeguids | ||
33 | } | ||
34 | |||
35 | do_install() { | 34 | do_install() { |
36 | oe_runmake install DESTDIR=${D} | 35 | oe_runmake install DESTDIR=${D} |
37 | } | 36 | } |
38 | 37 | ||
39 | do_install_class-native() { | 38 | do_install_append_class-native() { |
40 | install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids | 39 | install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids |
41 | } | 40 | } |
42 | 41 | ||