summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/corosync
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-01-09 14:07:32 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-12 15:34:45 +0100
commitdf0d0066ef25abbb288257b0e75fe47559c1d648 (patch)
treebc329e65872d90c8e0c234dd0ba82f6c9143f824 /meta-oe/recipes-extended/corosync
parentafeac90022fb62fddf179fa21cd4132da18153fb (diff)
downloadmeta-openembedded-df0d0066ef25abbb288257b0e75fe47559c1d648.tar.gz
corosync_2.3.4: add new recipe
The Corosync Cluster Engine and Application Programming Interfaces. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/corosync')
-rw-r--r--meta-oe/recipes-extended/corosync/corosync_2.3.4.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/corosync/corosync_2.3.4.bb b/meta-oe/recipes-extended/corosync/corosync_2.3.4.bb
new file mode 100644
index 000000000..b84257fc0
--- /dev/null
+++ b/meta-oe/recipes-extended/corosync/corosync_2.3.4.bb
@@ -0,0 +1,61 @@
1SUMMARY = "The Corosync Cluster Engine and Application Programming Interfaces"
2DESCRIPTION = "This package contains the Corosync Cluster Engine Executive, several default \
3APIs and libraries, default configuration files, and an init script."
4HOMEPAGE = "http://corosync.github.io/corosync/"
5
6SECTION = "base"
7
8inherit autotools pkgconfig systemd
9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 "
12
13SRC_URI[md5sum] = "4b0f36a1dc014527e5b192265dbd7e70"
14SRC_URI[sha256sum] = "3dae93fb1cf5c560295253b0560cbc25421ed053ee373852864f3a60c03247d4"
15
16LICENSE = "BSD"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
18
19DEPENDS = "groff-native nss libqb"
20
21SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service"
22SYSTEMD_AUTO_ENABLE = "enable"
23
24INITSCRIPT_NAME = "corosync-daemon"
25
26PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
27
28PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_unitdir}/system/,--with-systemddir="
29
30EXTRA_OECONF = "--disable-nss \
31 --with-upstartdir=%{_sysconfdir}/init \
32"
33EXTRA_OECONF += " --enable-nss "
34
35do_configure_prepend() {
36 ( cd ${S}
37 ${S}/autogen.sh )
38}
39
40do_install_append() {
41 install -d ${D}${sysconfdir}/sysconfig/
42 install -d ${D}/${sysconfdir}/init.d
43 install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync
44 install -m 0644 ${S}/init/corosync-notifyd.conf.in ${D}${sysconfdir}/sysconfig/corosync-notifyd.conf
45 install -m 0644 ${S}/init/corosync.conf.in ${D}${sysconfdir}/sysconfig/corosync.conf
46 install -m 0644 ${S}/init/corosync.in ${D}${sysconfdir}/init.d/corosync
47 install -m 0644 ${S}/init/corosync-notifyd.in ${D}${sysconfdir}/init.d/corosync-notifyd
48
49 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
50 install -d ${D}${systemd_unitdir}/system
51 install -m 0644 ${S}/init/corosync.service.in ${D}${systemd_unitdir}/system/corosync.service
52 install -m 0644 ${S}/init/corosync-notifyd.service.in ${D}${systemd_unitdir}/system/corosync-notifyd.service
53 sed -i -e 's,@INITWRAPPERSDIR@,${sysconfdir}/init.d,g' ${D}${systemd_unitdir}/system/corosync.service
54 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/corosync-notifyd.service
55 sed -i -e 's,@SBINDIR@,${base_sbindir},g' ${D}${systemd_unitdir}/system/corosync-notifyd.service
56 fi
57}
58
59RDEPENDS_${PN} += "bash"
60
61FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"