diff options
author | Roy Li <rongqing.li@windriver.com> | 2015-08-17 17:48:15 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-08-24 13:58:17 +0200 |
commit | ec6ac82b3d493113f22f6dcf8c614fb887643793 (patch) | |
tree | e0563d067340ec2b813fd8a31a4ec4e9765ec124 /meta-oe/recipes-extended/collectd | |
parent | f09842906c2cefb7890c696abcd3ddf5b776258c (diff) | |
download | meta-openembedded-ec6ac82b3d493113f22f6dcf8c614fb887643793.tar.gz |
collectd: upgrade to 5.5.0
1. remove two patch glibc-2.20-compatiblity.patch and
0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch, which
have been merged into
2. update collectd-version.patch
3. redefine the collectd dependence
4. update the license, lots of components have been relicensed to the MIT
license, and The majority of plugins is licensed either under the "MIT License"
or the "GNU General Public License"
4. update the checksum
Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/collectd')
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/collectd-version.patch | 16 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch | 102 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd_5.5.0.bb (renamed from meta-oe/recipes-extended/collectd/collectd_5.4.1.bb) | 12 |
5 files changed, 41 insertions, 147 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch b/meta-oe/recipes-extended/collectd/collectd/0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch deleted file mode 100644 index 52b9a86cb..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From f6c89c17955223bf8c99a901ca6f901b83fa521f Mon Sep 17 00:00:00 2001 | ||
2 | From: Marc Fournier <marc.fournier@camptocamp.com> | ||
3 | Date: Wed, 3 Dec 2014 16:15:28 +0100 | ||
4 | Subject: [PATCH] netlink: ensure size_t portability in DEBUG() statement | ||
5 | |||
6 | This prevents the following error when building on 32bit systems with | ||
7 | gcc 4.7.2: | ||
8 | |||
9 | netlink.c: In function 'ir_read': | ||
10 | netlink.c:783:7: error: format '%lu' expects argument of type 'long unsigned int', but argument 5 has type 'size_t' [-Werror=format] | ||
11 | --- | ||
12 | src/netlink.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/netlink.c b/src/netlink.c | ||
16 | index 422dc8c..3c4642c 100644 | ||
17 | --- a/src/netlink.c | ||
18 | +++ b/src/netlink.c | ||
19 | @@ -683,7 +683,7 @@ static int ir_read (void) | ||
20 | continue; | ||
21 | } | ||
22 | |||
23 | - DEBUG ("netlink plugin: ir_read: querying %s from %s (%lu).", | ||
24 | + DEBUG ("netlink plugin: ir_read: querying %s from %s (%zu).", | ||
25 | type_name[type_index], iflist[ifindex], ifindex); | ||
26 | |||
27 | nlh = mnl_nlmsg_put_header (buf); | ||
28 | -- | ||
29 | 2.1.4 | ||
30 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch b/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch new file mode 100644 index 000000000..ef6afad9b --- /dev/null +++ b/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | [PATCH] define the collectd dependence | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | libavltree.la libcommon.la libheap.la are created dynamically, and in LDADD, | ||
6 | but not in DEPENDENCIES | ||
7 | |||
8 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
9 | --- | ||
10 | src/daemon/Makefile.am | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am | ||
14 | index 10860ec..7f826e3 100644 | ||
15 | --- a/src/daemon/Makefile.am | ||
16 | +++ b/src/daemon/Makefile.am | ||
17 | @@ -49,7 +49,7 @@ collectd_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL) | ||
18 | collectd_CFLAGS = $(AM_CFLAGS) | ||
19 | collectd_LDFLAGS = -export-dynamic | ||
20 | collectd_LDADD = libavltree.la libcommon.la libheap.la -lm | ||
21 | -collectd_DEPENDENCIES = | ||
22 | +collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la | ||
23 | |||
24 | # Link to these libraries.. | ||
25 | if BUILD_WITH_LIBRT | ||
26 | -- | ||
27 | 1.9.1 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch b/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch index 1e2b7c159..86c3f65b7 100644 --- a/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch +++ b/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch | |||
@@ -11,21 +11,19 @@ Upstream-Status: Pending | |||
11 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | 11 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> |
12 | 12 | ||
13 | diff --git a/version-gen.sh b/version-gen.sh | 13 | diff --git a/version-gen.sh b/version-gen.sh |
14 | index e344541..d1c0929 100755 | 14 | index b09be8e..2671066 100755 |
15 | --- a/version-gen.sh | 15 | --- a/version-gen.sh |
16 | +++ b/version-gen.sh | 16 | +++ b/version-gen.sh |
17 | @@ -2,7 +2,10 @@ | 17 | @@ -2,8 +2,10 @@ |
18 | 18 | ||
19 | DEFAULT_VERSION="5.2.2.git" | 19 | DEFAULT_VERSION="5.5.0.git" |
20 | 20 | ||
21 | -VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`" | 21 | -VERSION="`git describe 2> /dev/null | grep collectd | sed -e 's/^collectd-//'`" |
22 | - | ||
22 | +VERSION="" | 23 | +VERSION="" |
23 | +if test -d .git ; then | 24 | +if test -d .git ; then |
24 | + VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`" | 25 | + VERSION="`git describe 2> /dev/null | grep collectd | sed -e 's/^collectd-//'`" |
25 | +fi | 26 | +fi |
26 | |||
27 | if test -z "$VERSION"; then | 27 | if test -z "$VERSION"; then |
28 | VERSION="$DEFAULT_VERSION" | 28 | VERSION="$DEFAULT_VERSION" |
29 | -- | 29 | fi |
30 | 1.7.10.4 | ||
31 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch b/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch deleted file mode 100644 index 2596bedf9..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch +++ /dev/null | |||
@@ -1,102 +0,0 @@ | |||
1 | This makes it forward compatible with glibc 2.20+ where _BSD_SOURCE | ||
2 | macro has been deprecated. | ||
3 | |||
4 | Fixes warnings like | ||
5 | |||
6 | usr/include/features.h:148:3: error: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Werror=cpp] | ||
7 | | # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | Upstream-Status: Pending | ||
11 | Index: collectd-5.4.1/configure.ac | ||
12 | =================================================================== | ||
13 | --- collectd-5.4.1.orig/configure.ac 2014-09-03 01:21:10.666084244 -0700 | ||
14 | +++ collectd-5.4.1/configure.ac 2014-09-03 01:31:27.794084244 -0700 | ||
15 | @@ -1288,6 +1288,7 @@ | ||
16 | |||
17 | AC_CHECK_MEMBERS([struct udphdr.uh_dport, struct udphdr.uh_sport], [], [], | ||
18 | [#define _BSD_SOURCE | ||
19 | +#define _DEFAULT_SOURCE 1 | ||
20 | #if HAVE_STDINT_H | ||
21 | # include <stdint.h> | ||
22 | #endif | ||
23 | @@ -1309,6 +1310,7 @@ | ||
24 | ]) | ||
25 | AC_CHECK_MEMBERS([struct udphdr.dest, struct udphdr.source], [], [], | ||
26 | [#define _BSD_SOURCE | ||
27 | +#define _DEFAULT_SOURCE 1 | ||
28 | #if HAVE_STDINT_H | ||
29 | # include <stdint.h> | ||
30 | #endif | ||
31 | Index: collectd-5.4.1/src/dns.c | ||
32 | =================================================================== | ||
33 | --- collectd-5.4.1.orig/src/dns.c 2014-01-26 00:09:14.856391886 -0800 | ||
34 | +++ collectd-5.4.1/src/dns.c 2014-09-03 01:32:37.666084244 -0700 | ||
35 | @@ -22,6 +22,7 @@ | ||
36 | **/ | ||
37 | |||
38 | #define _BSD_SOURCE | ||
39 | +#define _DEFAULT_SOURCE 1 | ||
40 | |||
41 | #include "collectd.h" | ||
42 | #include "common.h" | ||
43 | Index: collectd-5.4.1/src/exec.c | ||
44 | =================================================================== | ||
45 | --- collectd-5.4.1.orig/src/exec.c 2014-01-26 00:09:14.860391963 -0800 | ||
46 | +++ collectd-5.4.1/src/exec.c 2014-09-03 01:32:28.874084244 -0700 | ||
47 | @@ -24,6 +24,7 @@ | ||
48 | **/ | ||
49 | |||
50 | #define _BSD_SOURCE /* For setgroups */ | ||
51 | +#define _DEFAULT_SOURCE 1 | ||
52 | |||
53 | #include "collectd.h" | ||
54 | #include "common.h" | ||
55 | Index: collectd-5.4.1/src/load.c | ||
56 | =================================================================== | ||
57 | --- collectd-5.4.1.orig/src/load.c 2014-01-26 00:09:23.532559941 -0800 | ||
58 | +++ collectd-5.4.1/src/load.c 2014-09-03 01:32:51.462084244 -0700 | ||
59 | @@ -22,6 +22,7 @@ | ||
60 | **/ | ||
61 | |||
62 | #define _BSD_SOURCE | ||
63 | +#define _DEFAULT_SOURCE 1 | ||
64 | |||
65 | #include "collectd.h" | ||
66 | #include "common.h" | ||
67 | Index: collectd-5.4.1/src/network.c | ||
68 | =================================================================== | ||
69 | --- collectd-5.4.1.orig/src/network.c 2014-01-26 00:09:23.532559941 -0800 | ||
70 | +++ collectd-5.4.1/src/network.c 2014-09-03 01:32:44.522084244 -0700 | ||
71 | @@ -23,6 +23,7 @@ | ||
72 | **/ | ||
73 | |||
74 | #define _BSD_SOURCE /* For struct ip_mreq */ | ||
75 | +#define _DEFAULT_SOURCE 1 | ||
76 | |||
77 | #include "collectd.h" | ||
78 | #include "plugin.h" | ||
79 | Index: collectd-5.4.1/src/ntpd.c | ||
80 | =================================================================== | ||
81 | --- collectd-5.4.1.orig/src/ntpd.c 2014-01-26 00:09:14.880392351 -0800 | ||
82 | +++ collectd-5.4.1/src/ntpd.c 2014-09-03 01:32:20.350084244 -0700 | ||
83 | @@ -20,6 +20,7 @@ | ||
84 | **/ | ||
85 | |||
86 | #define _BSD_SOURCE /* For NI_MAXHOST */ | ||
87 | +#define _DEFAULT_SOURCE 1 | ||
88 | |||
89 | #include "collectd.h" | ||
90 | #include "common.h" | ||
91 | Index: collectd-5.4.1/src/utils_dns.c | ||
92 | =================================================================== | ||
93 | --- collectd-5.4.1.orig/src/utils_dns.c 2014-01-26 00:09:14.908392893 -0800 | ||
94 | +++ collectd-5.4.1/src/utils_dns.c 2014-09-03 01:31:47.062084244 -0700 | ||
95 | @@ -34,6 +34,7 @@ | ||
96 | */ | ||
97 | |||
98 | #define _BSD_SOURCE | ||
99 | +#define _DEFAULT_SOURCE 1 | ||
100 | |||
101 | #include "collectd.h" | ||
102 | #include "plugin.h" | ||
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.4.1.bb b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb index 3a566db23..feda26be9 100644 --- a/meta-oe/recipes-extended/collectd/collectd_5.4.1.bb +++ b/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb | |||
@@ -1,19 +1,18 @@ | |||
1 | SUMMARY = "Collects and summarises system performance statistics" | 1 | SUMMARY = "Collects and summarises system performance statistics" |
2 | DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files." | 2 | DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files." |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2 & MIT" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1bd21f19f7f0c61a7be8ecacb0e28854" |
5 | 5 | ||
6 | DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2" | 6 | DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2" |
7 | 7 | ||
8 | SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ | 8 | SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ |
9 | file://no-gcrypt-badpath.patch \ | 9 | file://no-gcrypt-badpath.patch \ |
10 | file://collectd-version.patch \ | 10 | file://collectd-version.patch \ |
11 | file://glibc-2.20-compatiblity.patch \ | 11 | file://0001-redefine-the-dependence.patch \ |
12 | file://0001-netlink-ensure-size_t-portability-in-DEBUG-statement.patch \ | ||
13 | file://collectd.init \ | 12 | file://collectd.init \ |
14 | file://collectd.service" | 13 | file://collectd.service" |
15 | SRC_URI[md5sum] = "6f56c71c96573a7f4f7fb3bfab185974" | 14 | SRC_URI[md5sum] = "c39305ef5514b44238b0d31f77e29e6a" |
16 | SRC_URI[sha256sum] = "75452129f271cb0aad28e57f12a49070618bbb7b6a9d64cf869e8766fa2f66e0" | 15 | SRC_URI[sha256sum] = "847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88" |
17 | 16 | ||
18 | inherit autotools pythonnative update-rc.d pkgconfig systemd | 17 | inherit autotools pythonnative update-rc.d pkgconfig systemd |
19 | 18 | ||
@@ -43,6 +42,7 @@ PACKAGECONFIG[pinba] = "--enable-pinba,--disable-pinba,protobuf-c-native protobu | |||
43 | PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" | 42 | PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" |
44 | PACKAGECONFIG[libesmtp] = "--with-libesmtp,--without-libesmtp,libesmtp" | 43 | PACKAGECONFIG[libesmtp] = "--with-libesmtp,--without-libesmtp,libesmtp" |
45 | PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl" | 44 | PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl" |
45 | PACKAGECONFIG[libatasmart] = "--with-libatasmart,--without-libatasmart,libatasmart" | ||
46 | 46 | ||
47 | EXTRA_OECONF = " \ | 47 | EXTRA_OECONF = " \ |
48 | ${FPLAYOUT} \ | 48 | ${FPLAYOUT} \ |