diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-23 22:20:47 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:13:30 +0200 |
commit | adcea06043bf138ac66b3fb6a7ff80dc761b7739 (patch) | |
tree | ac864ec4b16e70567873f3f6e197024cd0e23fab /meta-oe/recipes-extended/collectd | |
parent | 68c22d5bf159110be7d8f6897d54f42e1f1f1834 (diff) | |
download | meta-openembedded-adcea06043bf138ac66b3fb6a7ff80dc761b7739.tar.gz |
collectd: Upgrade to 5.7.1
Drop upstreamed patches or backports
Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/collectd')
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-collectd-replace-deprecated-readdir_r-with-readdir.patch | 66 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch | 47 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch | 121 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/CVE-2016-6254.patch | 55 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/collectd-version.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd/no-gcrypt-badpath.patch | 63 | ||||
-rw-r--r-- | meta-oe/recipes-extended/collectd/collectd_5.7.1.bb (renamed from meta-oe/recipes-extended/collectd/collectd_5.5.0.bb) | 11 |
8 files changed, 185 insertions, 235 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-collectd-replace-deprecated-readdir_r-with-readdir.patch b/meta-oe/recipes-extended/collectd/collectd/0001-collectd-replace-deprecated-readdir_r-with-readdir.patch deleted file mode 100644 index f3d53f26e..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/0001-collectd-replace-deprecated-readdir_r-with-readdir.patch +++ /dev/null | |||
@@ -1,66 +0,0 @@ | |||
1 | Subject: [PATCH] collectd: replace deprecated readdir_r() with readdir() | ||
2 | |||
3 | * Replace the usage of readdir_r() with readdir() | ||
4 | to address a compilation error under glibc 2.24 | ||
5 | due to the deprecation of readdir_r | ||
6 | |||
7 | | ../../collectd-5.5.0/src/vserver.c: In function 'vserver_read': | ||
8 | | ../../collectd-5.5.0/src/vserver.c:167:3: error: 'readdir_r' is deprecated [-Werror=deprecated-declarations] | ||
9 | | status = readdir_r (proc, (struct dirent *) dirent_buffer, &dent); | ||
10 | | ^~~~~~ | ||
11 | | In file included from /buildarea4/myu2/build/prj_test_20160722/bitbake_build/tmp/sysroots/qemux86/usr/include/features.h:368:0, | ||
12 | | from /buildarea4/myu2/build/prj_test_20160722/bitbake_build/tmp/sysroots/qemux86/usr/include/stdio.h:27, | ||
13 | | from ../../collectd-5.5.0/src/daemon/collectd.h:34, | ||
14 | | from ../../collectd-5.5.0/src/vserver.c:29: | ||
15 | | /buildarea4/myu2/build/prj_test_20160722/bitbake_build/tmp/sysroots/qemux86/usr/include/dirent.h:189:12: note: declared here | ||
16 | | extern int __REDIRECT (readdir_r, | ||
17 | | ^ | ||
18 | |||
19 | [1]https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=7584a3f96de88d5eefe5d6c634515278cbfbf052;hp=8d9c92017d85f23ba6a2b3614b2f2bcf1820d6f0 | ||
20 | |||
21 | Upstream-Status: Pending | ||
22 | |||
23 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
24 | --- | ||
25 | src/vserver.c | 15 ++++----------- | ||
26 | 1 file changed, 4 insertions(+), 11 deletions(-) | ||
27 | |||
28 | diff --git a/src/vserver.c b/src/vserver.c | ||
29 | index bd2e867..2e4e715 100644 | ||
30 | --- a/src/vserver.c | ||
31 | +++ b/src/vserver.c | ||
32 | @@ -131,15 +131,8 @@ static derive_t vserver_get_sock_bytes(const char *s) | ||
33 | |||
34 | static int vserver_read (void) | ||
35 | { | ||
36 | -#if NAME_MAX < 1024 | ||
37 | -# define DIRENT_BUFFER_SIZE (sizeof (struct dirent) + 1024 + 1) | ||
38 | -#else | ||
39 | -# define DIRENT_BUFFER_SIZE (sizeof (struct dirent) + NAME_MAX + 1) | ||
40 | -#endif | ||
41 | - | ||
42 | DIR *proc; | ||
43 | - struct dirent *dent; /* 42 */ | ||
44 | - char dirent_buffer[DIRENT_BUFFER_SIZE]; | ||
45 | + struct dirent *dent = NULL; /* 42 */ | ||
46 | |||
47 | errno = 0; | ||
48 | proc = opendir (PROCDIR); | ||
49 | @@ -164,11 +157,11 @@ static int vserver_read (void) | ||
50 | |||
51 | int status; | ||
52 | |||
53 | - status = readdir_r (proc, (struct dirent *) dirent_buffer, &dent); | ||
54 | - if (status != 0) | ||
55 | + dent = readdir (proc); | ||
56 | + if (dent == NULL && errno != 0) | ||
57 | { | ||
58 | char errbuf[4096]; | ||
59 | - ERROR ("vserver plugin: readdir_r failed: %s", | ||
60 | + ERROR ("vserver plugin: readdir failed: %s", | ||
61 | sstrerror (errno, errbuf, sizeof (errbuf))); | ||
62 | closedir (proc); | ||
63 | return (-1); | ||
64 | -- | ||
65 | 2.8.2 | ||
66 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch b/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch index d0a58041f..1ceacd8c4 100644 --- a/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch +++ b/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch | |||
@@ -9,31 +9,28 @@ Signed-off-by: Roy Li <rongqing.li@windriver.com> | |||
9 | configure.ac | 14 ++++++++------ | 9 | configure.ac | 14 ++++++++------ |
10 | 1 file changed, 8 insertions(+), 6 deletions(-) | 10 | 1 file changed, 8 insertions(+), 6 deletions(-) |
11 | 11 | ||
12 | diff --git a/configure.ac b/configure.ac | 12 | Index: collectd-5.7.1/configure.ac |
13 | index 923498e..7206095 100644 | 13 | =================================================================== |
14 | --- a/configure.ac | 14 | --- collectd-5.7.1.orig/configure.ac |
15 | +++ b/configure.ac | 15 | +++ collectd-5.7.1/configure.ac |
16 | @@ -4778,12 +4778,14 @@ then | 16 | @@ -5556,12 +5556,14 @@ else |
17 | with_libxml2="no (pkg-config doesn't know libxml-2.0)" | 17 | with_libxml2="no (pkg-config doesn't know libxml-2.0)" |
18 | fi | 18 | fi |
19 | 19 | ||
20 | - $PKG_CONFIG --exists libvirt 2>/dev/null | 20 | -$PKG_CONFIG --exists libvirt 2>/dev/null |
21 | - if test "$?" = "0" | 21 | -if test "$?" = "0" |
22 | - then | 22 | -then |
23 | - with_libvirt="yes" | 23 | - with_libvirt="yes" |
24 | - else | 24 | -else |
25 | - with_libvirt="no (pkg-config doesn't know libvirt)" | 25 | - with_libvirt="no (pkg-config doesn't know libvirt)" |
26 | + if test "x$enable_libvirt" = "xyes"; then | 26 | +if test "x$enable_libvirt" = "xyes"; then |
27 | + $PKG_CONFIG --exists libvirt 2>/dev/null | 27 | + $PKG_CONFIG --exists libvirt 2>/dev/null |
28 | + if test "$?" = "0" | 28 | + if test "$?" = "0" |
29 | + then | 29 | + then |
30 | + with_libvirt="yes" | 30 | + with_libvirt="yes" |
31 | + else | 31 | + else |
32 | + with_libvirt="no (pkg-config doesn't know libvirt)" | 32 | + with_libvirt="no (pkg-config doesn't know libvirt)" |
33 | + fi | 33 | + fi |
34 | fi | ||
35 | fi | 34 | fi |
36 | if test "x$with_libxml2" = "xyes" | 35 | if test "x$with_libxml2" = "xyes" |
37 | -- | 36 | then |
38 | 1.9.1 | ||
39 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch b/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch new file mode 100644 index 000000000..70b0983e4 --- /dev/null +++ b/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch | |||
@@ -0,0 +1,121 @@ | |||
1 | From 14d469bc82c758116aef7d549abd49c131b4170f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 11:54:57 -0700 | ||
4 | Subject: [PATCH] configure: Check for -Wno-error=format-truncation compiler | ||
5 | option | ||
6 | |||
7 | If this option is supported by compiler then disable it ( gcc7+) | ||
8 | Fixes | ||
9 | client.c:834:23: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 1010 [-Werror=format-truncation=] | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | configure.ac | 3 +- | ||
14 | m4/ax_check_compile_flag.m4 | 74 +++++++++++++++++++++++++++++++++++++++++++++ | ||
15 | 2 files changed, 76 insertions(+), 1 deletion(-) | ||
16 | create mode 100644 m4/ax_check_compile_flag.m4 | ||
17 | |||
18 | diff --git a/configure.ac b/configure.ac | ||
19 | index 8854542..f3a6b57 100644 | ||
20 | --- a/configure.ac | ||
21 | +++ b/configure.ac | ||
22 | @@ -4,7 +4,6 @@ AC_INIT([collectd],[m4_esyscmd(./version-gen.sh)]) | ||
23 | AC_CONFIG_SRCDIR(src/target_set.c) | ||
24 | AC_CONFIG_HEADERS(src/config.h) | ||
25 | AC_CONFIG_AUX_DIR([libltdl/config]) | ||
26 | - | ||
27 | dnl older automake's default of ARFLAGS=cru is noisy on newer binutils; | ||
28 | dnl we don't really need the 'u' even in older toolchains. Then there is | ||
29 | dnl older libtool, which spelled it AR_FLAGS | ||
30 | @@ -6688,6 +6687,8 @@ then | ||
31 | AM_CFLAGS="$AM_CFLAGS -Werror" | ||
32 | AM_CXXFLAGS="$AM_CXXFLAGS -Werror" | ||
33 | fi | ||
34 | +AX_CHECK_COMPILE_FLAG([-Werror=format-truncation],[AM_CFLAGS="$AM_CFLAGS -Wno-error=format-truncation" AM_CXXFLAGS="$AM_CXXFLAGS -Wno-error=format-truncation"]) | ||
35 | + | ||
36 | AC_SUBST([AM_CFLAGS]) | ||
37 | AC_SUBST([AM_CXXFLAGS]) | ||
38 | |||
39 | diff --git a/m4/ax_check_compile_flag.m4 b/m4/ax_check_compile_flag.m4 | ||
40 | new file mode 100644 | ||
41 | index 0000000..dcabb92 | ||
42 | --- /dev/null | ||
43 | +++ b/m4/ax_check_compile_flag.m4 | ||
44 | @@ -0,0 +1,74 @@ | ||
45 | +# =========================================================================== | ||
46 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html | ||
47 | +# =========================================================================== | ||
48 | +# | ||
49 | +# SYNOPSIS | ||
50 | +# | ||
51 | +# AX_CHECK_COMPILE_FLAG(FLAG, [ACTION-SUCCESS], [ACTION-FAILURE], [EXTRA-FLAGS], [INPUT]) | ||
52 | +# | ||
53 | +# DESCRIPTION | ||
54 | +# | ||
55 | +# Check whether the given FLAG works with the current language's compiler | ||
56 | +# or gives an error. (Warnings, however, are ignored) | ||
57 | +# | ||
58 | +# ACTION-SUCCESS/ACTION-FAILURE are shell commands to execute on | ||
59 | +# success/failure. | ||
60 | +# | ||
61 | +# If EXTRA-FLAGS is defined, it is added to the current language's default | ||
62 | +# flags (e.g. CFLAGS) when the check is done. The check is thus made with | ||
63 | +# the flags: "CFLAGS EXTRA-FLAGS FLAG". This can for example be used to | ||
64 | +# force the compiler to issue an error when a bad flag is given. | ||
65 | +# | ||
66 | +# INPUT gives an alternative input source to AC_COMPILE_IFELSE. | ||
67 | +# | ||
68 | +# NOTE: Implementation based on AX_CFLAGS_GCC_OPTION. Please keep this | ||
69 | +# macro in sync with AX_CHECK_{PREPROC,LINK}_FLAG. | ||
70 | +# | ||
71 | +# LICENSE | ||
72 | +# | ||
73 | +# Copyright (c) 2008 Guido U. Draheim <guidod@gmx.de> | ||
74 | +# Copyright (c) 2011 Maarten Bosmans <mkbosmans@gmail.com> | ||
75 | +# | ||
76 | +# This program is free software: you can redistribute it and/or modify it | ||
77 | +# under the terms of the GNU General Public License as published by the | ||
78 | +# Free Software Foundation, either version 3 of the License, or (at your | ||
79 | +# option) any later version. | ||
80 | +# | ||
81 | +# This program is distributed in the hope that it will be useful, but | ||
82 | +# WITHOUT ANY WARRANTY; without even the implied warranty of | ||
83 | +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General | ||
84 | +# Public License for more details. | ||
85 | +# | ||
86 | +# You should have received a copy of the GNU General Public License along | ||
87 | +# with this program. If not, see <https://www.gnu.org/licenses/>. | ||
88 | +# | ||
89 | +# As a special exception, the respective Autoconf Macro's copyright owner | ||
90 | +# gives unlimited permission to copy, distribute and modify the configure | ||
91 | +# scripts that are the output of Autoconf when processing the Macro. You | ||
92 | +# need not follow the terms of the GNU General Public License when using | ||
93 | +# or distributing such scripts, even though portions of the text of the | ||
94 | +# Macro appear in them. The GNU General Public License (GPL) does govern | ||
95 | +# all other use of the material that constitutes the Autoconf Macro. | ||
96 | +# | ||
97 | +# This special exception to the GPL applies to versions of the Autoconf | ||
98 | +# Macro released by the Autoconf Archive. When you make and distribute a | ||
99 | +# modified version of the Autoconf Macro, you may extend this special | ||
100 | +# exception to the GPL to apply to your modified version as well. | ||
101 | + | ||
102 | +#serial 5 | ||
103 | + | ||
104 | +AC_DEFUN([AX_CHECK_COMPILE_FLAG], | ||
105 | +[AC_PREREQ(2.64)dnl for _AC_LANG_PREFIX and AS_VAR_IF | ||
106 | +AS_VAR_PUSHDEF([CACHEVAR],[ax_cv_check_[]_AC_LANG_ABBREV[]flags_$4_$1])dnl | ||
107 | +AC_CACHE_CHECK([whether _AC_LANG compiler accepts $1], CACHEVAR, [ | ||
108 | + ax_check_save_flags=$[]_AC_LANG_PREFIX[]FLAGS | ||
109 | + _AC_LANG_PREFIX[]FLAGS="$[]_AC_LANG_PREFIX[]FLAGS $4 $1" | ||
110 | + AC_COMPILE_IFELSE([m4_default([$5],[AC_LANG_PROGRAM()])], | ||
111 | + [AS_VAR_SET(CACHEVAR,[yes])], | ||
112 | + [AS_VAR_SET(CACHEVAR,[no])]) | ||
113 | + _AC_LANG_PREFIX[]FLAGS=$ax_check_save_flags]) | ||
114 | +AS_VAR_IF(CACHEVAR,yes, | ||
115 | + [m4_default([$2], :)], | ||
116 | + [m4_default([$3], :)]) | ||
117 | +AS_VAR_POPDEF([CACHEVAR])dnl | ||
118 | +])dnl AX_CHECK_COMPILE_FLAGS | ||
119 | -- | ||
120 | 2.12.2 | ||
121 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch b/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch deleted file mode 100644 index ef6afad9b..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/0001-redefine-the-dependence.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | [PATCH] define the collectd dependence | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | libavltree.la libcommon.la libheap.la are created dynamically, and in LDADD, | ||
6 | but not in DEPENDENCIES | ||
7 | |||
8 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
9 | --- | ||
10 | src/daemon/Makefile.am | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am | ||
14 | index 10860ec..7f826e3 100644 | ||
15 | --- a/src/daemon/Makefile.am | ||
16 | +++ b/src/daemon/Makefile.am | ||
17 | @@ -49,7 +49,7 @@ collectd_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL) | ||
18 | collectd_CFLAGS = $(AM_CFLAGS) | ||
19 | collectd_LDFLAGS = -export-dynamic | ||
20 | collectd_LDADD = libavltree.la libcommon.la libheap.la -lm | ||
21 | -collectd_DEPENDENCIES = | ||
22 | +collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la | ||
23 | |||
24 | # Link to these libraries.. | ||
25 | if BUILD_WITH_LIBRT | ||
26 | -- | ||
27 | 1.9.1 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/CVE-2016-6254.patch b/meta-oe/recipes-extended/collectd/collectd/CVE-2016-6254.patch deleted file mode 100644 index bc85b4c0e..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/CVE-2016-6254.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | From dd8483a4beb6f61521d8b32c726523bbea21cd92 Mon Sep 17 00:00:00 2001 | ||
2 | From: Florian Forster <octo@collectd.org> | ||
3 | Date: Tue, 19 Jul 2016 10:00:37 +0200 | ||
4 | Subject: [PATCH] network plugin: Fix heap overflow in parse_packet(). | ||
5 | |||
6 | Emilien Gaspar has identified a heap overflow in parse_packet(), the | ||
7 | function used by the network plugin to parse incoming network packets. | ||
8 | |||
9 | This is a vulnerability in collectd, though the scope is not clear at | ||
10 | this point. At the very least specially crafted network packets can be | ||
11 | used to crash the daemon. We can't rule out a potential remote code | ||
12 | execution though. | ||
13 | |||
14 | Fixes: CVE-2016-6254 | ||
15 | |||
16 | cherry picked from upstream commit b589096f | ||
17 | |||
18 | Upstream Status: Backport | ||
19 | |||
20 | Signed-off-by: Alexandru Moise <alexandru.moise@windriver.com> | ||
21 | --- | ||
22 | src/network.c | 3 +++ | ||
23 | 1 file changed, 3 insertions(+) | ||
24 | |||
25 | diff --git a/src/network.c b/src/network.c | ||
26 | index 551bd5c..cb979b2 100644 | ||
27 | --- a/src/network.c | ||
28 | +++ b/src/network.c | ||
29 | @@ -1444,6 +1444,7 @@ static int parse_packet (sockent_t *se, /* {{{ */ | ||
30 | printed_ignore_warning = 1; | ||
31 | } | ||
32 | buffer = ((char *) buffer) + pkg_length; | ||
33 | + buffer_size -= (size_t) pkg_length; | ||
34 | continue; | ||
35 | } | ||
36 | #endif /* HAVE_LIBGCRYPT */ | ||
37 | @@ -1471,6 +1472,7 @@ static int parse_packet (sockent_t *se, /* {{{ */ | ||
38 | printed_ignore_warning = 1; | ||
39 | } | ||
40 | buffer = ((char *) buffer) + pkg_length; | ||
41 | + buffer_size -= (size_t) pkg_length; | ||
42 | continue; | ||
43 | } | ||
44 | #endif /* HAVE_LIBGCRYPT */ | ||
45 | @@ -1612,6 +1614,7 @@ static int parse_packet (sockent_t *se, /* {{{ */ | ||
46 | DEBUG ("network plugin: parse_packet: Unknown part" | ||
47 | " type: 0x%04hx", pkg_type); | ||
48 | buffer = ((char *) buffer) + pkg_length; | ||
49 | + buffer_size -= (size_t) pkg_length; | ||
50 | } | ||
51 | } /* while (buffer_size > sizeof (part_header_t)) */ | ||
52 | |||
53 | -- | ||
54 | 2.7.4 | ||
55 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch b/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch deleted file mode 100644 index 86c3f65b7..000000000 --- a/meta-oe/recipes-extended/collectd/collectd/collectd-version.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | Don't pick up version string from parent git repository | ||
2 | |||
3 | If the collectd source is extracted from a tarball underneath a | ||
4 | directory structure that includes another git repository, that | ||
5 | repository will be picked up by "git describe" which is not | ||
6 | desirable. Check whether collectd itself is a git repository and just | ||
7 | use the default version if not. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | ||
12 | |||
13 | diff --git a/version-gen.sh b/version-gen.sh | ||
14 | index b09be8e..2671066 100755 | ||
15 | --- a/version-gen.sh | ||
16 | +++ b/version-gen.sh | ||
17 | @@ -2,8 +2,10 @@ | ||
18 | |||
19 | DEFAULT_VERSION="5.5.0.git" | ||
20 | |||
21 | -VERSION="`git describe 2> /dev/null | grep collectd | sed -e 's/^collectd-//'`" | ||
22 | - | ||
23 | +VERSION="" | ||
24 | +if test -d .git ; then | ||
25 | + VERSION="`git describe 2> /dev/null | grep collectd | sed -e 's/^collectd-//'`" | ||
26 | +fi | ||
27 | if test -z "$VERSION"; then | ||
28 | VERSION="$DEFAULT_VERSION" | ||
29 | fi | ||
diff --git a/meta-oe/recipes-extended/collectd/collectd/no-gcrypt-badpath.patch b/meta-oe/recipes-extended/collectd/collectd/no-gcrypt-badpath.patch index 0e876ae85..1fde6a071 100644 --- a/meta-oe/recipes-extended/collectd/collectd/no-gcrypt-badpath.patch +++ b/meta-oe/recipes-extended/collectd/collectd/no-gcrypt-badpath.patch | |||
@@ -1,30 +1,43 @@ | |||
1 | Disable defaulting of GCRYPT_LDFLAGS to -L/usr/lib | 1 | Index: collectd-5.7.1/configure.ac |
2 | |||
3 | Prevents "unsafe for cross compilation" warnings that cause | ||
4 | do_qa_configure to fail. | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | ||
9 | |||
10 | Index: collectd-5.4.1/configure.ac | ||
11 | =================================================================== | 2 | =================================================================== |
12 | --- collectd-5.4.1.orig/configure.ac 2014-09-03 01:20:22.062084244 -0700 | 3 | --- collectd-5.7.1.orig/configure.ac |
13 | +++ collectd-5.4.1/configure.ac 2014-09-03 01:20:22.058084244 -0700 | 4 | +++ collectd-5.7.1/configure.ac |
14 | @@ -1867,11 +1867,11 @@ | 5 | @@ -2305,7 +2305,7 @@ AC_ARG_WITH(libgcrypt, [AS_HELP_STRING([ |
15 | GCRYPT_CPPFLAGS=`"$with_libgcrypt_config" --cflags 2>/dev/null` | 6 | with_libgcrypt="yes" |
16 | fi | 7 | else if test -f "$withval/bin/gcrypt-config" && test -x "$withval/bin/gcrypt-config" |
8 | then | ||
9 | - with_libgcrypt_config="$withval/bin/gcrypt-config" | ||
10 | + with_libgcrypt_config="$withval/bin/pkg-config" | ||
11 | with_libgcrypt="yes" | ||
12 | else if test -d "$withval" | ||
13 | then | ||
14 | @@ -2313,12 +2313,12 @@ AC_ARG_WITH(libgcrypt, [AS_HELP_STRING([ | ||
15 | GCRYPT_LDFLAGS="$GCRYPT_LDFLAGS -L$withval/lib" | ||
16 | with_libgcrypt="yes" | ||
17 | else | ||
18 | - with_libgcrypt_config="gcrypt-config" | ||
19 | + with_libgcrypt_config="pkg-config" | ||
20 | with_libgcrypt="$withval" | ||
21 | fi; fi; fi | ||
22 | ], | ||
23 | [ | ||
24 | - with_libgcrypt_config="libgcrypt-config" | ||
25 | + with_libgcrypt_config="pkg-config" | ||
26 | with_libgcrypt="yes" | ||
27 | ]) | ||
17 | 28 | ||
18 | - if test "x$GCRYPT_LDFLAGS" = "x" | 29 | @@ -2326,12 +2326,12 @@ if test "x$with_libgcrypt" = "xyes" && t |
19 | - then | 30 | then |
20 | - gcrypt_exec_prefix=`"$with_libgcrypt_config" --exec-prefix 2>/dev/null` | 31 | if test "x$GCRYPT_CPPFLAGS" = "x" |
21 | - GCRYPT_LDFLAGS="-L$gcrypt_exec_prefix/lib" | 32 | then |
22 | - fi | 33 | - GCRYPT_CPPFLAGS=`"$with_libgcrypt_config" --cflags 2>/dev/null` |
23 | +# if test "x$GCRYPT_LDFLAGS" = "x" | 34 | + GCRYPT_CPPFLAGS=`"$with_libgcrypt_config" --cflags libgcrypt 2>/dev/null` |
24 | +# then | 35 | fi |
25 | +# gcrypt_exec_prefix=`"$with_libgcrypt_config" --exec-prefix 2>/dev/null` | ||
26 | +# GCRYPT_LDFLAGS="-L$gcrypt_exec_prefix/lib" | ||
27 | +# fi | ||
28 | 36 | ||
29 | if test "x$GCRYPT_LIBS" = "x" | 37 | if test "x$GCRYPT_LIBS" = "x" |
30 | then | 38 | then |
39 | - GCRYPT_LIBS=`"$with_libgcrypt_config" --libs 2>/dev/null` | ||
40 | + GCRYPT_LIBS=`"$with_libgcrypt_config" --lib libgcrypt 2>/dev/null` | ||
41 | fi | ||
42 | fi | ||
43 | |||
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb b/meta-oe/recipes-extended/collectd/collectd_5.7.1.bb index 59732db81..b7789c7ca 100644 --- a/meta-oe/recipes-extended/collectd/collectd_5.5.0.bb +++ b/meta-oe/recipes-extended/collectd/collectd_5.7.1.bb | |||
@@ -6,18 +6,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1bd21f19f7f0c61a7be8ecacb0e28854" | |||
6 | DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2" | 6 | DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2" |
7 | 7 | ||
8 | SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ | 8 | SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ |
9 | file://no-gcrypt-badpath.patch \ | ||
10 | file://collectd-version.patch \ | ||
11 | file://0001-redefine-the-dependence.patch \ | ||
12 | file://collectd.init \ | 9 | file://collectd.init \ |
13 | file://collectd.service \ | 10 | file://collectd.service \ |
11 | file://no-gcrypt-badpath.patch \ | ||
14 | file://0001-conditionally-check-libvirt.patch \ | 12 | file://0001-conditionally-check-libvirt.patch \ |
15 | file://0001-collectd-replace-deprecated-readdir_r-with-readdir.patch \ | ||
16 | file://CVE-2016-6254.patch \ | ||
17 | file://0001-fix-to-build-with-glibc-2.25.patch \ | 13 | file://0001-fix-to-build-with-glibc-2.25.patch \ |
14 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ | ||
18 | " | 15 | " |
19 | SRC_URI[md5sum] = "c39305ef5514b44238b0d31f77e29e6a" | 16 | SRC_URI[md5sum] = "dc36141ed3058c4919bbd54b87c07873" |
20 | SRC_URI[sha256sum] = "847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88" | 17 | SRC_URI[sha256sum] = "7edd3643c0842215553b2421d5456f4e9a8a58b07e216b40a7e8e91026d8e501" |
21 | 18 | ||
22 | inherit autotools pythonnative update-rc.d pkgconfig systemd | 19 | inherit autotools pythonnative update-rc.d pkgconfig systemd |
23 | 20 | ||