summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/bitwise
diff options
context:
space:
mode:
authorRamon Fried <rfried.dev@gmail.com>2020-12-15 22:45:42 +0200
committerKhem Raj <raj.khem@gmail.com>2020-12-15 21:29:18 -0800
commit3ef806b2a0cb9dc6614ab75b365c932aa1f9bc4c (patch)
treeef3497501ae9bf8373da65cfba6252208a6f49ad /meta-oe/recipes-extended/bitwise
parentf03ad4971ed0b7cf34550a90ee3c0fa18f964533 (diff)
downloadmeta-openembedded-3ef806b2a0cb9dc6614ab75b365c932aa1f9bc4c.tar.gz
bitwise: add new recipe
Bitwise is multi base interactive calculator supporting dynamic base conversion and bit manipulation. It's a handy tool for low level hackers, kernel developers and device drivers developers. Signed-off-by: Ramon Fried <rfried.dev@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/bitwise')
-rw-r--r--meta-oe/recipes-extended/bitwise/bitwise_0.41.bb24
-rw-r--r--meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch29
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb b/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
new file mode 100644
index 000000000..037822781
--- /dev/null
+++ b/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Bitwise terminal calculator"
2DESCRIPTION = "Bitwise is multi base interactive calculator \
3supporting dynamic base conversion and bit manipulation.\
4It's a handy tool for low level hackers, \
5kernel developers and device drivers developers."
6
7HOMEPAGE = "https://github.com/mellowcandle/bitwise"
8SECTION = "console/utils"
9
10LICENSE = "GPLv3"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
12
13SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
14 file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
15 "
16SRC_URI[sha256sum] = "33ce934fb99dadf7652224152cc135a0abf6a211adde53d96e9be7067567749c"
17
18UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
19
20S = "${WORKDIR}/${BPN}-v${PV}"
21
22DEPENDS = "ncurses readline"
23
24inherit autotools
diff --git a/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch b/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
new file mode 100644
index 000000000..ad3f0bb1f
--- /dev/null
+++ b/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
@@ -0,0 +1,29 @@
1From 2089b514045d2de64a5d9c54e241731e85d77df2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 14 Dec 2020 22:11:59 -0800
4Subject: [PATCH] makefile.am: Fix build when build dir is not same as
5 sourcedir
6
7This ensures right include paths are added to compiler
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Makefile.am | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/Makefile.am b/Makefile.am
15index eba85a1..da998ff 100644
16--- a/Makefile.am
17+++ b/Makefile.am
18@@ -19,7 +19,7 @@ if COND_DEBUG
19 MAYBE_DEBUG=-g -O0
20 endif
21
22-AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE)
23+AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE) -I$(srcdir)/inc
24
25 check_PROGRAMS = tests/test-shunting-yard
26 tests_test_shunting_yard_SOURCES = src/shunting-yard.c inc/shunting-yard.h \
27--
282.29.2
29