summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-13 10:55:51 +0000
committerKhem Raj <raj.khem@gmail.com>2019-01-13 10:28:01 -0800
commite219649594742a200c1dd5d28e8bf2f5eda2504e (patch)
treea83798cb84c1fcbe44cd2035aaaaba840966090b /meta-oe/recipes-devtools
parent24af1f974cc95c50dfa56ad15b113279c3993c5d (diff)
downloadmeta-openembedded-e219649594742a200c1dd5d28e8bf2f5eda2504e.tar.gz
meta-oe: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple attempts at doing so (or simply have re-appeared?). Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb2
-rw-r--r--meta-oe/recipes-devtools/php/php.inc2
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
index f3a0f70ee..c2d2180ba 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
@@ -22,7 +22,7 @@ BBCLASSEXTEND = "native"
22# you need to install the multilib development package (e.g. 22# you need to install the multilib development package (e.g.
23# libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part 23# libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part
24# (HOST_CC="gcc -m32"). 24# (HOST_CC="gcc -m32").
25BUILD_CC_ARCH_append = " ${@['-m32',''][d.getVar('SITEINFO_BITS', True) != '32']}" 25BUILD_CC_ARCH_append = " ${@['-m32',''][d.getVar('SITEINFO_BITS') != '32']}"
26 26
27# The lua makefiles expect the TARGET_SYS to be from uname -s 27# The lua makefiles expect the TARGET_SYS to be from uname -s
28# Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD 28# Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index bfd0ddfb8..ca7bd91b2 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -8,7 +8,7 @@ BBCLASSEXTEND = "native"
8DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native" 8DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native"
9DEPENDS_class-native = "zlib-native libxml2-native" 9DEPENDS_class-native = "zlib-native libxml2-native"
10 10
11PHP_MAJOR_VERSION = "${@d.getVar('PV', True).split('.')[0]}" 11PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}"
12 12
13SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ 13SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
14 file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \ 14 file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
index ca38e6aa2..30c850365 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
@@ -21,7 +21,7 @@ LDFLAGS_append_libc-musl = " -largp"
21 21
22def set_target_arch(d): 22def set_target_arch(d):
23 import re 23 import re
24 arch = d.getVar('TARGET_ARCH', True) 24 arch = d.getVar('TARGET_ARCH')
25 if re.match(r'i.86', arch, re.I): 25 if re.match(r'i.86', arch, re.I):
26 return 'i386' 26 return 'i386'
27 else: 27 else: