summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2018-07-24 09:43:00 -0400
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commitdf411368c0d342ad34094ab8ff022b52caf8fdda (patch)
treea547277bd76dd879a8e28d1e043fc13d651e8aad /meta-oe/recipes-devtools
parent864eb0024f6f8cf91b3484fb002bf89f94fbb1ea (diff)
downloadmeta-openembedded-df411368c0d342ad34094ab8ff022b52caf8fdda.tar.gz
lapack: Add recipe.
* Build tested. * Note: needs FORTRAN enabled in local.conf or similar. * Used to build scipy on pi-3. scipy passed many tests. * Based on work from meta-gnss https://github.com/carlesfernandez/meta-gnss-sdr * Hopefully this helps others playing with scipy and things. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb b/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb
new file mode 100644
index 000000000..ef1abd567
--- /dev/null
+++ b/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Linear Algebra PACKage"
2URL = "http://www.netlib.org/lapack"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40"
5
6# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
7# Enabling FORTRAN
8# Note this is not officially supported and is just illustrated here to
9# show an example of how it can be done
10# You'll also need your fortran recipe to depend on libgfortran
11#FORTRAN_forcevariable = ",fortran"
12#RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath"
13
14DEPENDS = "libgfortran"
15
16SRC_URI = "http://www.netlib.org/lapack/lapack-${PV}.tar.gz"
17SRC_URI[md5sum] = "96591affdbf58c450d45c1daa540dbd2"
18SRC_URI[sha256sum] = "deb22cc4a6120bff72621155a9917f485f96ef8319ac074a7afbc68aab88bcf6"
19
20EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
21OECMAKE_GENERATOR = "Unix Makefiles"
22
23inherit cmake pkgconfig
24