diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-06 18:09:03 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-11 10:46:55 +0100 |
commit | 8be88d3249a8a49f1fda46890494e68499eed1c2 (patch) | |
tree | a018a2e3f6365721812276d24b8197e6a6b82295 /meta-oe/recipes-devtools | |
parent | fc5b483f76571528462806fe030052a8319f8fe6 (diff) | |
download | meta-openembedded-8be88d3249a8a49f1fda46890494e68499eed1c2.tar.gz |
Revert "luajit: Upgrade to 2.1 beta1"
This reverts commit 2ce3086aa859178fb5f7d6db9876229c8ed5a6eb.
Causes sysdig and devilspie2 build failures.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb (renamed from meta-oe/recipes-devtools/luajit/luajit_2.1.bb) | 27 |
2 files changed, 41 insertions, 19 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch new file mode 100644 index 000000000..f123b3f55 --- /dev/null +++ b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 528009f5ca0685c95ef27f6c8957160499c0576a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 10 May 2013 10:42:45 -0700 | ||
4 | Subject: [PATCH] Do not strip automatically, this leaves the stripping | ||
5 | busines to OE | ||
6 | |||
7 | Upstream-Status: Inappropriate [OE-Specific] | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/Makefile | 2 -- | ||
12 | 1 file changed, 2 deletions(-) | ||
13 | |||
14 | diff --git a/src/Makefile b/src/Makefile | ||
15 | index 278324a..5ecd6d5 100644 | ||
16 | --- a/src/Makefile | ||
17 | +++ b/src/Makefile | ||
18 | @@ -665,12 +665,10 @@ $(LUAJIT_A): $(LJVMCORE_O) | ||
19 | $(LUAJIT_SO): $(LJVMCORE_O) | ||
20 | $(E) "DYNLINK $@" | ||
21 | $(Q)$(TARGET_LD) $(TARGET_ASHLDFLAGS) -o $@ $(LJVMCORE_DYNO) $(TARGET_ALIBS) | ||
22 | - $(Q)$(TARGET_STRIP) $@ | ||
23 | |||
24 | $(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP) | ||
25 | $(E) "LINK $@" | ||
26 | $(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) $(TARGET_O) $(TARGET_ALIBS) | ||
27 | - $(Q)$(TARGET_STRIP) $@ | ||
28 | $(E) "OK Successfully built LuaJIT" | ||
29 | |||
30 | ############################################################################## | ||
31 | -- | ||
32 | 1.7.9.5 | ||
33 | |||
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.1.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb index 5cee53267..4a15a4e1b 100644 --- a/meta-oe/recipes-devtools/luajit/luajit_2.1.bb +++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb | |||
@@ -3,13 +3,13 @@ LICENSE = "MIT" | |||
3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3992f1fbae3b8b061f9056b7fcda8cc6" | 3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3992f1fbae3b8b061f9056b7fcda8cc6" |
4 | HOMEPAGE = "http://luajit.org" | 4 | HOMEPAGE = "http://luajit.org" |
5 | 5 | ||
6 | SRCREV = "776c6935ed807fc3b1ee6cd89a0cf682ffb7e9de" | 6 | SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \ |
7 | SRC_URI = "git://luajit.org/git/luajit-2.0.git;protocol=http;branch=v${PV} \ | 7 | file://0001-Do-not-strip-automatically-this-leaves-the-stripping.patch \ |
8 | " | 8 | " |
9 | SRC_URI[md5sum] = "dd9c38307f2223a504cbfb96e477eca0" | ||
10 | SRC_URI[sha256sum] = "620fa4eb12375021bef6e4f237cbd2dd5d49e56beb414bee052c746beef1807d" | ||
9 | 11 | ||
10 | SPIN = ".0-beta1" | 12 | S = "${WORKDIR}/LuaJIT-${PV}" |
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | 13 | ||
14 | inherit pkgconfig binconfig | 14 | inherit pkgconfig binconfig |
15 | 15 | ||
@@ -23,17 +23,7 @@ do_configure_prepend() { | |||
23 | EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX} \ | 23 | EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX} \ |
24 | TARGET_CFLAGS="${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}" \ | 24 | TARGET_CFLAGS="${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}" \ |
25 | TARGET_LDFLAGS="${TOOLCHAIN_OPTIONS}" \ | 25 | TARGET_LDFLAGS="${TOOLCHAIN_OPTIONS}" \ |
26 | TARGET_SHLDFLAGS="${TOOLCHAIN_OPTIONS}" TARGET_STRIP="/bin/echo"' | 26 | TARGET_SHLDFLAGS="${TOOLCHAIN_OPTIONS}"' |
27 | |||
28 | # Important note: On the build machine bit compatible glibc-dev and libgcc must | ||
29 | # be installed. E.g if the target architecture has 32 bit (see '-m32' below), | ||
30 | # 32 bit versions of glibc-dev/libgcc (e.g glibc-devel.i686 / libgcc.i686 on | ||
31 | # fedora) are required. | ||
32 | # | ||
33 | # Otherwise the following error occurs: | ||
34 | # | /usr/include/gnu/stubs.h:7:27: fatal error: gnu/stubs-32.h: No such file or directory | ||
35 | # | # include <gnu/stubs-32.h> | ||
36 | |||
37 | EXTRA_OEMAKE_append_powerpc = ' HOST_CC="${BUILD_CC} -m32"' | 27 | EXTRA_OEMAKE_append_powerpc = ' HOST_CC="${BUILD_CC} -m32"' |
38 | EXTRA_OEMAKE_append_x86 = ' HOST_CC="${BUILD_CC} -m32"' | 28 | EXTRA_OEMAKE_append_x86 = ' HOST_CC="${BUILD_CC} -m32"' |
39 | EXTRA_OEMAKE_append_x86-64 = ' HOST_CC="${BUILD_CC}"' | 29 | EXTRA_OEMAKE_append_x86-64 = ' HOST_CC="${BUILD_CC}"' |
@@ -46,8 +36,7 @@ do_compile () { | |||
46 | } | 36 | } |
47 | 37 | ||
48 | do_install () { | 38 | do_install () { |
49 | oe_runmake 'DESTDIR=${D}' 'TARGET_STRIP=/bin/echo' install | 39 | oe_runmake 'DESTDIR=${D}' install |
50 | ln -s ${bindir}/${BPN}-${PV}${SPIN} ${D}${bindir}/luajit | ||
51 | rmdir ${D}${datadir}/lua/5.* \ | 40 | rmdir ${D}${datadir}/lua/5.* \ |
52 | ${D}${datadir}/lua \ | 41 | ${D}${datadir}/lua \ |
53 | ${D}${libdir}/lua/5.* \ | 42 | ${D}${libdir}/lua/5.* \ |
@@ -63,5 +52,5 @@ FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \ | |||
63 | ${libdir}/libluajit-5.1.so \ | 52 | ${libdir}/libluajit-5.1.so \ |
64 | ${libdir}/pkgconfig/luajit.pc \ | 53 | ${libdir}/pkgconfig/luajit.pc \ |
65 | " | 54 | " |
66 | FILES_luajit-common = "${datadir}/${BPN}-${PV}${SPIN}" | 55 | FILES_luajit-common = "${datadir}/${BPN}-${PV}" |
67 | 56 | ||