summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-29 15:35:46 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commit3dc2b511836de6b9b95f0ece124841322ae341c4 (patch)
tree5dee35cf7ecbe4d7140997e5d19618f74bf35c5e /meta-oe/recipes-devtools
parent920265d47a9d75a8f4054ec2291c7a1c6dc904e8 (diff)
downloadmeta-openembedded-3dc2b511836de6b9b95f0ece124841322ae341c4.tar.gz
jsonrpc: Update to 1.1.1
License-Updare: Change in copyright headers https://github.com/cinemast/libjson-rpc-cpp/commit/ba3507a24bd07e89641ecbc7e567c01a754c8d73#diff-61e0bdf7e1b43c5c93d9488b22e04170 Drop all patches since these issues are already fixed in new version add new dependency on hiredis Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch77
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorclient-Typecast-min-arguments-correctl.patch33
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorserver-Include-sys-select.h-before-oth.patch34
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-memset-and-family-needs-to-include-string.h.patch26
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc/0002-Fix-build-problem-on-Mac.patch27
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc_git.bb (renamed from meta-oe/recipes-devtools/jsonrpc/jsonrpc_0.7.0.bb)20
6 files changed, 8 insertions, 209 deletions
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch
deleted file mode 100644
index 748e4da1a..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1From ac61124df17ab76527508bbb9a3115d4d6cc1af6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 21 Nov 2016 11:26:26 -0800
4Subject: [PATCH] cmake: replace hardcoded lib/${CMAKE_LIBRARY_PATH} with
5 {CMAKE_INSTALL_LIBDIR}
6
7Fixes
8| CMake Error at src/jsonrpccpp/CMakeLists.txt:207 (install):
9| install TARGETS given unknown argument "/lib".
10
11and
12
13Wrong install paths during cross compile
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 src/jsonrpccpp/CMakeLists.txt | 8 ++++----
18 src/stubgenerator/CMakeLists.txt | 6 +++---
19 2 files changed, 7 insertions(+), 7 deletions(-)
20
21diff --git a/src/jsonrpccpp/CMakeLists.txt b/src/jsonrpccpp/CMakeLists.txt
22index e4a1eb5..13f9056 100644
23--- a/src/jsonrpccpp/CMakeLists.txt
24+++ b/src/jsonrpccpp/CMakeLists.txt
25@@ -205,15 +205,15 @@ if (WIN32)
26 endif()
27
28 install(TARGETS ${ALL_LIBS}
29- LIBRARY DESTINATION lib${LIB_SUFFIX}/${CMAKE_LIBRARY_PATH}
30- ARCHIVE DESTINATION lib${LIB_SUFFIX}/${CMAKE_LIBRARY_PATH}
31+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
32+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
33 RUNTIME DESTINATION bin
34 )
35
36 #set pkg-config
37 get_filename_component(FULL_PATH_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX} ABSOLUTE)
38 set(FULL_PATH_INCLUDEDIR "${FULL_PATH_INSTALL_PREFIX}/include")
39-set(FULL_PATH_LIBDIR "${FULL_PATH_INSTALL_PREFIX}/lib/${CMAKE_LIBRARY_PATH}")
40+set(FULL_PATH_LIBDIR "${FULL_PATH_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
41
42 CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/libjsonrpccpp-client.pc.cmake ${CMAKE_BINARY_DIR}/libjsonrpccpp-client.pc)
43 CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/libjsonrpccpp-server.pc.cmake ${CMAKE_BINARY_DIR}/libjsonrpccpp-server.pc)
44@@ -223,6 +223,6 @@ INSTALL(FILES
45 "${CMAKE_BINARY_DIR}/libjsonrpccpp-server.pc"
46 "${CMAKE_BINARY_DIR}/libjsonrpccpp-client.pc"
47 "${CMAKE_BINARY_DIR}/libjsonrpccpp-common.pc"
48- DESTINATION "lib${LIB_SUFFIX}/${CMAKE_LIBRARY_PATH}/pkgconfig")
49+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
50
51
52diff --git a/src/stubgenerator/CMakeLists.txt b/src/stubgenerator/CMakeLists.txt
53index f9dbe4c..b57b0fe 100644
54--- a/src/stubgenerator/CMakeLists.txt
55+++ b/src/stubgenerator/CMakeLists.txt
56@@ -58,15 +58,15 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/cmake/libjsonrpccpp-stub.pc.cmake ${CMAKE_BIN
57
58 INSTALL(FILES
59 "${CMAKE_BINARY_DIR}/libjsonrpccpp-stub.pc"
60- DESTINATION "lib/${CMAKE_LIBRARY_PATH}/pkgconfig")
61+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
62
63 install(DIRECTORY ${CMAKE_SOURCE_DIR}/src/stubgenerator/
64 DESTINATION include/jsonrpccpp/stubgen
65 FILES_MATCHING PATTERN "*.h")
66
67 install(TARGETS ${ALL_LIBS} jsonrpcstub
68- LIBRARY DESTINATION lib${LIB_SUFFIX}/${CMAKE_LIBRARY_PATH}
69- ARCHIVE DESTINATION lib${LIB_SUFFIX}/${CMAKE_LIBRARY_PATH}
70+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
71+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
72 RUNTIME DESTINATION bin
73 )
74
75--
762.10.2
77
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorclient-Typecast-min-arguments-correctl.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorclient-Typecast-min-arguments-correctl.patch
deleted file mode 100644
index d21e97950..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorclient-Typecast-min-arguments-correctl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 9500f12f5d827840634311d6ca972d9551211e4d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 21 Nov 2016 01:00:51 -0800
4Subject: [PATCH] filedescriptorclient: Typecast min() arguments correctly
5
6Fixes
7
8| /mnt/a/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/jsonrpc/0.7.0-r0/git/src/jsonrpccp
9p/client/connectors/filedescriptorclient.cpp:47:92: note: deduced conflicting types for parameter 'co
10nst _Tp' ('unsigned int' and 'long unsigned int')
11| ssize_t byteWritten = write(outputfd, toSend.c_str(), min(toSend.size(), MAX_WRITE_SIZE));
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/jsonrpccpp/client/connectors/filedescriptorclient.cpp | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/jsonrpccpp/client/connectors/filedescriptorclient.cpp b/src/jsonrpccpp/client/connectors/filedescriptorclient.cpp
19index 77aac7e..6325b5c 100644
20--- a/src/jsonrpccpp/client/connectors/filedescriptorclient.cpp
21+++ b/src/jsonrpccpp/client/connectors/filedescriptorclient.cpp
22@@ -43,7 +43,7 @@ void FileDescriptorClient::SendRPCMessage(const std::string& message,
23 string toSend = message;
24 do
25 {
26- ssize_t byteWritten = write(outputfd, toSend.c_str(), min(toSend.size(), MAX_WRITE_SIZE));
27+ ssize_t byteWritten = write(outputfd, toSend.c_str(), min((long unsigned int)toSend.size(), MAX_WRITE_SIZE));
28 if (byteWritten < 1)
29 throw JsonRpcException(Errors::ERROR_CLIENT_CONNECTOR,
30 "Unknown error occured while writing to the output file descriptor");
31--
322.10.2
33
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorserver-Include-sys-select.h-before-oth.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorserver-Include-sys-select.h-before-oth.patch
deleted file mode 100644
index 3b9068a7d..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-filedescriptorserver-Include-sys-select.h-before-oth.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From c7aad10628949e126f50e3264b5bc7eb417347c6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 21 Nov 2016 01:25:10 -0800
4Subject: [PATCH] filedescriptorserver: Include sys/select.h before other
5 headers
6
7Fixes errors e.g.
8| /mnt/a/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/jsonrpc/0.7.0-r0/git/src/jsonrpccp
9p/server/connectors/filedescriptorserver.h:63:7: error: unknown type name 'fd_set'
10| fd_set read_fds;
11| ^
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/jsonrpccpp/server/connectors/filedescriptorserver.cpp | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp b/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
19index 9d74223..8e019ca 100644
20--- a/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
21+++ b/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
22@@ -7,8 +7,8 @@
23 * @license See attached LICENSE.txt
24 ************************************************************************/
25
26-#include "filedescriptorserver.h"
27 #include <sys/select.h>
28+#include "filedescriptorserver.h"
29 #include <sys/types.h>
30 #include <sys/stat.h>
31 #include <unistd.h>
32--
332.10.2
34
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-memset-and-family-needs-to-include-string.h.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-memset-and-family-needs-to-include-string.h.patch
deleted file mode 100644
index 21ef98bf5..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-memset-and-family-needs-to-include-string.h.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From f5416f1c2b2989f94163a2ae4b91c9b9fa13c620 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 31 Mar 2017 13:32:31 -0700
4Subject: [PATCH 1/2] memset() and family needs to include string.h
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/jsonrpccpp/server/connectors/unixdomainsocketserver.cpp | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/jsonrpccpp/server/connectors/unixdomainsocketserver.cpp b/src/jsonrpccpp/server/connectors/unixdomainsocketserver.cpp
12index 9fca57b..e63c49e 100644
13--- a/src/jsonrpccpp/server/connectors/unixdomainsocketserver.cpp
14+++ b/src/jsonrpccpp/server/connectors/unixdomainsocketserver.cpp
15@@ -16,7 +16,7 @@
16 #include <cstdio>
17 #include <fcntl.h>
18 #include <unistd.h>
19-#include <string>
20+#include <cstring>
21
22 using namespace jsonrpc;
23 using namespace std;
24--
252.12.1
26
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0002-Fix-build-problem-on-Mac.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0002-Fix-build-problem-on-Mac.patch
deleted file mode 100644
index aece45b02..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0002-Fix-build-problem-on-Mac.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 79050ef9607f242e0d509969b19e9390220c3411 Mon Sep 17 00:00:00 2001
2From: Yongwei Wu <wuyongwei@gmail.com>
3Date: Sat, 31 Dec 2016 11:57:11 +0800
4Subject: [PATCH 2/2] Fix build problem on Mac.
5
6__suseconds_t is not defined on Mac/BSD; use the POSIX-conformant
7suseconds_t.
8---
9 src/jsonrpccpp/server/connectors/filedescriptorserver.cpp | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp b/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
13index 8e019ca..68107f2 100644
14--- a/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
15+++ b/src/jsonrpccpp/server/connectors/filedescriptorserver.cpp
16@@ -122,7 +122,7 @@ int FileDescriptorServer::WaitForRead() {
17 FD_ZERO(&except_fds);
18 FD_SET(inputfd, &read_fds);
19 timeout.tv_sec = 0;
20- timeout.tv_usec = (__suseconds_t) (READ_TIMEOUT * 1000000);
21+ timeout.tv_usec = (suseconds_t) (READ_TIMEOUT * 1000000);
22 // Wait for something to read
23 return select(inputfd + 1, &read_fds, &write_fds, &except_fds, &timeout);
24 }
25--
262.12.1
27
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_0.7.0.bb b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_git.bb
index eb1ff65b6..aea11b082 100644
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_0.7.0.bb
+++ b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_git.bb
@@ -5,22 +5,16 @@ DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \
5HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp" 5HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp"
6 6
7LICENSE = "MIT" 7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee72d601854d5d2a065cf642883c489b" 8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e728c5b36018f6c383b4b9efd9c8840"
9SECTION = "libs"
10DEPENDS = "curl jsoncpp libmicrohttpd hiredis"
9 11
10PV = "0.7.0+git${SRCPV}" 12PV = "1.1.1+git${SRCPV}"
13# v1.1.1
14SRCREV = "319783c635cf8cabcc1a980495c99a88f9ebbd97"
11 15
12SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp \ 16SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp \
13 file://0001-cmake-replace-hardcoded-lib-CMAKE_LIBRARY_PATH-with-.patch \
14 file://0001-filedescriptorclient-Typecast-min-arguments-correctl.patch \
15 file://0001-filedescriptorserver-Include-sys-select.h-before-oth.patch \
16 file://0001-memset-and-family-needs-to-include-string.h.patch \
17 file://0002-Fix-build-problem-on-Mac.patch \
18 " 17 "
19SRCREV = "ccbdb41388bdd929828941652da816bf52a0580e"
20
21SECTION = "libs"
22
23DEPENDS = "curl jsoncpp libmicrohttpd"
24 18
25S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
26 20
@@ -30,3 +24,5 @@ EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO
30 -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \ 24 -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \
31 -DCMAKE_LIBRARY_PATH=${libdir} \ 25 -DCMAKE_LIBRARY_PATH=${libdir} \
32" 26"
27
28FILES_${PN}-dev += "${libdir}/libjson-rpc-cpp/cmake"