summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authoreu@felipetonello.com <eu@felipetonello.com>2016-05-03 16:20:23 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:25 +0200
commit3bae88a2ee7befdd5bff6e7002c5407f94eb720d (patch)
tree44c8fdc725449f339f6552c1dee9ed6b2e9f9756 /meta-oe/recipes-devtools
parenta78aebb60604dc8b65bd20926af38687feebbc8e (diff)
downloadmeta-openembedded-3bae88a2ee7befdd5bff6e7002c5407f94eb720d.tar.gz
protobuf: add protobuf-c recipe
replaces/obsoletes: commit 0d31f8448412 [Added protobuf-c criu dependency] in meta-virtualization This version of the recipe also adds a separated package for the compiler. Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf-c_1.2.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.2.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.2.1.bb
new file mode 100644
index 000000000..40fb96cf4
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.2.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11
12DEPENDS = "protobuf-native protobuf"
13
14PACKAGE_BEFORE_PN = "${PN}-compiler"
15RDEPENDS_${PN}-compiler = "protobuf-compiler"
16RDEPENDS_${PN}-dev += "${PN}-compiler"
17
18LIC_FILES_CHKSUM = "file://LICENSE;md5=235c3195a3968524dc1524b4ebea0c0e"
19SRC_URI = "https://github.com/protobuf-c/protobuf-c/archive/v${PV}.tar.gz"
20
21SRC_URI[md5sum] = "b884aeba4283309445a8e3b6e7322dd6"
22SRC_URI[sha256sum] = "2d708fb3c024b9e6e86df141faff802194f5db90a4b79e6d4aa6bd61dd983dd6"
23
24inherit autotools pkgconfig
25
26FILES_${PN}-compiler = "${bindir}"
27
28BBCLASSEXTEND = "native nativesdk"